none
Conexão Remota RDP no windows 8 demora para fazer "hand shake" RRS feed

  • Pergunta

  • Olá Boa tarde!

    Possuo algumas estações Windows 8 e faço acesso remoto em todas elas normalmente seja na lan ou na wan. O roteador está configurado e direcionando as portas para cada estação e o firewall também está configurado. Porém, uma das estações fica um tempo muito maior que as outras protegendo a conexão (cerca de 1 min) antes de iniciar. O que pode estar ocorrendo com esta estação?

    Grato,

    Andrei

    quarta-feira, 30 de outubro de 2013 10:22

Todas as Respostas

  • Olá Andrei, boa tarde!

    Você está em um domínio? Tenho o mesmo problema mas com diversos SO e não só com Windows 8. Já experimentou trocar o DNS primário das estações. Alguns dos meus problemas se resolveram com esta simples ação.

    terça-feira, 14 de janeiro de 2014 17:19
  • Boa tarde amigo,

    Veja o link abaixo que ele vai te ajudar:

    http://superuser.com/questions/515180/windows-8-server-2012-rdp-connection-is-slow

    Veja a threats abaixo:

    http://social.technet.microsoft.com/Forums/windows/en-US/e862b4a9-0613-4054-9e4f-ce7ee99ebec9/windows-8-slow-doing-rdp?forum=w8itprogeneral

    Algumas dicas:

    http://www.computing.net/answers/windows-8/remote-desktop-running-slow-on-windows-8/222.html


    Marcelo dos Santos Gonçalves

    Não se esqueça de “Marcar como Resposta” se resolveu seu problema. Caso foi útil algum link ou sugestão dê um voto na resposta.



    terça-feira, 14 de janeiro de 2014 17:24
  • Boa tarde Marcelo!

    Já efetuei os procedimentos citados nos links que você nos passou mas infelizmente nenhum deles resolveu efetivamento o problema. tenho estações que demoram até três minutos para se conectar ao host de destino e outras que levam 5 segundos para se conectar à este mesmo host. Já estou ficando sem alternativas. Agradeço sua ajuda.

    terça-feira, 14 de janeiro de 2014 18:19
  • Não desista amigo IT é legal pelos desafios, tenho algumas perguntas:

    1- A lentidão acontece em todas as máquinas Win8?

    2- A lentidão acontece nas máquinas em LAN ou WAN?

    3- Existem máquinas com acesso rápido e lento no meso local?

    terça-feira, 14 de janeiro de 2014 18:30
  • 1 - Tenho diversos sistemas Microsoft em meu ambiente. A lentidão ocorre de Win 7 e 8 para 2003 e 2008/2008 R2.

    2 - Ambos os locais. Mesmo com nosso TMG direcionando a conexão para portas específicas em nosso parceiros remotos o problema é apresentado.

    3- Sim, existem e isso que me deixa mais curioso. Tanto de maquinas com as mesmas configuração (hardware e software) quanto de maquinas cm configurações diferentes.

    Minha estrutura consiste em em um servidor Remote desktop Gateway stand alone (não optei por farm) que redireciona as conexões dos meus clients para os servidores. É utilizado um certificado de criptografia de 2048 bits. Toda a estrutura e regras de acesso são baseadas em meu domínio. tudo previamente testado pela minha equipe durante vários meses e seguindo as melhores práticas da Microsoft.

    Já tentei apontar para o meu RDG um único servidor de DNS julgando que poderias ser este o problema, uma vez que ele fazia pesquisas nos DNS de nossas filiais em outros estados, mas também não foi a solução definitiva.

    Mais alguma sugestão que deixei passar despercebida?

    terça-feira, 14 de janeiro de 2014 18:44
  • Miqueias,

    E os ativos? Existe algum switch cascateado no local?

    Achei algo interessante ... Faça o seguinte teste em uma máquina lenta:

    - Run a command prompt (cmd.exe) as an Administrator
    - Type: netsh interface tcp set global autotuninglevel=disabled
    Disable the autotunning feature in Vista completely, and fit and lock the RWIN receive window to default value 65536 bytes.

    If you want to to re-enable it:
    - Type: netsh interface tcp set global autotuninglevel=normal

    In some cases you may need to use this command in addition to the above, but I didn't have to:
    - Type: netsh interface tcp set global rss=disabled

    Update! This command makes your network connection EVEN FASTER
    Type: netsh interface tcp set global autotuninglevel=highlyrestricted



    Marcelo dos Santos Gonçalves

    Não se esqueça de “Marcar como Resposta” se resolveu seu problema. Caso foi útil algum link ou sugestão dê um voto na resposta.


    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    terça-feira, 14 de janeiro de 2014 18:54
  • Boa tarde.

    Não temos cascatas, apenas core. Um dos detalhes que me esqueci de mencionar é que a porta 3389 por padrão é bloqueada em meu dominio. 

    O problema persiste :/  Estas configurações não surtiram efeito. Continuo pesquisando mas não encontro nada conclusivo ou esclarecedor ou algo dê uma pista.

    quarta-feira, 15 de janeiro de 2014 15:59
  • Após a atualização do cliente RDP o problema foi solucionado. Agora uso a versão Windows 8.1 e a criptografia é maior, o que exige mais tempo para acesso, mas ficou igual para todas as estações. (cerca de 8s)

    Obrigado

    • Sugerido como Resposta Edinaldo Junior terça-feira, 10 de junho de 2014 11:43
    segunda-feira, 9 de junho de 2014 16:05