none
Outlook desconectando no Exchange 2007 RRS feed

  • Pergunta

  • Boa tarde pessoal,

    Estou com um problema, a mais ou menos 2 semanas, em meu ambiente com exchange server 2007. Todos os clientes de email outlook, independente de versão, estão se desconectando de meu servidor exchange e fica uma ampulheta no icontray do exchange onde aparece a requisição de dados do exchange server. Neste momento, o outlook simplesmente trava, fica congelado e alguns segundos/minutos depois aparece o balão dizendo que foi perdida a conexão com o exchange server. Algum tempo depois ele reconecta sozinho. Isto tem ocorrido várias vezes ao dia e principalmente em horário comercial. Já recorri a todos os KBs possiveis e imagináveis e não consegui descobri a causa raiz. Já desinstalei o antivirus, já reinstalei o office e nada. 

    Detalhe que este problema ocorre com mais frequência, quando o usuário possui um PST na máquina local. Mesmo executando um scan no pst não resolveu o problema. Notei também que quando o outlook trava, se eu for no icontray do outlook e mandar cancelar a requisição com o servidor ele destrava mas a conexão perde do mesmo jeito.

    Não consigo simular este problema no ambiente usando MAPI puro, apenas com o RPC/HTTP.

    Outro detalhe é o evento id 26 que ocorre sempre e é intermetente. As vezes a cada 6 minutos, as vezes demora 30... 

    Preciso de algum help...

    Abraços

    quarta-feira, 4 de novembro de 2015 20:50

Respostas

  • Olá WCCARDOSO,

    Bom dia!

    Desculpe a demora ao responder.

    Baseado nas informações que você me passou, faça os seguintes testes:

    -Selecione a opção "Conectar somente..."

    -Selecione "Em redes rápidas..."

    E verifique o comportamento do Outlook.

    Outra informação importante, mande os resultados dos seus Providers do Exchange Server, utilizando o comando Get-OutlookProvider

    Get-OutlookProvider

    Faça o teste usando a ferramenta Exchange Remote Connectivity Analyzer e nos informe o resultado.

    Abraços!


    Lenon Candido Sales



    sexta-feira, 6 de novembro de 2015 12:38
  • Boa tarde WCCARDOSO,

    É necessário que você realize a análise do seu ambiente.

    Mesmo que você faça a migração, ainda poderá ter problemas

    Veja esta documentação sobre o Exchange Server 2013, que irá lhe ajudar a entender.

    Ask the Perf Guy: Sizing Exchange 2013 Deployments

    Abraços!


    Lenon Candido Sales

    • Marcado como Resposta Cristopher C I_ quinta-feira, 12 de novembro de 2015 12:33
    segunda-feira, 9 de novembro de 2015 17:20

Todas as Respostas

  • Olá WCCARDOSO,

    Bom dia!

    Um ponto interessante é você verificar como que está a performance dos seus servidores.

    Por gentileza, me informe qual versão está o seu Exchange Server e quantos servidores CAS você tem instalado.

    Segue uma ferramenta que irá lhe ajudar a verificar performance nos servers

    Experfwiz (Exchange Performance Data Collection tool)


    Outra informação importante, execute este comando no seus servidores CAS e envie os resultados por gentileza

    Get-ClientAccessServer | foreach{get-counter "\netlogon(*)\semaphore timeouts" -ComputerName $_.name}

    Abraços!




    Lenon Candido Sales

    • Sugerido como Resposta Emanuella Clara quinta-feira, 5 de novembro de 2015 17:15
    • Marcado como Resposta Emanuella Clara quinta-feira, 5 de novembro de 2015 17:15
    • Não Marcado como Resposta Emanuella Clara quinta-feira, 5 de novembro de 2015 17:15
    quinta-feira, 5 de novembro de 2015 14:08
  • Bom dia Lenon,

    Primeiramente obrigado pela resposta..

    Então.. meu exchange server ainda é o 2007. Estou planejando migrar ainda para o 2013 mas não estou com recursos de hardware para isto ainda.

    Uma coisa que notei é que estes problemas ocorrem sempre em horário de muita concorrência. A noite é tranquilo pois não tem quase ninguem usando. Poderia ser algum problema de concorrência no RPC?

    Eu tenho apenas 1 servidor de CAS para atender.

    Quanto ao comando que você postou, não funcionou.

    A ferramenta lá deixei monitorando, mas aparentemente os gráficos estão bem tranquilos.

    Abraços


    quinta-feira, 5 de novembro de 2015 14:27
  • Olá WCCARDOSO,

    Executando o comando que informei anteriormente, ele deverá aparecer da seguinte forma, tente executar novamente e compartilhe conosco por favor.

    Ele mostra se você está tendo algum tipo de problema quando Exchange Server tenta atender as requisições.

    Por favor, veja a possibilidade de realizar a alteração conforme a documentação abaixo para ajudar a resolver o seu problema

    Many Outlook Anywhere Users Intermittently Lose Connectivity with Their Exchange Mailboxes at the Same Time

    Para que você possa entender como que funciona esta alteração dentro do ambiente, segue uma explicação neste documento.

    Modifying the Queue Length for Exchange App Pools in IIS

    Executando este procedimento, será necessário realizar o restart do IIS,  que poderá causar indisponibilidade para os seus usuários.

    Outras questões:

    - Acontece apenas com usuários internos?

    - O usuário final recebe alguma mensagem de erro?

    - Chegou a verificar se o Exchange apresenta alguma informação no Event Viewer quando ocorre o problema com os usuários? Se sim, mande para que nós possamos lhe ajudar a verificar.

    Abraços!


    Lenon Candido Sales

    • Sugerido como Resposta Emanuella Clara quinta-feira, 5 de novembro de 2015 17:16
    quinta-feira, 5 de novembro de 2015 17:12
  • Opa Lenon,

    Consegui executar:

    

    Quanto as suas questões:

    - Acontece apenas com usuários internos?

    R: Ocorre apenas com os usuários externos. Ou seja, apenas com quem usa o Outlook Anywhere.

    - O usuário final recebe alguma mensagem de erro?

    R: Geralmente o outlook trava e em seguida perde conexão com o servidor conforme imagem:

    - Chegou a verificar se o Exchange apresenta alguma informação no Event Viewer quando ocorre o problema com os usuários? Se sim, mande para que nós possamos lhe ajudar a verifica

    R: Os eventos ocorrem mais no cliente com evento id 26. No exchange reparei o seguinte:

    Process MSEXCHANGEADTOPOLOGY (PID=1980). When updating security for a remote procedure call (RPC) access for the Exchange Active Directory Topology service, Exchange could not retrieve the security descriptor for Exchange server object CORREIO6 - Error code=8007077f. 
     The Exchange Active Directory Topology service will continue with limited permissions

    Process MSEXCHANGEADTOPOLOGY (PID=1980). The site monitor API was unable to verify the site name for this Exchange computer - Call=DsctxGetContext Error code=8007077f. Make sure that Exchange server is correctly registered on the DNS server.

    Abraços e obrigado

    quinta-feira, 5 de novembro de 2015 17:36
  • Olá WCCARDOSO,

    Por favor, me mande um print destas configurações do Outlook do usuário.

    Vá em File > Account Settings > Account Setting > Select Account > Change > More Settings... > Connection Tab

    Sobre o outro procedimento que te passei antes, você não chegou a efetuar?

    Abraços!


    Lenon Candido Sales

    • Sugerido como Resposta Emanuella Clara sexta-feira, 6 de novembro de 2015 16:41
    quinta-feira, 5 de novembro de 2015 18:23
  • Segue tela:

    Quanto aos procedimentos relacionados ao IIS, realizei sim. Estou aguardando pra ver se tem algum efeito.

    Abraços


    quinta-feira, 5 de novembro de 2015 19:29
  • Olá WCCARDOSO,

    Bom dia!

    Desculpe a demora ao responder.

    Baseado nas informações que você me passou, faça os seguintes testes:

    -Selecione a opção "Conectar somente..."

    -Selecione "Em redes rápidas..."

    E verifique o comportamento do Outlook.

    Outra informação importante, mande os resultados dos seus Providers do Exchange Server, utilizando o comando Get-OutlookProvider

    Get-OutlookProvider

    Faça o teste usando a ferramenta Exchange Remote Connectivity Analyzer e nos informe o resultado.

    Abraços!


    Lenon Candido Sales



    sexta-feira, 6 de novembro de 2015 12:38
  • WCCARDOSO,

    além de todas as questões citadas pelo Lenon, como está a comunicação dos seus servidores com o AD ?

    existe mais de um DC? se sim, como está a replicação deles ?

    sexta-feira, 6 de novembro de 2015 13:05
  • Bom dia Lenon,

    Fiz o ajuste que você mencionou, embora já tenha testado antes.

    Segue resultado do comando get-outlookprovider:

    CertPrincipalName :
    Server            :
    TTL               : 1
    AdminDisplayName  :
    ExchangeVersion   : 0.1 (8.0.535.0)
    Name              : EXCH
    DistinguishedName : CN=EXCH,CN=Outlook,CN=AutoDiscover,CN=Client Access,CN=Firs
                        t Organization,CN=Microsoft Exchange,CN=Services,CN=Configu
                        ration,DC=unicrednne,DC=com,DC=br
    Identity          : EXCH
    Guid              : dd3e398e-227e-4157-868b-2454a24c8b71
    ObjectCategory    : unicrednne.com.br/Configuration/Schema/ms-Exch-Auto-Discove
                        r-Config
    ObjectClass       : {top, msExchAutoDiscoverConfig}
    WhenChanged       : 20/02/2008 16:31:29
    WhenCreated       : 20/02/2008 16:31:29
    OriginatingServer : DC.unicrednne.com.br
    IsValid           : True

    CertPrincipalName : none
    Server            :
    TTL               : 1
    AdminDisplayName  :
    ExchangeVersion   : 0.1 (8.0.535.0)
    Name              : EXPR
    DistinguishedName : CN=EXPR,CN=Outlook,CN=AutoDiscover,CN=Client Access,CN=Firs
                        t Organization,CN=Microsoft Exchange,CN=Services,CN=Configu
                        ration,DC=unicrednne,DC=com,DC=br
    Identity          : EXPR
    Guid              : ff9b01a5-1327-4b37-8ee3-8aa5593319c0
    ObjectCategory    : unicrednne.com.br/Configuration/Schema/ms-Exch-Auto-Discove
                        r-Config
    ObjectClass       : {top, msExchAutoDiscoverConfig}
    WhenChanged       : 05/12/2011 21:34:54
    WhenCreated       : 20/02/2008 16:31:29
    OriginatingServer : DC.unicrednne.com.br
    IsValid           : True

    CertPrincipalName :
    Server            :
    TTL               : 1
    AdminDisplayName  :
    ExchangeVersion   : 0.1 (8.0.535.0)
    Name              : WEB
    DistinguishedName : CN=WEB,CN=Outlook,CN=AutoDiscover,CN=Client Access,CN=First
                         Organization,CN=Microsoft Exchange,CN=Services,CN=Configur
                        ation,DC=unicrednne,DC=com,DC=br
    Identity          : WEB
    Guid              : 7ca8f224-26e7-408c-86ca-9bf3e99520e8
    ObjectCategory    : unicrednne.com.br/Configuration/Schema/ms-Exch-Auto-Discove
                        r-Config
    ObjectClass       : {top, msExchAutoDiscoverConfig}
    WhenChanged       : 20/02/2008 16:31:29
    WhenCreated       : 20/02/2008 16:31:29
    OriginatingServer : DC.unicrednne.com.br
    IsValid           : True

    Abraços

    sexta-feira, 6 de novembro de 2015 14:06
  • Olá Vinicius,

    Possui 3 DCs na minha rede. A replicação está ok. Algum comando que você precise ver resultados?

    Abraços

    sexta-feira, 6 de novembro de 2015 14:07
  • Olá WCCARDOSO,

    Obrigado pelo envio dos dados.

    No início você informou que tem apenas um CAS. Quantos usuários você tem atualmente que conectam no seu Exchange?

    Abraços!


    Lenon Candido Sales

    sexta-feira, 6 de novembro de 2015 18:04
  • Opa Lenon,

    Atualmente são 1600 caixas de email, mas 95% utiliza o OWA.

    Instalei outro CAS ontem para ver se resultava em melhora, mas continua do mesmo jeito.

    Abraços

    sexta-feira, 6 de novembro de 2015 19:46
  • WCCARDOSO,

    realmente 1600 caixa para somente um CAS ao meu ver é pouco, voce instalou outro e fez o balanceamento de carga ?

    o Exchange 2007 ainda usa afinidade e talvez se a carga não estiver balanceada os clientes ainda vão se conectar pelo mesmo servidor.

    você pode balancear essa carga via DNS load balance (round robin), com um NLB do windows ou o mais recomendado ( e mais caro) um HLB (hardware load balancer) de camada 7.


    sexta-feira, 6 de novembro de 2015 19:57
  • Olá WCCARDOSO,

    A recomendação é que você faça m sizing do seu ambiente para que as requisições sejam atendias para o seu usuário.

    Abaixo algumas informações importantes que podem lhe ajudar a entender e como poderá configurar o seu ambiente.

    As informações passadas pelo Vinícius são extremamente recomendadas.

    Load Balancing Exchange 2007 Client Access Servers using Windows Network Load-Balancing Technology – Part 1: Overview of Windows NLB Clusters

    Planning Processor Configurations

    Planning Memory Configurations

    High Availability

    CAS Load-Balancing Best Practices (Part 1)

    Abraços!


    Lenon Candido Sales

    sexta-feira, 6 de novembro de 2015 20:15
  • Bom dia pessoal,

    Obrigado pela ajuda de todos. Vou procurar ler os materiais e tentar fazer o balanceamento. Gostaria apenas de saber uma opinião a respeito de migração. Vocês acham que este problema seria sanado com uma migração do 2007 para o 2013?

    Abraços

    segunda-feira, 9 de novembro de 2015 14:41
  • Boa tarde WCCARDOSO,

    É necessário que você realize a análise do seu ambiente.

    Mesmo que você faça a migração, ainda poderá ter problemas

    Veja esta documentação sobre o Exchange Server 2013, que irá lhe ajudar a entender.

    Ask the Perf Guy: Sizing Exchange 2013 Deployments

    Abraços!


    Lenon Candido Sales

    • Marcado como Resposta Cristopher C I_ quinta-feira, 12 de novembro de 2015 12:33
    segunda-feira, 9 de novembro de 2015 17:20
  • Pessoal,

    Apenas a título de informação... algumas configurações que fiz que aparentemente surtiram efeito:

    1 - Alterar o tipo de autenticação do OutlookAnywhere para Basic ou invés de NTLM - Neste caso os usuários que estão com problema não estão em meu domínio e logo não precisam do NTLM

    2 - Desabilitar o SSL Offloading

    3 - Desabilitar o uso de Public Folders nos Outlooks, uma vez que não utilizo em meu ambiente

    Deste modo, no "Status de conexão" no ícone do Outlook que antes possuia 6 conexões ativas, agora só aparecem 3.

    O evento ID 26 parou de ocorrer.

    Estou monitorando pra ver se é uma solução definitiva.

    Obrigado


    Abraços

    quarta-feira, 11 de novembro de 2015 14:38
  • Bom dia WCCARDOSO.

    Marquei a resposta do Lenon para organização do Fórum, porem a thread seguirá aceitando comentários.

    Excelente quinta-feira.

    Abraços

    quinta-feira, 12 de novembro de 2015 12:35
  • Boa tarde Pessoal,

    Finalmente consegui instalar um ambiente de Coexistência do 2013 com o 2007. 

    Migrei 3 contas apenas do 2007 para o 2013. Mesmo assim os episódios de travamentos ainda ocorrem. Com menos frequência, mas ocorrem. Se eu tenho apenas 3 contas utilizando este novo ambiente, então o problema relacionado a carga no CAS pode ser desconsiderada, certo?

    Sinceramente não sei mais o que fazer. 

    Se houver mais alguma dica para dar, agradeço.

    Abraços

    quinta-feira, 19 de novembro de 2015 17:15