none
Fórmula Ano e mês do excel RRS feed

  • Pergunta

  • Bom dia, estou com uma dúvida, estava usando a fórmula SOMASES e coloquei os dados tudo, mas o critério que eu quero é que a soma seja feito somente no mês de julho/2010, eu queria saber como eu faço isso porque toda a vez que eu tento ele pega a data contando o dia. Como eu faço só para ele ler o mês e o ano?
    sexta-feira, 13 de agosto de 2010 12:10

Respostas

  • Rafael,

    veja se essa funciona:

    http://www.babooforum.com.br/forum/index.php?showtopic=559577

     


    Gilberto Soares Lopes
    sexta-feira, 13 de agosto de 2010 12:24
    Moderador
  • 1 - Na planilha Vendas Totais (Mensalmente), selecione o range B3:XFD3 e pressione Ctrl+1. Na guia Número selecione Personalizado e em Tipo digite mmmm. Em seguida, clique em  OK.

    2 - Escreva na célula B4 da planilha Vendas Totais (Mensalmente):

     

    =SOMARPRODUTO(--(MÊS('Saída de Materiais'!$C$3:$XFD$3)=MÊS(B$3));--('Saída de Materiais'!$C55:$XFD55))*--($A4='Saída de Materiais'!$A55)

    3 - Arraste a fórmula para toda a planilha.

    Nota: essa fórmula somará, por exemplo, valores de Julho/2010 e Julho/2011 porque o teste condicional leva em conta apenas o mês da data. Caso precise também diferenciar o ano, use:

    =SOMARPRODUTO(--(MÊS('Saída de Materiais'!$C$3:$XFD$3)=MÊS(B$3));--(ANO('Saída de Materiais'!$C$3:$XFD$3)=ANO(B$3));--('Saída de Materiais'!$C55:$XFD55))*--($A4='Saída de Materiais'!$A55)

     

    sexta-feira, 13 de agosto de 2010 23:23

Todas as Respostas

  • Rafael,

    veja se essa funciona:

    http://www.babooforum.com.br/forum/index.php?showtopic=559577

     


    Gilberto Soares Lopes
    sexta-feira, 13 de agosto de 2010 12:24
    Moderador
  • Não, porque eu não quero somar meses, quero que o mês (julho) seja o critério da soma, por exemplo:

     

    3/07/2010 - 4/7/2010 - 13/09/2010 - 18/07/2010

    12             -   13        -   15           -      2                

     

    Quero selecionar todas as datas, mas que ela só somasse os números referentes ao mês de julho de 2010. Que seria no caso do exemplo daria 27.

    sexta-feira, 13 de agosto de 2010 12:36
  • Rafael,

    se você selecionar ou definir somente o intervalo do mês terá esse resultado, mas acredito que não seja isso que você procura, se possível, por gentileza coloque uma parte do conteúdo da planilha aqui no fórum e informe qual célula tem que somar e de que forma.

    Visualizando a planilha fica mais fácil de entender.


    Gilberto Soares Lopes
    sexta-feira, 13 de agosto de 2010 13:19
    Moderador
  • [img]http://img831.imageshack.us/i/imagem1sa.jpg/[/img]

    [img]http://img23.imageshack.us/i/imagemraa.jpg/[/img]

     

    Você está vendo eu quero colocar o critério só para ele somar os valores referentes ao mês de julho de 2010 .

    sexta-feira, 13 de agosto de 2010 13:40
  • Rafael,

    nenhum dos dois links acima foram encontrados:

    404 Not Found


    nginx/0.7.64
    Gilberto Soares Lopes
    sexta-feira, 13 de agosto de 2010 15:05
    Moderador
  • http://img820.imageshack.us/i/imagembf.jpg/

     

    http://img836.imageshack.us/i/imagem1pz.jpg/

     

    tenta esses

    sexta-feira, 13 de agosto de 2010 15:17
  • 1 - Na planilha Vendas Totais (Mensalmente), selecione o range B3:XFD3 e pressione Ctrl+1. Na guia Número selecione Personalizado e em Tipo digite mmmm. Em seguida, clique em  OK.

    2 - Escreva na célula B4 da planilha Vendas Totais (Mensalmente):

     

    =SOMARPRODUTO(--(MÊS('Saída de Materiais'!$C$3:$XFD$3)=MÊS(B$3));--('Saída de Materiais'!$C55:$XFD55))*--($A4='Saída de Materiais'!$A55)

    3 - Arraste a fórmula para toda a planilha.

    Nota: essa fórmula somará, por exemplo, valores de Julho/2010 e Julho/2011 porque o teste condicional leva em conta apenas o mês da data. Caso precise também diferenciar o ano, use:

    =SOMARPRODUTO(--(MÊS('Saída de Materiais'!$C$3:$XFD$3)=MÊS(B$3));--(ANO('Saída de Materiais'!$C$3:$XFD$3)=ANO(B$3));--('Saída de Materiais'!$C55:$XFD55))*--($A4='Saída de Materiais'!$A55)

     

    sexta-feira, 13 de agosto de 2010 23:23
  • vlws funciono perfeito era isso mesmo^^
    segunda-feira, 16 de agosto de 2010 12:48