none
Erro instalação TollKit RRS feed

  • Pergunta

  • Boa tarde, tenho instalado o Visual Studio 2005, com o SQL 2005 que vem junto com o VS2005, e também o Manager Studio para criar scripts, preciso instalar o toolkit para desenvolver Reporting Service, tentei instalar este (http://www.microsoft.com/DownLoads/details.aspx?familyid=3C856B93-369F-4C6F-9357-C35384179543&displaylang=en
    ) mas  chega na parte Feature Selection que pede pra selecionar os componentes que serão instalados, mesmo que eu selecione todos os componentes ou não, ao dar o Next a proxima opção está desativada para habilitar e o no proximo Next ele me retorna o seguinte erro:

    "TÍTULO: Microsoft SQL Server Setup
    ------------------------------

    None of the selected features can be installed or upgraded. Setup cannot proceed since no effective change is being made to the machine. To continue, click Back and then select features to install. To exit SQL Server Setup, click Cancel.

    Para obter ajuda, clique em: http://go.microsoft.com/fwlink?LinkID=20476&ProdName=Microsoft+SQL+Server&ProdVer=9.00.2047.00&EvtSrc=setup.rll&EvtID=SQLSetup90&EvtType=28108

    ------------------------------
    BOTÕES:

    OK
    ------------------------------
    "

    Name: Microsoft SQL Server 2005 Tools Express Edition Reason: Your upgrade is blocked. For more information about upgrade support, see the "Version and Edition Upgrades" and "Hardware and Software Requirements" topics in SQL Server 2005 Setup Help or SQL Server 2005 Books Online. Language check: Your upgrade is blocked because of cross-language compatibility rules. For more information about cross-language support, see the Version and Edition Upgrades topic in SQL Server 2005 Setup Help or SQL Server 2005 Books Online.

    Obrigado!
    quinta-feira, 1 de outubro de 2009 18:45

Respostas

  • Oi Fábio... 

    as 2 mensagens de erro são bem auto explicativas: 

    Your upgrade is blocked because of cross-language compatibility rules. For more information about cross-language support, see the Version and Edition Upgrades topic in SQL Server 2005 Setup Help or SQL Server 2005 Books Online.

    a lingua do sql server express que está instalado e a do toolkit que você está tentando instalar são linguas diferentes. isso não é suportado. baixe o toolkit no mesmo idioma que o sql server express ou desinstale o sql server express

    Build version check:
    você já deve estar com algum service pack instalado e está tentando instalar uma versão mais antiga agora por cima... 

    minha sugestão: pra economizar tempo e esforço.... desinstale o client tools do sql express, roda a instalacao do toolkit e depois se necessário instale novamente os componentes que faltarem.. 

    abs,

    Felipe Ferreira
    http://weblogs.asp.net/felipeferreira
    MCT, MCITP, MCPD, 5X MCTS
    • Marcado como Resposta fabiojpoli quarta-feira, 14 de outubro de 2009 10:47
    sexta-feira, 9 de outubro de 2009 17:55

Todas as Respostas

  • Boa tarde Fábio

    As atualizações da sua máquina estão em dia? Se sim, qual a configuracão?




    Espero ter ajudado
    Anderson - DBA/MCP/MCTS/MCITP/MCT - Sua pergunta foi respondida ? Marque-a como tal! www.myspace.com/andersondpa
    quinta-feira, 1 de outubro de 2009 18:54
  • Não sei se estão em dia, acho que sim, é Win XP Dual core, 2GB de RAM...
    quinta-feira, 1 de outubro de 2009 18:58
  • Verifica se as atualizações estão em dia, acredito que seja este o seu problema



    Espero ter ajudado


    Anderson - DBA/MCP/MCTS/MCITP/MCT - Sua pergunta foi respondida ? Marque-a como tal! www.myspace.com/andersondpa
    quinta-feira, 1 de outubro de 2009 19:10
  • Oi Fabio,

    tente rodar o executável passando o parametro SKUUPGRADE=1, algum dos componentes que você deseja instalar já estão instalados e por isso a instalação bloqueia.. 

    a partir do executar da máquina: 
    start /wait c:\setup.exe SKUUPGRADE=1

    ou senão... desinstalar os componentes que estao instalados (client tools e management studio) para depois executar esse instalador, que no caso irá instalar novamente o management pra vc...


    abraço,

    Felipe Ferreira
    http://weblogs.asp.net/felipeferreira
    MCT, MCITP, MCPD, 5X MCTS
    quinta-feira, 1 de outubro de 2009 20:37
  • Fábio,

    Outro detalhe importante, faça uma limpeza no registro do seu Windows, utilizando ferramentas para limpeza, desta forma, você estará se certificando que o problema não esta relacionado com qualquer outra instalação.
    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    sexta-feira, 2 de outubro de 2009 01:04
    Moderador
  • Felipe, como posso fazer isso se não sou administrador e não tenho permissão para a instalação, o arquivo .exe por exemplo, tem opção de executar como... e inserir a senha do administrador.

    Junior, como posso fazer essa limpeza?

    Obrigado!
    sexta-feira, 2 de outubro de 2009 11:22
  • Não tem permissão de administrador? mas você tem a senha de administrador, correto? 
    você pode abrir o prompt de comando como administrador e então rodar o comando que eu passei.. ou entao qndo você executar esse comando ele deveria lhe pedir o usuario/senha...
    infelizmente você precisa ter permissao de administrador, senao nada feito..


    abraço,

    Felipe Ferreira
    http://weblogs.asp.net/felipeferreira
    MCT, MCITP, MCPD, 5X MCTS
    sexta-feira, 2 de outubro de 2009 11:36
  • Entrei como administrador, fiz a atualização do windows update, mas continua gerando o seguinte erro, estou com o Visual Studio 2005 Trial e SQL Server Express 2005.

    Obrigado!

    Name: Microsoft SQL Server 2005 Tools Express Edition
    Reason: Your upgrade is blocked. For more information about upgrade support, see the "Version and Edition Upgrades" and "Hardware and Software Requirements" topics in SQL Server 2005 Setup Help or SQL Server 2005 Books Online.

    Language check:
    Your upgrade is blocked because of cross-language compatibility rules. For more information about cross-language support, see the Version and Edition Upgrades topic in SQL Server 2005 Setup Help or SQL Server 2005 Books Online.

    Build version check:
    Your upgrade is blocked because the existing component is a later version than the version you are trying to upgrade to. To modify an existing SQL Server component, go to Add or Remove Programs in Control Panel, select the component you would like to modify, and then click Change/Remove.



    sexta-feira, 9 de outubro de 2009 17:50
  • Oi Fábio... 

    as 2 mensagens de erro são bem auto explicativas: 

    Your upgrade is blocked because of cross-language compatibility rules. For more information about cross-language support, see the Version and Edition Upgrades topic in SQL Server 2005 Setup Help or SQL Server 2005 Books Online.

    a lingua do sql server express que está instalado e a do toolkit que você está tentando instalar são linguas diferentes. isso não é suportado. baixe o toolkit no mesmo idioma que o sql server express ou desinstale o sql server express

    Build version check:
    você já deve estar com algum service pack instalado e está tentando instalar uma versão mais antiga agora por cima... 

    minha sugestão: pra economizar tempo e esforço.... desinstale o client tools do sql express, roda a instalacao do toolkit e depois se necessário instale novamente os componentes que faltarem.. 

    abs,

    Felipe Ferreira
    http://weblogs.asp.net/felipeferreira
    MCT, MCITP, MCPD, 5X MCTS
    • Marcado como Resposta fabiojpoli quarta-feira, 14 de outubro de 2009 10:47
    sexta-feira, 9 de outubro de 2009 17:55
  • Felipe,

    Acho que se ele instalar novamente o Tool Kits com o idioma correto, já vai resolver o problema.
    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    sábado, 10 de outubro de 2009 20:28
    Moderador
  • Buenas Junior!

    tem que fazer um teste, mas eu acredito que não por causa da mensagem: 
    Your upgrade is blocked because the existing component is a later version than the version you are trying to upgrade to.

    ou seja.. ele tem por exemplo o Service Pack 1 instalado do client components e tá tentando instalar usando o SKUPGRADE=1, que tenta atualizar os componentes... porém o instalador não pode atualizar a versão SP1 pra RTM por exemplo..

    mas vamos ver o que o Fábio nos diz após testar :)

    abraço

    Felipe Ferreira
    http://weblogs.asp.net/felipeferreira
    MCT, MCITP, MCPD, 5X MCTS
    sábado, 10 de outubro de 2009 21:28
  • Desinstalei o SQL Server, instalei o toolkit e reinstalei o SQL Server, aparentemente deu tudo certo, talvez hoje eu tente desenvolver algum relatório para teste. Obrigado pela ajuda pessoal. Abraços!
    quarta-feira, 14 de outubro de 2009 10:46
  • Fabio,

    Então não teve jeito, foi necessário reinstalar novamente.

    Ficamos no aguardo.
    Pedro Antonio Galvão Junior - MVP - Windows Server System - SQL Server/Coordenador de Projetos/DBA
    quarta-feira, 14 de outubro de 2009 13:03
    Moderador
  • Sim.

    Desinstalei o SQL Server, instalei o toolkit e reinstalei o SQL Server
    quarta-feira, 14 de outubro de 2009 14:01