none
Formulário InfoPath em Lista RRS feed

  • Pergunta

  • Olá, pessoal.

    Criei um formulário para que o usuário anônimo insira as informações (como formulário de contato) baseado em campos predefinidos em uma lista.

    Fiz a publicação e está funcionando. Inseri esse formulário como webpart em uma página do site, mas só consigo acessar se estiver logado, como anônimo dá erro:

    A página está configurada para permitir acesso anônimo.

    Estou utilizando Sharepoint 2013 Server e InfoPath 2013.

    Alguém pode me ajudar?


    • Editado Sheila Porto quinta-feira, 23 de março de 2017 03:29
    quinta-feira, 23 de março de 2017 03:20

Todas as Respostas

  • Boa tarde Sheila Porto

    Tudo bem contigo?

    Grato pela participação no Fórum Microsoft Technet.

    A quanto tempo este erro vem acontecendo?

    Atenciosamente,


    Guilherme Macedo S

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 23 de março de 2017 20:39
  • Bom dia, Guilherme Macedo.

    Tudo bem e você?

    O problema é recente pois estou começando a desenvolver neste mês. Tenho que criar alguns formulários para acesso anônimo mas gravando as informações em uma lista.

    Ativei alguns recursos do conjunto de sites e revisei as permissões.

    Um dos formulários(1) não faz qualquer tipo de alteração ou leitura em bibliotecas ou listas, mas foi criado por causa do recurso de views que precisava para exibir informações e este está funcionando depois dos ajustes feitos. Este formulário foi adicionado à uma página tipo "Página Wiki" e o adicionei como uma webpart.

    O outro é como um formulário(2) de contato que preciso gravar os dados em lista. Neste caso, associei o formulário à lista que passou a ser o padrão para registros novos dentro da lista. Para o acesso a este formulário, criei uma página de web parts e incluí como uma webpart.

    Esta página está com acesso anônimo configurado e consigo visualizar, mas a web part não abre, porém a lista está com permissão para "Usuários Anônimos" com permissão para "Adicionar Itens, Exibir Itens". Mesmo assim aparece essa mensagem acima.

    Tentei fazer o formulário(2) da mesma forma que o formulário(1), mas a webpart que aparece não é o que eu criei e sim o padrão da lista.

    Desde já agradeço.

    Att.

    sexta-feira, 24 de março de 2017 13:04