none
Instalações repetidas RRS feed

  • Pergunta

  • Boa tarde,

    O Auto push esta enviando o client do sccm varias vezes na mesma estação, isso começou depois que associe a estação a Boundaries, não sei se tem algum sentido.

    Exemplo, hoje em uma determinada estação o client foi instalado 5 vezes.

    CcmSetup is exiting with return code 0 ccmsetup 22/06/2015 07:44:42 3060 (0x0BF4)
    CcmSetup is exiting with return code 0 ccmsetup 22/06/2015 08:31:21 6220 (0x184C)
    CcmSetup is exiting with return code 0 ccmsetup 22/06/2015 09:15:11 6580 (0x19B4)
    CcmSetup is exiting with return code 0 ccmsetup 22/06/2015 10:06:46 7964 (0x1F1C)
    CcmSetup is exiting with return code 0 ccmsetup 22/06/2015 14:05:27 7380 (0x1CD4)

    Obs.: Não enviei a instalação manualmente, esta somente com o auto push.

    O que pode estar acontecendo ?

    segunda-feira, 22 de junho de 2015 18:18

Respostas

  • Ola Thiago,

    Faria algumas recomendacoes:

    Verifique suas boundaries, que tipo de boundaries voce esta usando? quantos computadores estao com este problema? Existe um padrao entre eles? Sistema Operacional, aplicacoes ou Features habilitadas? O que o CCM.log no seu servidor esta mostrando? Que tipo de configuracoes voce fez para aplicar o Client Push? O Cliente que continua a ser reinstalado, esta funcionando? Ele reporta corretamente?

    Pense no processo como um todo e fazer o troubleshoot to problema fica mais facil.

    Se o problema esta em somente um cliente, tente remover completamente, se for necessario use o ccmcleaner, e arquivo de configuracao do cliente em c:\windows\smscfg.ini

    Verifique os logs do cliente, existe algum outro problema? comunicacao com o cliente servidor? Se a instalacao for feita manualmente por linha de comando o problema ocorre tamebm?

    Tente entender o fluxo de instalacao do cliente por cliente push acredito que ira ajudar, abaixo alguns links que possam te ajudar.

    http://blogs.technet.com/b/systemcenterpt/archive/2011/07/28/configuration-manager-troubleshooting-flowcharts.aspx

    Um abraco

    Renato S Pacheco

    quarta-feira, 24 de junho de 2015 18:34
  • Opa,

    Abrimos um chamado com a microsoft e descobrimos que o problema que ocorreu conosco é um bug na aplicação e que já possui um chamado interno na microsoft para os desenvolvedores corrigir.

    Erro:
    Alguns clients estavam criando um tarefa no windows chamada "Configuration Manager Client Retry Task" que executava o comando "C:\Windows\ccmsetup\ccmsetup.exe" /runservice "/config:C:\Windows\ccmsetup\MobileClientUnicode.tcf" "/RetryWinTask:1" a cada 5 horas fazendo com que a reinstalação se iniciasse, porem no final ela não excluía a tarefa.

    A solução que adotamos foi remover essa tarefa utilizando o comando "schtasks.exe /Delete /TN "\Microsoft\Microsoft\Configuration Manager\Configuration Manager Client Retry Task" /F" aplicada via GPO ... resolveu o problema.

    Esse bug do SCCM esta sendo tratado com a equipe de produtos da Microsoft.

    Obrigado pelo apoio galera !!!!

    • Marcado como Resposta Thiago Rufino quinta-feira, 2 de julho de 2015 00:06
    quinta-feira, 2 de julho de 2015 00:06

Todas as Respostas

  • Boa tarde, o Auto push com o usuário administrador vai tentar instalar o cliente em todos os computadores que vc adicionou no Dominio. A configuração é essa. Caso deseja instalar manualmente desmarque a opção auto push.

    De uma conferida aqui

    http://prajwaldesai.com/install-configuration-manager-clients-using-client-push/

    Espero ter ajudado. Se útil, por favor classifique


    João Carlos Xavier de Macedo Specialist Platforms Microsoft MCP,MCT,MCSA,MCTS,MCITP, ENTERPRISE VIRTUALIZATION WINDOWS SERVER 2008 R2,MCSE WINDOWS SERVER 2012

    segunda-feira, 22 de junho de 2015 19:12
  • Boa tarde João,

    Estou utilizando somente o auto push, o mais estranho é as instalações repetidas ... mesmo eu instalando o manualmente e quando o auto push ta ativado ele não verifica se já instalado ? No meu caso instalou 5x no dia, e somente utilizando o auto push.

    verifiquei as configurações conforme o link enviado, as minhas estão ok.

    Esse incidente começou a ocorrer depois que associei o range dessa localidade em uma determinada boudaries, teria algo relacionado ?

    segunda-feira, 22 de junho de 2015 19:26
  • Thiago..realmente não e comum. Caso seja em um computador só, remova todas as instalações dos clientes e deixe a ferramenta instalar novamente automaticamente.


    João Carlos Xavier de Macedo Specialist Platforms Microsoft MCP,MCT,MCSA,MCTS,MCITP, ENTERPRISE VIRTUALIZATION WINDOWS SERVER 2008 R2,MCSE WINDOWS SERVER 2012

    terça-feira, 23 de junho de 2015 16:43
  • Ola Thiago,

    Faria algumas recomendacoes:

    Verifique suas boundaries, que tipo de boundaries voce esta usando? quantos computadores estao com este problema? Existe um padrao entre eles? Sistema Operacional, aplicacoes ou Features habilitadas? O que o CCM.log no seu servidor esta mostrando? Que tipo de configuracoes voce fez para aplicar o Client Push? O Cliente que continua a ser reinstalado, esta funcionando? Ele reporta corretamente?

    Pense no processo como um todo e fazer o troubleshoot to problema fica mais facil.

    Se o problema esta em somente um cliente, tente remover completamente, se for necessario use o ccmcleaner, e arquivo de configuracao do cliente em c:\windows\smscfg.ini

    Verifique os logs do cliente, existe algum outro problema? comunicacao com o cliente servidor? Se a instalacao for feita manualmente por linha de comando o problema ocorre tamebm?

    Tente entender o fluxo de instalacao do cliente por cliente push acredito que ira ajudar, abaixo alguns links que possam te ajudar.

    http://blogs.technet.com/b/systemcenterpt/archive/2011/07/28/configuration-manager-troubleshooting-flowcharts.aspx

    Um abraco

    Renato S Pacheco

    quarta-feira, 24 de junho de 2015 18:34
  • Tiago,

    Conseguiu resolver o problema?

    sexta-feira, 26 de junho de 2015 12:33
  • Opa,

    Abrimos um chamado com a microsoft e descobrimos que o problema que ocorreu conosco é um bug na aplicação e que já possui um chamado interno na microsoft para os desenvolvedores corrigir.

    Erro:
    Alguns clients estavam criando um tarefa no windows chamada "Configuration Manager Client Retry Task" que executava o comando "C:\Windows\ccmsetup\ccmsetup.exe" /runservice "/config:C:\Windows\ccmsetup\MobileClientUnicode.tcf" "/RetryWinTask:1" a cada 5 horas fazendo com que a reinstalação se iniciasse, porem no final ela não excluía a tarefa.

    A solução que adotamos foi remover essa tarefa utilizando o comando "schtasks.exe /Delete /TN "\Microsoft\Microsoft\Configuration Manager\Configuration Manager Client Retry Task" /F" aplicada via GPO ... resolveu o problema.

    Esse bug do SCCM esta sendo tratado com a equipe de produtos da Microsoft.

    Obrigado pelo apoio galera !!!!

    • Marcado como Resposta Thiago Rufino quinta-feira, 2 de julho de 2015 00:06
    quinta-feira, 2 de julho de 2015 00:06
  • Rufino, seu retorno é muito importante pois pode ajudar futuros colega.

    Qual o próximo passo depois que a Microsoft corrigir o problema? Irão enviar um patch de correção?

    quinta-feira, 9 de julho de 2015 20:51
  • Sim, a correção sairá em breve :)
    sexta-feira, 10 de julho de 2015 00:36