none
Função SE composta + Localizar RRS feed

  • Pergunta

  • Olá pessoal,

    Estou tentando fazer uma função mas não estou conseguindo...

    O caso é o seguinte:

    COLUNA A - Contém a OU dos equipamentos no AD (ex. MeuDominio\Clients\Desktop)

    Porem, os equipamentos são diversos, e estão em OUs diferentes (Desktop, Notebook, Produção).

    O que eu quero fazer é:

    Na COLUNA B - Exibir o tipo de equipamento...

    Eu tentei fazer isso: =SE(LOCALIZAR("Desktop";A2);"Desktop";SE("Notebook";A2);"Notebook";"PROD")

    Mas não funcionou :\

    Alguém tem ideia de como devo fazer essa função corretamente?

    Obrigado desde já!

    terça-feira, 8 de março de 2016 12:39

Respostas

  • Bem... dpois de mto pesquisar, encontrei isso e funcionou...rs

    =SE(ARRUMAR(DIREITA(A2;NÚM.CARACT(A2)-LOCALIZAR("@"; SUBSTITUIR(A2;"\";"@";(NÚM.CARACT(A2)-NÚM.CARACT(SUBSTITUIR(A2;"\";"")))/NÚM.CARACT("\")))))="Desktop";"Desktop";(SE(ARRUMAR(DIREITA(A2;NÚM.CARACT(A2)-LOCALIZAR("@"; SUBSTITUIR(A2;"\";"@";(NÚM.CARACT(A2)-NÚM.CARACT(SUBSTITUIR(A2;"\";"")))/NÚM.CARACT("\")))))="Notebook";"Notebook";(SE(ARRUMAR(DIREITA(A2;NÚM.CARACT(A2)-LOCALIZAR("@"; SUBSTITUIR(A2;"\";"@";(NÚM.CARACT(A2)-NÚM.CARACT(SUBSTITUIR(A2;"\";"")))/NÚM.CARACT("\")))))="Servers";"Servers";(SE(ARRUMAR(DIREITA(A2;NÚM.CARACT(A2)-LOCALIZAR("@"; SUBSTITUIR(A2;"\";"@";(NÚM.CARACT(A2)-NÚM.CARACT(SUBSTITUIR(A2;"\";"")))/NÚM.CARACT("\")))))="NoGPO";"PROD";"PROD")))))))

    • Marcado como Resposta Erick.Miranda sexta-feira, 11 de março de 2016 12:26
    sexta-feira, 11 de março de 2016 12:26