none
Erro 0x80073701 RRS feed

  • Pergunta

  • Senhores(as), boa noite!

    Tenho na empresa um servidor com Windows Server 2016 em inglês.

    Quando tento instalar uma nova função, aparece a seguinte mensagem de erro:

    The request to add or remove features on the specified server failed.

    Installation of one or more roles, role services, or features failed.

    The referenced assembly could not be found. Error: 0x80073701

    Alguém pode me ajudar a resolver este problema?

    Obrigado,

    Rogério


    • Editado IgorFKModerator terça-feira, 24 de julho de 2018 13:02 once -> one | note -> not
    terça-feira, 24 de julho de 2018 00:49

Respostas

  • Igor e Renato, bom dia.

    Com a dica do Igor e com mais um post que encontrei (https://community.spiceworks.com/topic/1974434-server-2016-unable-to-add-roles-or-features-after-making-server-a-domain-control), consegui resolver o problema.

    Neste post a pessoa informa que encontrou uns apontamentos para o Pacote de Linguagens em Francês. Que deletou todas as entradas no registro [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageDetect] e que após isso, conseguiu instalar as roles e features.

    No meu caso encontrei entradas em Espanhol, Francês, Japonês e alguns em Coreano.

    Após deletar as entradas, fiz um teste e consegui instalar como exemplo, o serviço de backup.

    Obs.: Agora vou tentar descobrir a causa do problema.

    Obrigado,

    Rogério
    quinta-feira, 26 de julho de 2018 11:35

Todas as Respostas

  • Bom dia Rogério, tudo bem?

    Você pode tentar solucionar o problema inicialmente executando alguns comandos que verificam a integridade dos arquivos do sistema, como:

    • sfc /scannow
    • dism /online /cleanup-image /restorehealth

     

    Bem como buscando por atualizações do sistema.

    Se nenhum dos passos acima solucionar o problema, você pode analisar o log CBS.log, disponível em %windir%\Logs\CBS\. Se achar algo fora do normal, uma entrada sobre algum componente do sistema que não esteja instalado, localize registros sobre o mesmo no regedit.exe e apague-os. Após isso as instalações deverão funcionar.

    Atenciosamente, 


    Igor F. Kunrath

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    Technet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.



    terça-feira, 24 de julho de 2018 12:42
    Moderador
  • Igor, bom dia.

    Tudo bem e com você?

    Tenho apenas uma dúvida.

    Posso rodar estes comandos com o servidor em produção?

    Pergunto pois ele é o nosso File Server.

    Corre o risco de reinicializar o servidor?

    Obrigado,

    Rogério

    quarta-feira, 25 de julho de 2018 14:35
  • Tudo certo! 

    Sim, você pode executar estes comandos sem problema, pois eles apenas escaneiam o sistema, suas operações não requerem inicialização.

    Boa sorte!


    Igor F. Kunrath

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    Technet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quarta-feira, 25 de julho de 2018 18:38
    Moderador
  • Igor, boa noite!!!

    Realizei o procedimento que você me passou, mas infelizmente não resolveu o problema.]

    • sfc /scannow
    • dism /online /cleanup-image /restorehealth
    • atualização do Windows (Windows UpDate)

            - 2018-07 Cumulative Update for Windows Server 2016 for x64-based Systems (KB4338814)

            - 2018-07 Cumulative Update for Windows Server 2016 for x64-based Systems (KB4338822)

    Tem mais alguma dica?

    Obrigado,

    Rogério

    quinta-feira, 26 de julho de 2018 01:41
  • Olá Rogério Casemiro,

    Esse erro geralmente é causado por causa de pacotes de linguagem extras instalados no sistema. Revise os pacotes instalados e remova-os caso necessário.

    Dê <g class="gr_ gr_23 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="23" id="23">uma</g> <g class="gr_ gr_26 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling" data-gr-id="26" id="26">olhada</g> <g class="gr_ gr_27 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling" data-gr-id="27" id="27">nesse</g> link. Talvez <g class="gr_ gr_24 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="24" id="24">possa</g> <g class="gr_ gr_25 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="25" id="25">lhe</g> auxiliar:

    How to resolve the error 0x80073701(ERROR_SXS_ASSEMBLY_MISSING) when you are installing a service pack or update

    Se o <g class="gr_ gr_44 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="44" id="44">problema</g> <g class="gr_ gr_51 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling" data-gr-id="51" id="51">continuar</g>, <g class="gr_ gr_71 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="71" id="71">somente</g> um in-place upgrade para resolver o <g class="gr_ gr_169 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="169" id="169">problema</g>.


    • Editado Renato Godois quinta-feira, 26 de julho de 2018 03:21 Ortografia
    quinta-feira, 26 de julho de 2018 03:19
  • Igor e Renato, bom dia.

    Com a dica do Igor e com mais um post que encontrei (https://community.spiceworks.com/topic/1974434-server-2016-unable-to-add-roles-or-features-after-making-server-a-domain-control), consegui resolver o problema.

    Neste post a pessoa informa que encontrou uns apontamentos para o Pacote de Linguagens em Francês. Que deletou todas as entradas no registro [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageDetect] e que após isso, conseguiu instalar as roles e features.

    No meu caso encontrei entradas em Espanhol, Francês, Japonês e alguns em Coreano.

    Após deletar as entradas, fiz um teste e consegui instalar como exemplo, o serviço de backup.

    Obs.: Agora vou tentar descobrir a causa do problema.

    Obrigado,

    Rogério
    quinta-feira, 26 de julho de 2018 11:35
  • Rogério, boa tarde. Estou com mesmo problema. como vc fez para deletar essas entradas. Poderia me ajudar por favor? tentei deletar mas aparece a mensagem. "Erro ao excluir todos os valores especificados. "
    quinta-feira, 26 de setembro de 2019 18:15
  • Rogério, boa tarde. Estou com mesmo problema. como vc fez para deletar essas entradas. Poderia me ajudar por favor? tentei deletar mas aparece a mensagem. "Erro ao excluir todos os valores especificados. "
    Também recebo essa mesma mensagem de erro, alguém tem alguma sugestão?
    sexta-feira, 10 de janeiro de 2020 18:52
  • Boa noite vc consegui resolver esse problema estou com esse erro quando estou tentador instalar o recurso do terminal server no windows server 2016.
    quarta-feira, 17 de junho de 2020 22:37