none
Permissão de acesso para grupo de usuário não funciona RRS feed

  • Pergunta

  • Bom dia,

    .

    Na aba de segurança de uma pasta compartilhada, defino permissões pra grupos de usuários, porém essa permissão não é obedecida. De tal forma que apenas o grupo "USERS" como um todo seja o controlador. 

    .

    Por exemplo: Na pasta, tenho as permissões para o grupo USERS como apenas listar o conteúdo das pastas e outro grupo FINANCEIRO com controle total. Os usuários do grupo FINANCEIRO não conseguem abrir os arquivos, dá acesso negado, podendo abrir os arquivos apenas quando libero o grupo USERS. Caso eu adicione os usuários (um a um) no grupo de segurança com controle total, funciona como deveria. Porém, com os grupos está complicado.

    .

    Alguma luz? kkkk

    sexta-feira, 7 de julho de 2017 13:38

Respostas

Todas as Respostas

  • Tente aplicar as permissões marcando a opção para substituir as permissões para objetos filhos.

    AT+

    sexta-feira, 7 de julho de 2017 14:12
  • Tente aplicar as permissões marcando a opção para substituir as permissões para objetos filhos.

    AT+

    Bom que agora um grupo de teste que criei funciona, mas quando coloco o grupo de Financeiro, não! 

    E não há negação nenhuma pra sobrepor... Tipo, coloquei as mesmas permissões pra um grupo de teste, funcionou beleza! Aí fui testar com o grupo do financeiro, coloquei o usuário no grupo e só troquei as permissões na pasta, tirando o grupo de teste e colocando o financeiro. Dá acesso negado pra tudo!

    .


    sexta-feira, 7 de julho de 2017 15:06

  • Pode ser que tenha alguma permissão herdada interferindo.

    Se não houver problema você pode "zerar" as permissões herdadas.

    Vá em Segurança > Avançadas > Alterar permissões...

    Desmarque Incluir Permissões Herdáveis... e na tela de Alerta, Adicionar.

    Monte sua lista de permissões e marque Substituir todas as permissões...

    Obs.:
    Caso ainda ocorra erro, talvez seja necessário ir primeiramente na aba Proprietário e tomar para si a propriedade da pasta e marcar em Substituir o proprietário, dar OK em tudo e iniciar procedimento anterior.

    sexta-feira, 7 de julho de 2017 15:12

  • Pode ser que tenha alguma permissão herdada interferindo.

    Se não houver problema você pode "zerar" as permissões herdadas.

    Vá em Segurança > Avançadas > Alterar permissões...

    Desmarque Incluir Permissões Herdáveis... e na tela de Alerta, Adicionar.

    Monte sua lista de permissões e marque Substituir todas as permissões...

    Obs.:
    Caso ainda ocorra erro, talvez seja necessário ir primeiramente na aba Proprietário e tomar para si a propriedade da pasta e marcar em Substituir o proprietário, dar OK em tudo e iniciar procedimento anterior.

    Cara, primeiro, não encontrei a opção "Incluir Permissões Herdáveis..." tirei um print, mas não posso fazer upload pela conta não ser verificada =/

    .

    Enfim, agora que voltei do almoço, fui testar e a pasta pegou as permissões do jeito que eu tinha deixado. Parece que é questão de tempo (?) como se as permissões para os grupos demorasse a ser efetivada para os usuários, já que sem alteração alguma a pasta passou a funcionar do jeito esperado. Foi aí que decidi testar novamente em outra pasta. Com o grupo financeiro funciona, mas se eu fizer com outro grupo, demora. 

    .

    PS: mesmo na pasta que passou a funcionar, quando testo com outro grupo, ela não pega as permissões.

    .

    Eu to ficando louco!!! kkk

    sexta-feira, 7 de julho de 2017 17:22
  • Boa tarde,

    Tente efetuar o cmdlet gpupdate /force, e veja se aplica as permissões.

    Atenciosamente,


    Guilherme Macedo S

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 10 de julho de 2017 16:09
  • Boa tarde,

    Tente efetuar o cmdlet gpupdate /force, e veja se aplica as permissões.

    Atenciosamente,


    Guilherme Macedo S

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    Executei e nada aconteceu, continua com o erro.

    .

    Porém, ao executar o GPRESULT /R, vejo que o usuário não está aplicando os grupos definidos. Ex: ao reiniciar a máquina (não todas as vezes) o usuário entra nos grupos definidos no AD, mas ao dar o GPUPDATE /FORCE, ele não entra!

    .

    Portanto os grupos funcionam, o que não está de acordo é a atualização dos grupos de segurança nas máquinas. Alguma sugestão?

    segunda-feira, 10 de julho de 2017 20:50
  • contas de usuários identificam novos grupos após efetuar logoff/logon e o AD consultado no processo de logon já tenha a replicação da informação. Contas de computadores identificam que são membros de novas inserções em grupos durante a inicialização do servidor/estação.


    Se quiser derrubar uma árvore na metade do tempo, passe o dobro do tempo amolando o machado.

    segunda-feira, 10 de julho de 2017 22:19
    Moderador
  • contas de usuários identificam novos grupos após efetuar logoff/logon e o AD consultado no processo de logon já tenha a replicação da informação. Contas de computadores identificam que são membros de novas inserções em grupos durante a inicialização do servidor/estação.


    Se quiser derrubar uma árvore na metade do tempo, passe o dobro do tempo amolando o machado.

    Tem como isso ficar instantâneo? 

    Tipo, no que eu alterar o grupo do usuário ele replicar imediatamente?

    .

    Grato

    terça-feira, 11 de julho de 2017 11:55
  • Caso a replicação dos ADs ( se houver mais do que 1) estiver funcionando corretamente, é um processo quase que instantâneo, mas ainda a conta tem que verificar que faz parte dos grupos onde você aplicou as permissões.

    pelo comando echo %logonserver% você identifica qual logon server esta consultando.

    você pode rodar o comando net user nome_de_usuario /domain e analisar quais grupos o usuário faz parte.

     

    Se quiser derrubar uma árvore na metade do tempo, passe o dobro do tempo amolando o machado.


    terça-feira, 11 de julho de 2017 16:21
    Moderador
  • Esta thread é duplicada !

    Sendo assim recomendamos você acompanhar as respostas em apenas uma thread.

    Segue link para continuarmos os estudos para a solução:

    https://social.technet.microsoft.com/Forums/pt-BR/winsrv2008pt/thread/2ad57e22-d0cd-4210-a40f-431bba079f14?clickjack-buster-key=48d1bf59-34e8-4212-96fd-cdc0aea2a146

    Esta thread esta encerrada !

    Agradeço pela compreensão

    Atenciosamente,


    Guilherme Macedo S

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quarta-feira, 12 de julho de 2017 13:05