none
Problemas com a fila de impressão em uma impressora de rede RRS feed

  • Pergunta

  •  

    Tenho uma multifuncional HP7310 com ip fixo.

    Todas as máquinas da rede (sistemas XP Professional sp2 e Vista Premium) conseguem acessar a página web deste ip.

    Todas conseguem escanear ou copiar na printer, ou seja, não há problema de comunicação.

    Todas as contas de tipo administrador conseguem imprimir nesta printer.

     

    Problema:

    As contas tipo "acesso limitado" recebem a mensagem "error printing" ao enviar documentos para a fila de impressão desta printer; o documento fica na fila com esta mensagem e não imprime;

     

    Comentários:

    - ao resetar a máquina, eventualmente, após um bom tempo, a impressão sai

    - enviar o mesmo documento para outra impressora da rede, imprime sem problemas, ou seja, aparentemente a fila funciona bem

    - tentei desinstalar o software da impressora em todas as máquinas da rede e reinstalá-lo, sem sucesso

    - tentei compartilhar o diretório windows/system32/spool para Todos, sem sucesso

    - tentei limpar, no registro, a existência de impressoras anteriores, sem sucesso

    - alterei temporariamente o tipo de conta para administrador e imprime sem problemas, mas não posso manter este tipo

    - não posso pedir para enviar diretamente para a impressora, as filas são muito utilizadas

     

    O ambiente funcionou sem problemas até que foi necessário alterar o nome do grupo de trabalho na rede e a impressora deixou de ser reconhecida pela rede. Ao refazer a instalação, apareceu esta característica.

     

    Alguém pode sugerir uma solução?

    Antecipadamente agradeço.

     

    Josi Perez

    terça-feira, 8 de janeiro de 2008 14:45

Respostas

Todas as Respostas

  • Josi....como recurso paleativo, quando alguma impressão ficar "presa", reinicie o serviço de "Print Spooler"...

     

    Atualize o Driver da impressora.

    Atualize o Sistema Operacional.

    Verifique se existem log´s reportando o erro.

     

    Att.

     

     

    Se a resposta ajudou,marque-a para facilitar a pesquisa.

     

     

    terça-feira, 8 de janeiro de 2008 16:33
  • Josi

    Procure no event view do windows e post aqui o log de sistema.

    Procure o erro Event ID no momento da impressão.

    Isso ajudará bastante.

     

     

    Abraços

     

    terça-feira, 8 de janeiro de 2008 19:59
  • Voce pode monitorar o driver da HP com as ferramentas regmon (monitor de registro) e filemon (monitor de arquivos) para tentar identificar possivel causas

     

    http://technet.microsoft.com/pt-br/sysinternals/default(en-us).aspx

     

    Aki tem uma possivel solução, testa ai e nos fala,

    se houver algum evento relacinado registrado no windows passa tb Smile

    http://microsoft-personal-operating-systems.hostweb.com/TopicMessages/microsoft.public.windowsxp.print_fax/849080/1/Default.aspx

     

    terça-feira, 8 de janeiro de 2008 20:30
  • Agradeço a todos que enviaram sugestões.

    Acabei encontrando uma dica na Internet e funcionou: vou escreve-la aqui - quem sabe possa resolver o problema de mais alguém.

     

    A solução consiste em alterar o nome da impressora pelo seu número IP.

    Em Painel de Controle, Impressoras, clicar com o botão direito em Propriedades, selecionar a guia Portas, selecionar a porta utilizada pela impressora e clicar em Configurar Porta, alterar o campo Nome da Impressora pelo número IP associado à printer.

    sábado, 19 de janeiro de 2008 16:25
  • O link

    http://microsoft-personal-operating-systems.hostweb.com/TopicMessages/microsoft.public.windowsxp.print_fax/849080/1/Default.aspx

    tem a solução que resolveu o problema: consiste em alterar o nome da impressora pelo seu número IP.

     

    Agradeço a todos que enviaram sugestões.

     

    sábado, 19 de janeiro de 2008 16:32
  • Estou passando exatamente pelo mesmo problema, exeto com um parâmetro diferente. Nossa impressora é uma HP Laser 1020 e esta instalada via USB em uma máquina da rede.

    Os administradores imprimem normalmente porém os usuários limitados ficam com a impressão presa na fila e não imprime nunca, a não ser que a máquina seja reiniciada.

     

    Se alguém puder me ajudar agradeço muito.

     

    Denis

     

    quinta-feira, 20 de março de 2008 17:17
  • Denis,

     

    Essas impresoras 1020, 1022, 1022n/w, são horriveis, aqui na nossa empresa temos umas 4 impressoras dessas, já passei por esse problema, então talves eu possa te ajudar, vamos lá:

     

    - nestes usuários limitados instale a impressora como local, com a porta LPT e não faça teste de impressão enm compartilhe ela.

    -vá nas configurações desta impressora e adcione um porta Standart TCP/IP, e defina ela com o ip da impressora.

     Fazendo isso uma a uma funcionou, mas lembrando que não instale ela através do software do cd, instale o driver, depois faça a instalação da mesma utilizando os drivers do windows.(instale o driver da impressora modelo local e não de rede)

     

    Espero ter ajudado em algo.

     

    Att,

     

    Felipe Flórido.

     

    quinta-feira, 20 de março de 2008 17:53
  • E se isso não funcionar faça o seguinte:

    Execute no DOS esse comando em cada maquina:

     

    1. Clique no menu Iniciar > Executar > digite: cmd [Enter];
    2. net stop spooler [Enter];
    3. cd %systemroot%\system32\spool\PRINTERS [Enter];
    4. del /f /s *.SHD [Enter];
    5. del /f /s *.SPL [Enter];
    6. net start spooler [Enter];
    7. exit [Enter].

     

     

    Att,

     

     

    Felipe Flórido.

    quinta-feira, 20 de março de 2008 18:10
  • Favor marcar a resposta!!!

    quinta-feira, 20 de março de 2008 19:37
  • Problema resolvido. Fiz o que vc explicou mas de uma forma diferente. Fiz um arquivo *.bat com as configutrações citadas. Executei e o problema foi resolvido.

     

    Quem precisar fazer igual é só copiar os dados abaixo:

     

    net stop spooler
    cd %systemroot%\system32\spool\PRINTERS
    del /f /s *.SHD
    del /f /s *.SPL
    net start spooler
    exit

     

    depois colar no bloco de notas(notepad) e salvar. Depois altere a extensão de txt para bat.

     

    é só executar e pronto.

     

    Agradeço a todos.

    quinta-feira, 20 de março de 2008 22:33
  • Bom dia,

    Nesse caso se vc tiver outra impressora igual a essa q apresenta lentidao, vc poderá redirecionar os documentos q estao na fila para outra porta utilizando uma porta IP.

    Espero ter ajudado

    Nilson Leite
    segunda-feira, 24 de março de 2008 12:53
  • Pessoal, vê se pode me ajudar....

     

    Meu problema é mais ou menos o seguinte.  Tenho uma rede com DHCP, DNS, WINS, tudo em modo automático, afinal de contas administração não é para criar problema e sim solucionar.

     

    Bom o caso é aprecido com o do nosso amigo da laserjet 1020, o que aliás é a mesma impressora. (o que a HP fez dessa vez, hein????)

     

    Essa impressora está em um note com Windows Vista, porém já esteve em uma estação com XP pro SP2, e o mesmo erro ocorreu.  Ela somente imprime com chaves de administradores e quando um usuário limitado ou power user, envia, a impressão fica presa na fila e só imprime reiniciando o sistema.

     

    Temos um impasse em algumas coisa que foi postado aqui.  A estação que está hoje, é um note, que por sinal, é do diretor.  ele carrega o note, então jamais poderia colocar um ip fixo, uma vez que ele pula de rede em rede, e tem outras conexões.

     

    Pedi para ele ficar rodando Bat, e tentar explicar sobre spool de impressora, seria impossível.  Isso está fora de cogitação, até porque não funcionaria, e logo caçaria minha cabeça por causa do bat sendo rodado o tempo todo, uma vez que administradores são poucos, podendo ser contado nos dedos, enquanto que usuários, são diversos.

     

    Gostaria de saber de uma solução, se existe para esse caso, sem ter que passar pela chefia (pelo menos para ele não ter que fazer nada), e de preferência definitiva.

     

    O caso dos ip, eu teria que configurar sempre, uma vez que cada vez que ele vai em empresas, e franquias, o pessoal muda a configuração de rede, ou simplismente também tem SHCP.

     

    Por favor peço ajuda!

    terça-feira, 25 de março de 2008 12:45
  • Rogi,

    Seu problema é exatamente igual ao meu. Provavelmente, se vc fizer o mesmo procedimento que eu fiz tera sucesso.
    Eu esqueci de mensionar, mas o arquivo bat que eu criei eu rodei ele na máquina onde estava a impressora.

    abraço
    quarta-feira, 26 de março de 2008 05:31
  • Pelo que entendi....  esse bat é para ser rodado na estação com a impressora, mas é para ser rodado toda vez que travar, estou correto??? 

     

    Se é isso, quem vai rodar???  Se é meu chefe que está nesta estação!!

     

    Esclarece para mim???

     

    Obrigado!

    quinta-feira, 27 de março de 2008 20:00
  • Você pode incluir a BAT no INICIAR > PROGRAMAS > INICIALIZAR no Perfil de Todos os Usuarios pq ai quando ele efetuar logon ja roda automatico.

    Espero ter ajudado


    Nilson Leite

    sexta-feira, 28 de março de 2008 19:45
  • Cria um agendamento apontando para esse arquivo .bat. Menu iniciar/executar/ tasks. Faz um agendamento de hora em hora para ser executado.

     

     

    fui,

     

    abrax.

    sexta-feira, 28 de março de 2008 21:13
  • Amigo tudo bom eu tbb estou com o problema de impressora "hp laser jet 1020" compartilhada na rede fica travando spooler de impressão....

     

    fiz o seguinte se desativar suporte bidirecional  ela funcioana mas quando a impressora tenta mandar uma msg pro pc ele da pau....

     

    se vc tiver uma maneira que  possa dar certo ficarei muito agrandecidoo....   

    sexta-feira, 25 de abril de 2008 12:24
  • Opa!

     

    1- verifica nas propriedades das impressoras se a opção para "manter documentos impressos" está marcada. Caso esteja desmarque.

     

    2- como são muitas impressoras seria bom vc deixar os temporários (cache de impressão) em outra partição, sem ser a de sistema.

     

    3- verifica também os processos rodando no servidor, na hora das impressões.

     

     

    Fui!!!

     

    se ajudou favor classificar.

    quinta-feira, 1 de maio de 2008 00:46
  • Denis,

     

     

    Estava com o mesmo problema e o resolvi de uma maneira diferente, e até o momento esta funcionando 100% fui até a impressora, depois na aba segurança, dei permissão a todos os usuários (todas - permissões especiais), você pode tentar desta forma para ver se lhe ajuda.

     

     

    Att.

     

    sexta-feira, 20 de junho de 2008 14:05
  • Pessoal,

     

    Aqui na empresa, estava com problemas na liberação da  fila do spool para a impressora, uma HP 2600n.

    No meu caso aqui, utilizo uma estrutura com domínio, num servidor windows 2003 server.

    Tinhamos um problema que alguns usuários conseguiam imprimir normalmente, outros as impressões saiam somente quando o print spooler era reestartado.

    A solução, os usuários que não conseguiam imprimir estavam em grupos (grupos das OUs do AD), cujo o nome do grupo ultrapassava 6 digitos... Alguns grupos por exemplo, GERENCIA, eu alterei para ADM e agora todos os usuários imprimem normalmente.

    Não consegui uma explicação exata para o caso, mas deve ser algo com relação a leitura de digitos do DOS. Se eu descobrir a possível causa do erro, posto em seguida.

     

    Att.

     

    segunda-feira, 19 de janeiro de 2009 17:29
  • Olá Bia, tudo bem ?

    Gostaria que vc me ajudasse. Estou enfrentando este mesmo problema, a impressão so sai quando o serviço print spooler é restartado e não consigo solução. Minha estrutura do AD contem muitas ramificações mais os nomes de OUs e Grupos são reduzidos pq aqui no local, os setores são identificados por abreviações, mesmo assim existe o problema. Você tem uma solução mais amadurecida que possa me ajudar ?

    Abraços.

    quinta-feira, 16 de setembro de 2010 01:17
  • Amigo Rogi_cps...

     

    No PC onde a impressora está instalada, rodando um Windows 7...

     

    Entre em "Ferramentas Administrativas\Gerenciamento do Computador\Usuários e Grupos Locais\Grupos\Administradores" e adicione o(s) usuário(s) que terá acesso à imressora. Fazendo isso eu consegui resolver o problema.

     

    Espero ter ajudado.

    • Sugerido como Resposta llluciano terça-feira, 17 de janeiro de 2012 12:10
    terça-feira, 17 de janeiro de 2012 12:09