locked
ERRO NA PAGINA DOS RELATORIOS RRS feed

  • Pergunta

  • Bom Dia!

     

    Não estou conseguindo visualizar os relatorios..dá o seguinte erro na página : HTTP 500 - Internal server error

     

    Obrigada

     

    Adriana

     

    quinta-feira, 21 de dezembro de 2006 13:38

Respostas

  • as permissoes estavam corretas!

    e não deu certo o procedimento do link.

     

    Muito Obrigada

    Dri

    quinta-feira, 21 de dezembro de 2006 18:08
  • Dri,

    Este erro acontece quando algum componente do SMS Reporting está danificado, corrompido ou ausente, o que pode ter ocorrido com a queda de energia.

    Faça o seguinte então:

    1. Desinstale o Reporting Point, desmarcando na console do SMS, no item Site System, a checkbox referente ao Reporting Point no servidor em que ele está instalado.

    2. Acompanhe através do log SMSReportingInstall.log até o término da desintalação

    3. Instale novamente o Reporting Point, marcando novamente a checkbox no item Site System, na console do SMS

    4. Acompanhe através do mesmo arquivo de log até a conclusão da instalação

     

    Bj


    Eduardo Almeida

    quarta-feira, 3 de janeiro de 2007 15:18

Todas as Respostas

  • Adriana,

    Vc adicionou os usuários ou grupos de acesso ao grupo SMS Reporting Users?

    Até mais,

    http://wesleey.spaces.live.com/

    quinta-feira, 21 de dezembro de 2006 13:52
  • Olá Thiago!

     

    o erro é esse:

    Server object error 'ASP 0177 : 8007007e'

    Server.CreateObject Failed

    /LM/W3svc/1/Root/SMSReporting_GES/global.asa, line 374

    8007007e

     

    e o link:

    http://ges-sms01/SMSReporting_GES/Reports.asp?ReportId=71

    Muito Obrigada,

    Att,

    Adriana

     

     

     

     

    quinta-feira, 21 de dezembro de 2006 13:54
  • Sim Wesley!

     

    aiai esse sms só dá dor de cabeça viu

     

    obrigada!!

    abs

    Dri

    quinta-feira, 21 de dezembro de 2006 17:33
  • as permissoes estavam corretas!

    e não deu certo o procedimento do link.

     

    Muito Obrigada

    Dri

    quinta-feira, 21 de dezembro de 2006 18:08
  • Adriana,

    Como tudo está certo, não era para estes erros ocorrerem. Verifique o Event Viewer do servidor SMS, e reporte-nos qualquer erro estranho, principalmente de DCOM.

    Olha, eu nunca tive dor de cabeça com o SMS. Tenha paciência.

    []'s

    http://wesleey.spaces.live.com/

    quinta-feira, 21 de dezembro de 2006 19:48
  • Wesley,

    Sim está tudo certo..é muito estranho..ontem estava normal até uma queda de energia aqui no bairro.

    Pensei em reinstalar o IIS..vc acha que adiantaria alguma coisa?

     

    Muito Obrigada,

    Abs,

     

    Adriana

    quinta-feira, 21 de dezembro de 2006 19:56
  • Oi Adriana,

    Como nenhum erro é exibido no Event Viewer, fica bem difícil achar alguma coisa. Aconselho que vc verifique cada um dos logs do SMS no servidor antes de fazer alguma alteração. Faça isso, e caso ache algum erro, envie-nos.

    Os logs estão na pasta SMS\Logs, na pasta de instalação.

    Vc tentou criar um novo usuário, dar permissões e testar?

    Vc não achou nenhum errinho de IIS, App Pool..nada?

    []'s

    http://wesleey.spaces.live.com/

    quinta-feira, 21 de dezembro de 2006 20:07
  • Achei alguns erros DCOM:

     

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID

    {0C0A3666-30C9-11D0-8F20-00805F2CD064}

    to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20). This security permission can be modified using the Component Services administrative tool.

     

    DCOM was unable to communicate with the computer SJC133851 using any of the configured protocols.

     

    this computer was not able to set up a secure session with a domain controller in domain SENAC due to the following:

    There are currently no logon servers available to service the logon request.

    This may lead to authentication problems. Make sure that this computer is connected to the network

     

    Obrigada!

    Adriana

    .

    sexta-feira, 22 de dezembro de 2006 12:39
  • Adriana,

    Este erro de DCOM em vermelho é interessante, mas parece que não está relacionado ao problema no Reporting. Mesmo assim vamos resolvê-lo.

    Dentro deste evento ao clicar no link de suporte da MS, vc verá como resolvê-lo:

     - Vá até HKEY_Classes_ROOT\CLSID\{0C0A3666-30C9-11D0-8F20-00805F2CD064}.
     - Identifique o ID do componente dentro da chave.
     - Execute DCOMCNFG, e defina a permissão de Local Activation para a conta Network Service no componente que possui o ID que vc encontro na chave de registro do primeiro item.

    Este procedimento irá resolver este problema de Access Denied de DCOM, mas este componente é o Machine Debugger, que aparentemente não está relacionado ao Reporting.

    Vc testou tudo isso com uma conta de usuário nova?

    []'s

    http://wesleey.spaces.live.com

    sexta-feira, 22 de dezembro de 2006 13:07
  • Oi Wesley..tentei sim com outra conta..mas dá o mesmo erro.

    e depois vc diz pra ter paciencia rs

     

    obrigada por tudo e bom natal e ano novo!

     

    abs

    sexta-feira, 22 de dezembro de 2006 18:00
  • Dri, Tudo bom.

    Tenta executar o seguinte comando

    regsvr32 FormatMessageCtl.dll

    O arquivo FormatMessageCtl.dll fica localizado no caminho C:\Inetpub\wwwroot\SMSComponent

    Após, reinicie os serviços do SMS Reporting Point e  IIS Admin

    Isso deve funcionar.

    Bjs

    Eduardo Almeida

    PS: Dri, calma com o SMS. rs

    quinta-feira, 28 de dezembro de 2006 13:44
  • Olá Teacher! Tudo bem fora o SMS que não quer gerar relatorios..só isso..o principal aiaiai rs

    Então..não deu certo... deu falha. calma né..é estou tentando...mas está complicado viu.

     

    Obrigada

    bjs

    Dri

     

     

     

     

    terça-feira, 2 de janeiro de 2007 17:55
  • Dri,

    Este erro acontece quando algum componente do SMS Reporting está danificado, corrompido ou ausente, o que pode ter ocorrido com a queda de energia.

    Faça o seguinte então:

    1. Desinstale o Reporting Point, desmarcando na console do SMS, no item Site System, a checkbox referente ao Reporting Point no servidor em que ele está instalado.

    2. Acompanhe através do log SMSReportingInstall.log até o término da desintalação

    3. Instale novamente o Reporting Point, marcando novamente a checkbox no item Site System, na console do SMS

    4. Acompanhe através do mesmo arquivo de log até a conclusão da instalação

     

    Bj


    Eduardo Almeida

    quarta-feira, 3 de janeiro de 2007 15:18
  • Caro Teacher

     Essa vai ser a última coisa que eu tento fazer..se não der certo vc por favor me passe seus telefones de contato que o jeito vai ser gritar para vc hehehe.

     

    Comprovado: SMS dá rugas..arghh rs

    Muito Obrigada pela ajuda!

    bjs

    Dri

    quarta-feira, 3 de janeiro de 2007 16:20
  • Desisto !

    Nada deu certo!

    Acho que só me sobrou a opção de reinstalar o maledito SMS.

     

    abs

    Dri

     

    quinta-feira, 4 de janeiro de 2007 12:33
  • Pessoal,

     

    Acredito que seja algo no IIS...mas tenho medo de remover e instalar novamente e dar problemas.

     

    O que vcs aconselham?

     

    Obrigada

    Abs

    Dri

     

     

    terça-feira, 9 de janeiro de 2007 16:17
  • Dri,

    Pode tentar.

    Tem alguma outra aplicação rodando nesse IIS ? ou é só o SMS ?

    O servidor que é IIS, é Windows 2000 ou 2003, DC ou Member Server ?

    Se não tiver nenhuma outra aplicação rodando em cima do IIS e se o servidor for Member Server pode remover e reinstalar sem problemas.

    Dicas:

    1. Desmarque as opções de Site Systems que utilizam o IIS neste servidor (Distribution Point, Management Point, Report Point, Server Locator Point), para o SMS não ficar inoperante você pode passar essas regras para um outro servidor. Espere a remoção desses componentes no IIS.

    2. Remova o IIS

    3. Reinstale o IIS

    4. Marque novamente os Site Systems, e espere ele terminar de instalar todos as roles.

     

    Eduardo Almeida

    terça-feira, 9 de janeiro de 2007 18:20
  • Ah, mais uma coisa,

    Se tiver alguma dúvida de como instalar o IIS, os componentes necessários para o SMS. O Wesley criou um procedimento muito bom de como configurar o IIS para o SMS.

    http://www.msit.com.br/publicacaoDetalhes.aspx?id=90


    Eduardo Almeida

    terça-feira, 9 de janeiro de 2007 18:24
  • Opa Eduardo!

    Obrigado por falar do procedimento que criei.

    Tem também o vídeo deste procedimento, que está dispnível em http://soapbox.msn.com/video.aspx?vid=4cedd2f3-9186-4f86-9ca0-d7671c441c65.

    []'s

    http://wesleey.spaces.live.com

    terça-feira, 9 de janeiro de 2007 21:34
  • vou tentar...muito obrigada Wesley e Edú!!

     

    Abs

    Dri

    quarta-feira, 10 de janeiro de 2007 18:54
  • Dri,

     

    Você já conseguiu gerar os relatórios, qualquer coisa me avisa? Tive o mesmo problema, e você tem razão, o problema é no IIS, é uma questão de permissão.

     

    Até mais

    terça-feira, 23 de janeiro de 2007 14:52
  • Claúdio,

     

    Consegui sim..com ajuda de um colega meu.

    Mas não era no IIS..foi um problema que ocorreu qndo eu troquei a senha.

    mas agora não consigo instalar o client do sms nos servidores..rs

    e como nada no SMS é simples de se resolver..lá vão mais alguns dias...soube q houve mudanças no AD..e talvez eu tenha que estende-lo novamente.

     

    Obrigada!

    Abs

    terça-feira, 23 de janeiro de 2007 16:03