none
ERRO - Instalação do ApplicationTemplateCore + HelpDesk + SharePoint 3.0 RRS feed

  • Pergunta

  • Ola pessoal, sou novato em SharePoint, é estou fazendo uns teste onde eu trabalho, na qual o meu objetivo e instalar e configurar o recurso do SharePoint de HeslpDesk.

     

    Fiz a instalação do W2K3-R2-SP2-PT_BR normalmente, instalei a versão do SharePoint 3.0 (e todos os requisitos necessários para o bom funcionamento da solução).

     

    Acessei normalmente o site padrão (Site de Equipe) e também o Administração Central do SharePoint, na qual todos estão funcionando perfeitamente.

     

    Baixei do site da Microsoft os modelos do SharePoint:

     

    ApplicationTemplateCore e o ServerAdminTemplates, todos para a versão em Portugues.

     

    Na instalação, seguir os procedimento recomendados pelo arquivo README_CORE.txt, na etapa de instalação, executando o comando "stsadm –o deploysolution –name ApplicationTemplateCore.wsp -allowgacdeployment" foi solicitado para eu completar alguns argumentos, na qual completei com a opção "-immedite"

     

    Fiz esse procedimento tanto no ApplicationTemplateCore e também no HelpDesk.wsp.

     

    Seguir a recomendação da Microsoft, de restartar o iis, mais quando eu acesso a Central do SharePoint, vou em Operações, Gerenciamento de Soluções, o status das duas soluções aparecer como ERRO.

     

    Tentei remover as soluções instaladas, mais aparecer uma mensagem dizendo que uma implantação ou cancelamento já está em andamento.

     

    Gostaria de saber qual o procedimento correto para instalar esse tipo de solução, é basicamente onde está o erro na hora de instalação desse Template.

     

    Agradeço a todos nessa ajuda.....

    segunda-feira, 16 de julho de 2007 17:41

Respostas

  • O problema da instalação do template, foi o Scheduling para o job criado pelo Sharepoint, sempre que é realizado um pedido de uma solução é criado um job, sendo criado definido um espaço temporal 0,1,5,10 minutos, se o "Windows SharePoint Services Timer service" nao estiver a funcionar correctamente, esse job nao e disparado, mesmo que na instrução esteja imediatte, para realizar o commit do processos pendentes, é necessário correr o processo "stsadm -o execadmsvcjobs", assumindo as alterações.
    Como esta instrução se encontra no script do Renan, logo irá funcionar correctamente.

    André Lage Microsoft SharePoint and CRM Consultant http://aaclage.blogspot.com
    • Marcado como Resposta Larah C. Vidotti sexta-feira, 10 de setembro de 2010 12:00
    sábado, 23 de maio de 2009 11:10
    Moderador

Todas as Respostas

  • Oi Robson, tem um vídeo que fala sobre essas instalações, dê uma olhada talves ajude.

    Se não me engano é a sessão 4.

     

    Abraços

    terça-feira, 17 de julho de 2007 13:35
  • Também passei por isso, depois de muito pesquisar, ai vai:

    No prompt vai para a pasta:
    C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN

    Executa isto:
    stsadm -o addsolution -filename nomedasolucao.wsp

    Depois isso:
    stsadm -o deploysolution -name nomedasolucao.wsp -allowgacdeployment -immediate


    É bem parecido com o que tem no readme.txt, mas é diferente.

    Tarcisio Jr.
    quinta-feira, 19 de julho de 2007 19:21
  • Olá pessoal,

     

    Segue um guia particular para o deployment dos Application Templates

    1. stsadm -o addsolution -filename applicationtemplatecore.wsp
    2. stsadm -o deploysolution -immediate -allowgacdeployment -name applicationtemplatecore.wsp
    3. Neste momento, você pode verificar se o deployment desta solution foi ralizado com sucesso. Para isso, utilize os seguintes passos:
      3.1 - Acesse o Sharepoint Central Administration
      3.2 - Tab operations
      3.3 - Na sessão Global Configuration, clique no link Solution Management
      3.4 - O status da solution applicationtemplatecore.wsp deve ser "Deployed"
    4. stsadm -o addsolution -filename <application template>.wsp
      stsadm -o deploysolution -allowgacdeployment -immediate -name <application template>.wsp
    5. Utilize novamente os procedimentos listados no item 3 para verificar se todos os Application templates encontram-se com o status "Deployed"

     

    []´s

     

    Hélio Sá Moreira

    Microsoft MVP - Office Sharepoint Server 2007

    sexta-feira, 20 de julho de 2007 12:57
  • Olá Hélio, segui seus passos porém no item 3 para verificar o o deployment está com o status de erro.

    Poderia me ajudar a descobir o que aconteceu?

     

    Obrigado

    terça-feira, 31 de julho de 2007 14:58
  • Bom dia.

     

    Comigo aconteceu o mesmo erro, alguem já conseguiu usar esse template?

     

    Abs.

    segunda-feira, 27 de agosto de 2007 13:10
  • Boa Noite,


    Eu usei o seguinte codigo e funcionou. Espero que ajude.


    REM -- inicio do instala.cmd --

    @ECHO OFF
    cLS
    SET PATH=%PATH%;C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN
    echo #####################
    echo ##  Prerequisitos                  ##
    echo #####################

    stsadm -o addsolution -filename ApplicationTemplateCore.wsp
    stsadm -o deploysolution -name ApplicationTemplateCore.wsp -allowgacdeployment -immediate
    stsadm -o execadmsvcjobs
    stsadm -o copyappbincontent

    Echo #####################
    echo ##  Prerequisitos                  ##
    echo #####################

    Echo #####################
    echo ##  Recursos                       ##
    echo #####################

    Echo ##################
    echo ## Fase 1 de 3              ##
    echo ##################

    stsadm -o addsolution -filename HelpDesk.wsp

    Echo ##################
    echo ## Fase 2 de 3              ##
    echo ##################
    stsadm -o execadmsvcjobs

    stsadm -o deploysolution -name HelpDesk.wsp -allowgacdeployment -immediate
    stsadm -o execadmsvcjobs

    Echo ##################
    echo ## Fase 3 de 3              ##
    echo ##################

    stsadm -o copyappbincontent

    Echo ##################
    echo ## Concluido                 ##
    echo ##################

    REM -- fim do instala.cmd --

    terça-feira, 19 de maio de 2009 03:53
  • O problema da instalação do template, foi o Scheduling para o job criado pelo Sharepoint, sempre que é realizado um pedido de uma solução é criado um job, sendo criado definido um espaço temporal 0,1,5,10 minutos, se o "Windows SharePoint Services Timer service" nao estiver a funcionar correctamente, esse job nao e disparado, mesmo que na instrução esteja imediatte, para realizar o commit do processos pendentes, é necessário correr o processo "stsadm -o execadmsvcjobs", assumindo as alterações.
    Como esta instrução se encontra no script do Renan, logo irá funcionar correctamente.

    André Lage Microsoft SharePoint and CRM Consultant http://aaclage.blogspot.com
    • Marcado como Resposta Larah C. Vidotti sexta-feira, 10 de setembro de 2010 12:00
    sábado, 23 de maio de 2009 11:10
    Moderador
  • Segue um artigo completo que possa ajudar inclusive tem um bat completo para você.

    Instalando os 40 Templates Sharepoint Ingles e Portugues

    Qualquer coisa entra em contato.

    OBS: A dica do André é muito relavante. As vezes o JOB não efetuado então tem que executar um comando para forçar a execução do mesmo.

    Abraços.

    Bruno Velaz
    Comunidade voltada a tecnologia SharePoint - CanalSharePoint
    www.canalsharepoint.com.br\brunovelaz
    Bruno Velaz - http://brunovelaz.spaces.live.com |*| CanalSharepoint.com.br\brunovelaz
    terça-feira, 26 de maio de 2009 13:45