none
Problemas com Robocopy RRS feed

  • Pergunta

  • Bom dia pessoal tudo bem?

    Eu tenho um servidor rodando o Windows Server 2008 standard.
    Tenho uma rotina de backup configurada da seguinte forma: 
     - robocopy D:"G:\BKP\dia_da_semana" /E /ETA /ZB - 
    Eu peço pra rodar o script e ele roda normamente, pela telinha do robocopy consigo visualizar os arquivos sendo copiados sem apresentar nenhum tipo de falha.
    Acontece que quando eu vou para a pasta para visualizar os arquivos a pasta esta em branco! Se eu clico em propriedades ela me fala que tem "x" arquivos em "x" pastas e me mostra o tamanho total dela que coincide exatamente com o local de origem, se eu faço algum tipo de alteração na pasta ele me mostra que aplica a alteração nos arquivos também.
    Mas se eu tento ver os arquivos nada feito é como se não tivesse nada.
    Já tentei alterar o script, pesquisar sobre mas não encontrei nada, por isso recorro a vocês para me ajudar nessa questão.

    Utilizo o mesmo script em outros locais e roda normalmente

    Peço a colaboração de todos vocês pois como estou lidando com Backup não quero correr o risco de quando precisar não ter nenhum arquivo para restaurar.

    Desde já agradeço pela atenção

    Estou a disposição para qualquer dúvida.

     

    Murilo Fonseca

    quarta-feira, 30 de novembro de 2011 14:11

Respostas

  • Murilo,

    Esse backup é feito em uma mídia externa? Verifica com um bom antivirus. Provavelmente tem algum virus nessa unidade ocultando os arquivos.

    Peça para visualizar pastas e arquivos ocultos e pastas e arquivos ocultos do sistema em Ferramentas > Opções de Pasta.

    Att.


    Flavio Lucio de Q. Ferreira
    flaviolucioqf@hotmail.com
    ticomuai.wordpress.com
    terça-feira, 6 de dezembro de 2011 13:30
  •  

    Olá Murilo,

    Tente acesentar na linha de comando , o comando "/a-:[rashcnet]" eusa o atributo de ocultar arquivo " H"

    deve ficar assim :

    robocopy D:"G:\BKP\dia_da_semana" /E /ETA /ZB /A-:H

    vc pode tentar tb um /copyall

    D:"G:\BKP\dia_da_semana" /E /ETA /ZB /COPYALL

    nunca usei o robocopy , mais vou começar a utilizar


    quinta-feira, 15 de dezembro de 2011 18:03

Todas as Respostas

  • Alguma novidade?

    Abraços,

     


    Flavio Honda - http://flaviohonda.wordpress.com
    quinta-feira, 1 de dezembro de 2011 18:34
    Moderador
  • Murilo,

    Esse backup é feito em uma mídia externa? Verifica com um bom antivirus. Provavelmente tem algum virus nessa unidade ocultando os arquivos.

    Peça para visualizar pastas e arquivos ocultos e pastas e arquivos ocultos do sistema em Ferramentas > Opções de Pasta.

    Att.


    Flavio Lucio de Q. Ferreira
    flaviolucioqf@hotmail.com
    ticomuai.wordpress.com
    terça-feira, 6 de dezembro de 2011 13:30
  •  

    Olá Murilo,

    Tente acesentar na linha de comando , o comando "/a-:[rashcnet]" eusa o atributo de ocultar arquivo " H"

    deve ficar assim :

    robocopy D:"G:\BKP\dia_da_semana" /E /ETA /ZB /A-:H

    vc pode tentar tb um /copyall

    D:"G:\BKP\dia_da_semana" /E /ETA /ZB /COPYALL

    nunca usei o robocopy , mais vou começar a utilizar


    quinta-feira, 15 de dezembro de 2011 18:03