none
O tráfego dos servidores de São Paulo está saindo do país, passando por MIAMI, para voltar até São Paulo RRS feed

  • Pergunta

  • Recentemente migramos para uma VM no datacenter de São Paulo para finalmente termos uma latência aceitável para nosso produto SaaS. Utilizamos atualmente um servidor Azure nos EUA e também a Locaweb (localmente), cuja latência é mínima, também hospedado em São Paulo. Para nossa surpresa, após migrarmos nossa aplicação para a VM em SP, descobrimos que o tráfego está sendo roteado do Brasil até um servidor em MIAMI e então de volta para São Paulo.

    Aqui vai o tracert:

    Rastreando a rota para simpax.com.br [23.97.102.98] com no máximo 30 saltos:
    
      1     6 ms     1 ms     1 ms  192.168.1.1
      2     *        *        *     Esgotado o tempo limite do pedido.
      3    33 ms    63 ms   245 ms  c9112101.virtua.com.br [201.17.33.1]
      4    15 ms    12 ms    14 ms  c9112281.virtua.com.br [201.17.34.129]
      5    18 ms    17 ms    15 ms  embratel-T0-0-2-0-tacc01.rjo.embratel.net.br [200.209.203.33]
      6   124 ms   121 ms   142 ms  200.244.216.44
      7   119 ms   124 ms   129 ms  ebt-BP1213-intl03.mianap.embratel.net.br [200.230.220.18]
      8   121 ms   128 ms   122 ms  ae3.miami15.mia.seabone.net [195.22.199.38]
      9   237 ms   228 ms   239 ms  xe-7-0-1.sanpaolo8.spa.seabone.net [195.22.219.179]
     10   234 ms   241 ms   236 ms  microsoft-customer.sanpaolo8.spa.seabone.net [195.22.219.14]
     11   241 ms   240 ms   242 ms  ae7-0.cpq01-96cbe-1b.ntwk.msn.net [191.234.81.253]

    Não sei o que fazer. Já migramos tudo para o Azure, modificamos nossos registros DNS e descomissionamos a VM que tínhamos nos EUA. Nunca poderíamos antecipar um comportamento absurdo desses: tráfego local ser roteado para fora do país para depois voltar.

    Acho isto totalmente inaceitável. Isto parece propaganda enganosa, uma vez que a Microsoft prometia com seus servidores no Brasil, uma latência mais baixa para acessos regionais. Na prática a latência é praticamente o DOBRO que tínhamos usando um datacenter do Azure nos EUA !

    Como não obtivemos resposta nos foruns em Inglês do Azure, e o forum brasileiro está fora do ar quando acessado pelo link de dentro do portal do azure (http://azure.microsoft.com/pt-br/support/forums/) migramos nossos DNS de volta para  a LOCAWEB para manter uma latência aceitável.

    Como o Azure não permite PING, usamos um aplicativo tcping que mensura o tempo que leva para se abrir uma conexão TCP/IP com determinado servidor. Nos resultados abaixo podemos ver como a latência é inaceitável para acesso a nossa VM em SP, sendo que estamos no RJ. O simpaxbr.cloudapp.net está hospedado no datacenter de SP, o simpax.cloudapp.net está em um datacenter do Azure nos EUA e o simpax.com.br foi movido de volta para a Locaweb, também em SP. Notem a latência absurda do simpaxbr:

    C:\Work>tcping simpaxbr.cloudapp.net
    
    Probing 23.97.102.98:80/tcp - Port is open - time=246.940ms
    Probing 23.97.102.98:80/tcp - Port is open - time=239.080ms
    Probing 23.97.102.98:80/tcp - Port is open - time=242.065ms
    Probing 23.97.102.98:80/tcp - Port is open - time=235.070ms
    
    Ping statistics for 23.97.102.98:80
         4 probes sent.
         4 successful, 0 failed.
    Approximate trip times in milli-seconds:
         Minimum = 235.070ms, Maximum = 246.940ms, Average = 240.789ms
    
    C:\Work>tcping simpax.cloudapp.net
    
    Probing 137.135.83.190:80/tcp - Port is open - time=155.231ms
    Probing 137.135.83.190:80/tcp - Port is open - time=143.825ms
    Probing 137.135.83.190:80/tcp - Port is open - time=153.049ms
    Probing 137.135.83.190:80/tcp - Port is open - time=146.419ms
    
    Ping statistics for 137.135.83.190:80
         4 probes sent.
         4 successful, 0 failed.
    Approximate trip times in milli-seconds:
         Minimum = 143.825ms, Maximum = 155.231ms, Average = 149.631ms
    
    C:\Work>tcping simpax.com.br
    
    Probing 187.45.229.123:80/tcp - Port is open - time=24.702ms
    Probing 187.45.229.123:80/tcp - Port is open - time=32.328ms
    Probing 187.45.229.123:80/tcp - Port is open - time=20.112ms
    Probing 187.45.229.123:80/tcp - Port is open - time=17.308ms
    
    Ping statistics for 187.45.229.123:80
         4 probes sent.
         4 successful, 0 failed.
    Approximate trip times in milli-seconds:
         Minimum = 17.308ms, Maximum = 32.328ms, Average = 23.612ms
    
    C:\Work>

    Para concluir, o tempo de acesso ao simpaxbr deveria ser em torno de 24ms, mas é 10x mais lento, em torno de 240ms.

    Não sabemos qual é a política de estorno da Microsoft, mas acreditamos que se não houver uma solução para este problema isto ficará muito "próximo" de propaganda enganosa.



    • Editado frmachado terça-feira, 2 de setembro de 2014 08:52
    terça-feira, 2 de setembro de 2014 08:50

Respostas

  • “Bom dia Frmachado,

    Obrigado por trabalhar com nosso time de suporte para termos mais detalhes a respeito desse problema.

    Um fato a considerar é que a decisão de roteamento entre a máquina cliente e o servidor é feita sempre pelo provedor de internet.

    Nós fizemos em conjunto o teste a partir de outros provedores brasileiros para o mesmo servidor de destino e como você notou o mesmo comportamento não se repetia.

     

    Realmente nós da Microsoft temos muito interesse em resolver esse problema visto que afeta a impressão que nossos clientes tem do serviço que fornecemos.

    O motivo dessa rota para fora do país é porque a Embratel e a Seabone possuem conectividade apenas em Miami. Como podemos observar no hop 7 e 8 do tracert que você postou originalmente aqui.

    Os outros provedores não usam os circuitos da Embratel, por isso não vemos o mesmo comportamento.

    O nosso time de infraestrutura de redes está trabalhando com os provedores para corrigir esse problema.

    Aguardamos que essa rota será corrigida e melhorada em breve mas isso também depende de contratos a serem assinados entre os provedores (Embratel e Seabone) que fogem do controle da Microsoft.”

    Abraço


    Ricardo Cortes Microsoft Contingent Staff

    Esse contedo e fornecido sem garantias de qualquer tipo, seja expressa ou implicita.

    MSDN Community Support

    • Sugerido como Resposta Ricardo Barbosa Cortes terça-feira, 14 de outubro de 2014 09:51
    • Marcado como Resposta Giovani Cr quarta-feira, 15 de outubro de 2014 13:21
    terça-feira, 14 de outubro de 2014 09:51

Todas as Respostas

  • Eu já questionei a Microsoft sobre isso e ainda não obtive resposta. Aparentemente os nomes são resolvidos fora do Brasil. Embora sejam cerca de 200ms a mais, faz diferença em alguns sistemas. 

    Thiago Custodio | Software Engineer
    Blog
    Twitter
    Faça parte da Comunidade Windows Azure Brasil no Facebook

    • Sugerido como Resposta Thiago CustodioMVP terça-feira, 2 de setembro de 2014 17:24
    • Não Sugerido como Resposta Thiago CustodioMVP terça-feira, 2 de setembro de 2014 17:24
    • Sugerido como Resposta Edinaldo Junior terça-feira, 2 de setembro de 2014 17:38
    • Não Sugerido como Resposta Edinaldo Junior quarta-feira, 3 de setembro de 2014 13:29
    terça-feira, 2 de setembro de 2014 17:24
  • Boa tarde FRmachado,

    Afim de te ajudar, primeiro precisamos estabelecer um canal de comunicação privada com você. Isto nos ajudará também na coleta de mais informações sobre este problema técnico. Você poderia por favor  enviar um e-mail no seguinte endereço CTS-ESC-MSDN-BR@outlook.com, com seus detalhes de contato (nome completo, endereço de e-mail, número de telefone) para que possamos resolver o seu problema.

    Att,



    Ricardo Cortes Microsoft Contingent Staff

    Esse contedo e fornecido sem garantias de qualquer tipo, seja expressa ou implicita.

    MSDN Community Support



    terça-feira, 2 de setembro de 2014 19:53
  • E ai frMachado,

    Tem alguma posição de como anda ? Você preencheu a resposta que te enviei?

    Abraço


    Ricardo Cortes Microsoft Contingent Staff

    Esse contedo e fornecido sem garantias de qualquer tipo, seja expressa ou implicita.

    MSDN Community Support

    quarta-feira, 3 de setembro de 2014 11:09
  • Olá Ricardo,

    Ontem estava em reunião o dia inteiro com meus sócios na empresa, onde demonstrei este problema técnico, e como migramos a solução SaaS de volta para Locaweb por causa do problema da latência, estamos um pouco menos sufocados, mas estamos pagando pelo serviço de uma VM que não podemos utilizar. Como eu abri este caso usando minha conta pessoal do Azure, onde mantenho meus "websites" e não a conta da empresa, onde mantenho nossa solução SaaS minhas credenciais de usuário não irão representar onde realmente o problema está ocorrendo. Vou lhe enviar um email com meus contatos, contato da empresa, link para a solução SaaS e link para o website (blog) da solução SaaS (todos no Azure). Apostamos cedo no Windows Azure pois desenvolvemos com tecnologia Microsoft há mais de 18 anos e acreditamos que a melhor solução para serviços "cloud" baseada em tecnologia Microsoft (.NET, IIS, etc.) deveria realmente vir da Microsoft. Não podemos deixar detalhes técnicos de infraestrutura inviabilizar o uso do Azure.

    quarta-feira, 3 de setembro de 2014 12:08
  • frmachado,

    Como o problema está sendo encaminhado em off (via email/fone), seria interessante marcar como respondido e encerrar o tópico.

    Atenciosamente,


    Edinaldo Oliveira

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    ** Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde. **

    ----------------------------------------------------------------------

    Convidem seus colegas para participarem do fórum Technet Brasil, assim todos ganham!!! Para entender melhor como, clique aqui.

    quarta-feira, 3 de setembro de 2014 12:10
  • frmachado,

    Como o problema está sendo encaminhado em off (via email/fone), seria interessante marcar como respondido e encerrar o tópico.

    Atenciosamente,


    Edinaldo Oliveira

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    ** Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde. **

    ----------------------------------------------------------------------

    Convidem seus colegas para participarem do fórum Technet Brasil, assim todos ganham!!! Para entender melhor como, clique aqui.

    Eu não acho certo marcar como respondido, mesmo porque NADa foi respondido. A Microsoft precisa se posicionar publicamente sobre o assunto. Irei atualizar o tópico com as respostas que receber em OFF. Tanto este aqui quanto o que abri em Inglês, pois os foruns brasileiros não são acessíveis pelo link de dentro do azure e dão erro.

    Marca-se um tópico como respondido quando se tem alguma solução. Eu mesmo responderei assim que tiver. Até lá acho correto deixar em aberto.

    quarta-feira, 3 de setembro de 2014 13:27
  • Bom dia Felipe,

    Não se preocupe em voltar para marcar como resposta, assim que seu problema for resolvido a Microsoft irá postar aqui uma posição oficial referente a solução do problema e ai ela mesmo marcará como respondida ok?

    Abraço


    Ricardo Cortes Microsoft Contingent Staff

    Esse contedo e fornecido sem garantias de qualquer tipo, seja expressa ou implicita.

    MSDN Community Support

    quarta-feira, 3 de setembro de 2014 14:17
  • “Bom dia Frmachado,

    Obrigado por trabalhar com nosso time de suporte para termos mais detalhes a respeito desse problema.

    Um fato a considerar é que a decisão de roteamento entre a máquina cliente e o servidor é feita sempre pelo provedor de internet.

    Nós fizemos em conjunto o teste a partir de outros provedores brasileiros para o mesmo servidor de destino e como você notou o mesmo comportamento não se repetia.

     

    Realmente nós da Microsoft temos muito interesse em resolver esse problema visto que afeta a impressão que nossos clientes tem do serviço que fornecemos.

    O motivo dessa rota para fora do país é porque a Embratel e a Seabone possuem conectividade apenas em Miami. Como podemos observar no hop 7 e 8 do tracert que você postou originalmente aqui.

    Os outros provedores não usam os circuitos da Embratel, por isso não vemos o mesmo comportamento.

    O nosso time de infraestrutura de redes está trabalhando com os provedores para corrigir esse problema.

    Aguardamos que essa rota será corrigida e melhorada em breve mas isso também depende de contratos a serem assinados entre os provedores (Embratel e Seabone) que fogem do controle da Microsoft.”

    Abraço


    Ricardo Cortes Microsoft Contingent Staff

    Esse contedo e fornecido sem garantias de qualquer tipo, seja expressa ou implicita.

    MSDN Community Support

    • Sugerido como Resposta Ricardo Barbosa Cortes terça-feira, 14 de outubro de 2014 09:51
    • Marcado como Resposta Giovani Cr quarta-feira, 15 de outubro de 2014 13:21
    terça-feira, 14 de outubro de 2014 09:51