none
Error Code 10061: Connection refused ISA Server 2004 para determinados sites RRS feed

  • Pergunta

  • Boa tarde pessoal, depois de muitas horas tentando resolver este problema decidi postar aqui para ver se vocês me ajudar. É o seguinte, tenho 1 servidor de proxy onde está instalado o ISA Server 2004 com algumas regras de firewall. Até semana passada estava acessando os sites normalmente, porém esta semana me deparei com um problema um pouco inusitado, no qual vou exemplificar.

    Tenho 2 domínios, suponhamos que seja o www.dominio1.com.br e www.dominio2.com.br, ambos com sites hospedados na Locaweb. Acontece que *apenas internamente* na rede da minha empresa eu só consigo acessá-los se for através de algum subdomínio, por exemplo: subdominioA.dominio1.com.br e subdominioB.dominio2.com.br.

    Quando tento acessar diretamente por www.dominio1.com.br por exemplo, sempre recebo uma mensagem de erro do ISA com os seguintes dizeres:


    Technical Information (for support personnel)
    • Error Code 10061: Connection refused
    • Background: The server you are attempting to access has refused the connection with the gateway. This usually results from trying to connect to a service that is inactive on the server.
    • Date: 15/8/2012 20:29:10
    • Server: proxy.local
    • Source: Remote server

    Estou completamente sem ideias de como resolver, alguém já passou por algo parecido? Lembrando que diversos outros sites como bing, google, terra entre outros, eu consigo normalmente acessar com o www.site.com.br, sendo que este problema acontece exclusivamente nesses sites meus.

    Desde já agradeço, me desculpem pela mensagem grande, mas tentei descrever com a maior clareza possível essa dor de cabeça.

    quarta-feira, 15 de agosto de 2012 20:47

Respostas

  • Amigo para contornar esse problema.

    crie um cname dentro do seu servidor dns ( AD ).

    Colocando o subdominio, e depois crie da maneira que voce gostaria de chama-lo no www

    Oque acontece é que o seu subdominio não esteja publicado ( DNS ) se não tem resolução não ha navegação e tem erros!


    Júnior Ramos | MCSE | MCSA | MCTS Server 2008| MCTS R2, Server Virtualization | E-mail Consultoriaemredes@live.com |

    • Marcado como Resposta Richard Juhasz sexta-feira, 17 de agosto de 2012 12:16
    quinta-feira, 16 de agosto de 2012 11:51
  • Foi resolvido o problema do Rafael,

    O problema foi que a empresa anterior que trabalhava lá, sacaneou o mesmo criando arquivos e apontamento de Hosts dentro das maquinas locais

    C:\windows\System32\etc\hosts

    Cada site acessado era redirecionado para localhost 127.0.0.1

    Obrigado Rafael em permitir meu acesso remoto para resolução do problema!


    Grato.


    Júnior Ramos | Analista em Tecnologia da informação| MCPID: 8549133 | e-mail: Consultoriaemredes@live.com | Fone: (47) 8417 - 3475 |

    • Marcado como Resposta rdant segunda-feira, 20 de agosto de 2012 14:59
    segunda-feira, 20 de agosto de 2012 14:38

Todas as Respostas

  • Bom dia, Rdant!

    Poderia criar uma regra usando no TO um Domain Name Sets faça  o teste e post novamente.

    Create Access Rule

    Action: Allow
    Protocols: HTTP and HTTPS
    From: Internal
    To: (Clique em ADD e vá até a opção Domain Name Sets) Crie um Domain chamado Ex: Site Empresa) e adicione as urls dentro com /* no final, Ex: www.dominio.com.br/*
    Users: ALL Users (Exemplo)


    Douglas Urbano

    quinta-feira, 16 de agosto de 2012 11:03
  • Bom dia, Douglas!

    Primeiramente, obrigado pela resposta.

    Então, efetuei a criação do Domain Name Sets e da regra exatamente do jeito que você apresentou, mas infelizmente nada mudou. Parece-me que algo está bloqueando o "www", pois se eu digito www.dominio1.com.br/subdominioA me retorna erro, mas subdominioA.dominio1.com.br acessa normalmente.

    Fico me perguntando, será que o acesso chega no ISA? É possível estar sendo barrado antes? Mas desconheço algum outro firewall ativo ou outro software que pode estar barrando.

    Mas detalhe, se no meu firefox eu configuro "Sem proxy", ou seja, se não passar pelo ISA né, funciona tudo perfeitamente.

    quinta-feira, 16 de agosto de 2012 11:36
  • Amigo para contornar esse problema.

    crie um cname dentro do seu servidor dns ( AD ).

    Colocando o subdominio, e depois crie da maneira que voce gostaria de chama-lo no www

    Oque acontece é que o seu subdominio não esteja publicado ( DNS ) se não tem resolução não ha navegação e tem erros!


    Júnior Ramos | MCSE | MCSA | MCTS Server 2008| MCTS R2, Server Virtualization | E-mail Consultoriaemredes@live.com |

    • Marcado como Resposta Richard Juhasz sexta-feira, 17 de agosto de 2012 12:16
    quinta-feira, 16 de agosto de 2012 11:51
  • Bom dia Júnior, obrigado pela resposta! As coisas não estão claras para mim, me desculpe. Qual a relação do DNS do meu AD com o acesso à sites externos, que estão hospedados na Locaweb? Eu fiz da seguinte maneira o que você me falou, criei três domínios na árvore "br" > "com" > "dominio1". Dentro do dominio 1 criei um host(A) de "www" com o IP do servidor onde está meu site na locaweb, mas não funcionou.

    Estou perdido, pois como disse, não consigo entender a relação do DNS (AD) com o acesso à sites externos. Lembrando que qualquer outro site, desde que liberado no ISA, acessa normalmente. Só tenho problemas com 2 domínios, que são meus, mas estão hospedados na Locaweb.

    Sabe o que pode ser?

    Agradeço desde já.

    segunda-feira, 20 de agosto de 2012 11:37
  • Qual a relação do DNS do meu AD com o acesso à sites externos, que estão hospedados na Locaweb?

    Amigo, vc tem um dominio e um subdominio, voce tem um site por exemplo www.dns1.meudns.com.br

    sendo que voce pode criar um cname de www.dn1.meudns.com.br,

    para então --> www.meudns.com.br

    quando voce navegar no www.meudns.com.br ele vai automaticamente entender que esta sendo acessado o  site www.dns1.meudns.com.br

    qualquer duvida me add no msn

    abs


    Júnior Ramos | Analista em Tecnologia da informação| MCPID:8549133

    segunda-feira, 20 de agosto de 2012 11:48
  • Júnior, agora identifiquei algo interessante. No Firefox eu possuo as configurações de rede como "Sem proxy", pois o ISA não está diretamente entre a LAN e a WAN, ou seja, eu consigo acessar internet sem passar pelo ISA (no Firefox). No Internet Explorer, é definido para passar pelo ISA. O interessante vem agora:

    No Firefox (Sem proxy) se eu tento acessar o meu domínio com "www", ou seja, www.dominio1.com.br, eu acabo caindo no servidor web (Wamp) da minha estação local (127.0.0.1)!!!

    No IE (Passa pelo ISA) se eu tento acessar o mesmo, aí é que aparece o "Connection refused". Se eu acesso o IP da máquina onde está o ISA, me retorna a mesma mensagem, "Connection refused".

    Conclusões que chego a partir disso (posso estar enganado), sem proxy eu sou redirecionado para minha estação local mesmo, com ISA eu redirecionado para o servidor onde está o ISA.

    E agora, o que pode ser isso? Estou muito perdido.

    Agradeço novamente.

    segunda-feira, 20 de agosto de 2012 11:49
  • me add no msn!

    Júnior Ramos | Analista em Tecnologia da informação| MCPID:8549133

    segunda-feira, 20 de agosto de 2012 11:52
  • Amigo, não consegui encontrar seu msn no perfil. Como posso contactá-lo?
    segunda-feira, 20 de agosto de 2012 13:08
  • perdão amigo, nao te informei anteriormente

    segue --> consultoriaemredes@live.com

    abs


    Júnior Ramos | Analista em Tecnologia da informação| MCPID:8549133

    segunda-feira, 20 de agosto de 2012 13:11
  • Opa obrigado, já estou adicionando.
    segunda-feira, 20 de agosto de 2012 13:30
  • tranquilo te aguardo!

    Júnior Ramos | Analista em Tecnologia da informação| MCPID: 8549133 | e-mail: Consultoriaemredes@live.com | Fone: (47) 8417 - 3475 |

    segunda-feira, 20 de agosto de 2012 13:32
  • Foi resolvido o problema do Rafael,

    O problema foi que a empresa anterior que trabalhava lá, sacaneou o mesmo criando arquivos e apontamento de Hosts dentro das maquinas locais

    C:\windows\System32\etc\hosts

    Cada site acessado era redirecionado para localhost 127.0.0.1

    Obrigado Rafael em permitir meu acesso remoto para resolução do problema!


    Grato.


    Júnior Ramos | Analista em Tecnologia da informação| MCPID: 8549133 | e-mail: Consultoriaemredes@live.com | Fone: (47) 8417 - 3475 |

    • Marcado como Resposta rdant segunda-feira, 20 de agosto de 2012 14:59
    segunda-feira, 20 de agosto de 2012 14:38
  • Realmente Júnior, resolvido! Confirmei o que tínhamos pensado, os caras fizeram alteração em alguma diretiva do Active Directory para que as estações recebam os arquivos de hosts "sacaneados".

    Júnior, eu que agradeço a pronta disponibilidade em ajudar a resolver o problema.

    Grato!

    segunda-feira, 20 de agosto de 2012 14:59
  • Rafael, disponha sempre que precisar!

    Obrigado


    Júnior Ramos | Analista em Tecnologia da informação| MCPID: 8549133 | e-mail: Consultoriaemredes@live.com | Fone: (47) 8417 - 3475 |

    segunda-feira, 20 de agosto de 2012 15:56