none
Service Pack 3 CU 14 x Service Pack 4 para SQL SERVER 2005 RRS feed

  • Pergunta

  • Prezados,

    Nas minhas instalações de SQL SERVER 2005 (32 bits) eu tenho instalado o Service Pack 3 com o Cumulative Update 11 ( Build 9.00.4309 ), porém percebi que foram liberados o Cumulative Update 14 ( Build 9.00.4317 ), mas também o Service Pack 4.

    Fiquei com dúvida em qual instalar, para atualizar meu ambiente, pois se verificarmos no link para baixar o CU14 do SP3 ( http://support.microsoft.com/kb/960598/en-us ), iremos verificar que o mesmo data de 21/02/2011.

    Porém no link para baixar o SP4 ( http://support.microsoft.com/kb/913089 ) verificaremos que o mesmo data de 17/12/2010.

    Um service pack de maior número, sempre é mais atualizado do que o anterior (ou seja, SP4 mais atual que SP3). Mas como o CU14 do SP3 foi liberado em data maior do que o SP4, fiquei na dúvida se apenas instalando o SP4 terei meu ambiente com as últimas atualizações ou se, no caso, vou ter que aplicar o CU14 do SP3 e só depois o SP4.

    Gostaria de saber qual a recomendação neste caso, pois fiquei em dúvida se o SP4 realmente traz todas as atualizações do SP3 e mais todos seus Cumulative Update's.

    Desde já agradeço o retorno de vocês.

    Obrigado,

    José Luiz

    terça-feira, 15 de março de 2011 19:45

Respostas

  • Recomendo atualizar para o SP4.

    No SQL Server os services packs são cumulativos.

     

    []'s!


    http://www.diaadiasql.com.br
    • Marcado como Resposta Richard Juhasz segunda-feira, 28 de março de 2011 20:08
    quarta-feira, 16 de março de 2011 14:04
  • José

    Como o Leandro comentou o que devemos observar o BUILD, apesar do CU14 do SP3 ter sido lançado depois do SP4 não significa que ele será o ultimo versão do SQL, existe um site do time de SQL da MSFT que lista todos os builds para todas as versões de SQL, deverá te ajudar.

    http://www.sqlteam.com/article/sql-server-versions

    Como o Leandro, comentou o build mais recente é o 5259 com o SP4+CU2

    att.
    Marcelo Fernandes


    MCP, MCDBA, MCSA, MCTS.
    Se útil, classifique!!!
    Me siga no twitter: @marcelodba

    • Marcado como Resposta Richard Juhasz segunda-feira, 28 de março de 2011 20:08
    quarta-feira, 16 de março de 2011 14:14
    Moderador

Todas as Respostas

  • Luiz, interessante essa questão. Acho que por compatibiliade eles devem ter lançado esses Cumulatives Updates, mesmo depois de ter lançado o service Pack 4.  Acho que para deixar o ambinte atualizado eu instalaria o SP4 + CU2 (http://support.microsoft.com/kb/2489409) que tem data de 22/02/2011 e elevaria a build para 9.00.5259.
    Att. Leandro Bugalho
    quarta-feira, 16 de março de 2011 10:49
  • Leandro,

    Primeiramente, muito obrigado pelo retorno.

    Seu raciocínio está correto. Creio que, no caso, a Microsoft deve ter lançado o SP4 em data anterior ao CU14 do SP3 e, depois, para equalizar tudo, lançou o CU2 do SP4, o qual deve contemplar todas as atualizações contidas até o CU14 do SP3.

    Obrigado mais uma vez. Farei isso no meu ambiente.

    José Luiz

    quarta-feira, 16 de março de 2011 13:07
  • Recomendo atualizar para o SP4.

    No SQL Server os services packs são cumulativos.

     

    []'s!


    http://www.diaadiasql.com.br
    • Marcado como Resposta Richard Juhasz segunda-feira, 28 de março de 2011 20:08
    quarta-feira, 16 de março de 2011 14:04
  • José

    Como o Leandro comentou o que devemos observar o BUILD, apesar do CU14 do SP3 ter sido lançado depois do SP4 não significa que ele será o ultimo versão do SQL, existe um site do time de SQL da MSFT que lista todos os builds para todas as versões de SQL, deverá te ajudar.

    http://www.sqlteam.com/article/sql-server-versions

    Como o Leandro, comentou o build mais recente é o 5259 com o SP4+CU2

    att.
    Marcelo Fernandes


    MCP, MCDBA, MCSA, MCTS.
    Se útil, classifique!!!
    Me siga no twitter: @marcelodba

    • Marcado como Resposta Richard Juhasz segunda-feira, 28 de março de 2011 20:08
    quarta-feira, 16 de março de 2011 14:14
    Moderador
  • Mais uma vez obrigado ao Leandro e obrigado também ao Renato e ao Marcelo pelas respostas.

    Como falei antes, vou atualizar meu ambiente para SP4 + CU2.

    Valeu !

    José Luiz

    quarta-feira, 16 de março de 2011 19:10