none
Problemas com ReportService + Datawarehouse. RRS feed

  • Pergunta

  • Boa tarde Galera.

    Estive migrando minhas bases de dados OperationsManager e OperationsManagerDW para outra maquina e tudo tranquilo. Só que quando voltei as bases para a maquina original ou seja o meu root management server o reportserver parou de gerar relatorios dando este erro.


    Note:  The following information was gathered when the operation was attempted.  The information may appear cryptic but provides context for the error.  The application will continue to run.

    Microsoft.Reporting.WinForms.ReportServerException: The item '/Microsoft.SystemCenter.DataWarehouse.Report.Library/Microsoft.SystemCenter.DataWarehouse.Report.ConfigurationChange' cannot be found. (rsItemNotFound)
       at Microsoft.Reporting.WinForms.ServerReport.GetExecutionInfo()
       at Microsoft.Reporting.WinForms.ServerReport.GetParameters()
       at Microsoft.EnterpriseManagement.Mom.Internal.UI.Reporting.Parameters.ReportParameterBlock.Initialize(ServerReport serverReport)
       at Microsoft.EnterpriseManagement.Mom.Internal.UI.Console.ReportForm.SetReportJob(Object sender, ConsoleJobEventArgs args)


    O meu reportservice esta acessivel via http://localhost/Reports e http://localhost/ReportServer. A config do reportserver esta com todos os checks verdinhos, ou seja esta funcionando.

    Agora nao consigo descobrir o que acontece com este erro em questão.

    Alguem ja passou por isso antes?

    Jefferson Dias

    LoBoGoL
    terça-feira, 28 de abril de 2009 15:28

Respostas

  • Fala Jefferson, blz?

     

    Cara eu entendi o que você está querendo fazer, mas infelizmente não entendi o cenário. Será que você pode detalhar um pouco mais? Você está migrando suas bases de um computador para outro, mas por que vc voltou elas para o servidor original?

     

    E sim, o acesso ao Reporting Services pode funcionar perfeitamente, mas o acesso a base Data Warehouse pode estar com problemas, pois estes são processos diferentes. Eu sugiro que você veja este link: http://technet.microsoft.com/en-us/library/cc540369.aspx

     

    Isso está me parecendo problemas de permissão de usuário ou alguma chave de registro/configuração como o nome do servidor antigo ainda. J

     

    Abraço e boa sorte.

     

    Cleber Marques
    Projeto MOF Brasil: Simplificando o Gerenciamento de Serviços de TI
    www.mof.com.br | www.clebermarques.com | www.clebermarques.com.br
    terça-feira, 28 de abril de 2009 16:51
    Moderador

Todas as Respostas

  • Fala Jefferson, blz?

     

    Cara eu entendi o que você está querendo fazer, mas infelizmente não entendi o cenário. Será que você pode detalhar um pouco mais? Você está migrando suas bases de um computador para outro, mas por que vc voltou elas para o servidor original?

     

    E sim, o acesso ao Reporting Services pode funcionar perfeitamente, mas o acesso a base Data Warehouse pode estar com problemas, pois estes são processos diferentes. Eu sugiro que você veja este link: http://technet.microsoft.com/en-us/library/cc540369.aspx

     

    Isso está me parecendo problemas de permissão de usuário ou alguma chave de registro/configuração como o nome do servidor antigo ainda. J

     

    Abraço e boa sorte.

     

    Cleber Marques
    Projeto MOF Brasil: Simplificando o Gerenciamento de Serviços de TI
    www.mof.com.br | www.clebermarques.com | www.clebermarques.com.br
    terça-feira, 28 de abril de 2009 16:51
    Moderador
  • Fala ai Cleber. Puts, nem te conto o que rolou aqui. Estavamos com problemas de I/O de disco porque o SQL esta junto com SCOM07 SP1. Resolvemos migrar o SQL para outra maquina e tudo estava indo tranquilo até o DBA daqui que autorizou a migraçao para a maquina dele que é um SQL05 de produção dizer que nao poderiamos mexer no reportservice desta maquina. Bom eu ja tinha feito todo o procedimento de remoçao da operationsmanagerDW e reportservice. Dai veio eu mente para resolver o problema rapido e evitar um maior downtime voltar o DW e o SRS, foi ai que a cagada começou e nao parou mais. Bom. Tomei a decisão de reformular toda a topologia já pensando em duas maquinas para cada serviço separado e com mais disco utilizando raid 5 ou 10. A boa noticia de tudo isso é que este SCOM07 em questão ainda nao estava em produção e posso fazer o que quero, alem do deadline deste projeto ser para o inicio de junho. Agradeço a ajuda. Jefferson Dias
    LoBoGoL
    • Editado LoBoGoL quinta-feira, 30 de abril de 2009 19:26
    quinta-feira, 30 de abril de 2009 19:25
  • Show de bola cara, precisando é só postar aqui, depois nos conte no que deu a migração e as lições aprendidas, vai ser legal compartilhar isso J

     

    Abraços

     

    Cleber Marques
    Projeto MOF Brasil: Simplificando o Gerenciamento de Serviços de TI
    www.mof.com.br | www.clebermarques.com | www.clebermarques.com.br
    segunda-feira, 11 de maio de 2009 03:15
    Moderador