none
Erro ao acessar SQL de outra estação RRS feed

  • Pergunta

  • Olá,

    Tenho um programa operando corretamente em uma máquina na qual também está o servidor SQL.

    Porém não consigo acessar o programa de outra estação ( ocorre o erro da imagem abaixo ).

    Na estação onde está o servidor as conexões remotas ao SQL estão habilitadas e o firewall foi desativado.

    Alguém pode me dar uma luz ? Não sei mais o que pode ser.

    Obrigado

    • Movido Gustavo Maia Aguiar terça-feira, 31 de janeiro de 2012 14:54 (De:SQL Server - Desenvolvimento Geral)
    terça-feira, 31 de janeiro de 2012 11:41

Todas as Respostas

  • Mike_Kia, bom dia!

     

    O erro está acontecendo porque na sua máquina locala comunicação entre ela e o SQL Server funciona pelo protocolo Shared Memory, porém tentando acessá-lo externamente ou seja de outra máquina, é necessário que você habilite o protocolo TCP-IP para isso faça o seguinte.

     

    1 - Entre no SQL Server Configuration Manager

    2 - Vá na aba SQL Nativa Client Configuration / Client Protocol

    3 - Botão Direito no Protocolo TCP/IP e ative-o.

     

     

    Logo apos isso faça o teste de conexão.

     

    Abs


    Luan.Moreno MTAC | MCP | MTA | MCTS SQL Server Administrator / Developer
    terça-feira, 31 de janeiro de 2012 11:54
  • Oi Luan,

    Verifiquei lá e o TCP/IP já está habilitado assim como o Named Pipes...

    Da mesma forma em "Sql Server 2005 Network configuration -> Protocols for sqlexpress".

    Que coisa :(

     

    terça-feira, 31 de janeiro de 2012 12:27
  • A sim SQL Server 2005,

     

    Espero que esse ajude!

     

    http://www.linglom.com/2007/08/31/enable-remote-connection-to-sql-server-2005-express/

     

    Abs


    Luan.Moreno MTAC | MCP | MTA | MCTS SQL Server Administrator / Developer
    terça-feira, 31 de janeiro de 2012 12:50
  • Estes pontos já estavam ok também.

    Pelo que estou vendo há algo crítico no SP3 do XP ( onde está o servidor ) que impede o acesso das estações ao SQL Server...parece que a solução passa por extirpar o XP SP3...

    Lamentável para dizer o mínimo.

    Valeu Luan

     

     

     

     

    terça-feira, 31 de janeiro de 2012 13:11