none
Bom funcionamento do PHP no Windows com IIS RRS feed

  • Pergunta

  • Pessoal,

    O que vocês estão usando para o PHP rodar de forma correta, tem algo?
    Da forma configurada aqui atualmente alguns includes não funcionam e o esquema de URLs Amigáveis também não funciona corretamente, enfim, precisa de algumas melhoras.

    O que vocês usam em configuração?

    No servidor Windows 2003 com II6 aqui usamos FastCGI para rodar o PHP e na configuração da extensão no IIS usamos apontado para C:\WINDOWS\system32\inetsrv\fcgiext.dll.

    E você?

    Rodrigo Deguir
    terça-feira, 26 de maio de 2009 17:53

Respostas

Todas as Respostas

  • Para lhe ser sincero eu nunca misturei essas plataformas, porcuro colocar o PHP fora do IIS mesmo para não ter problemas.
    Espere no Senhor, confia Nele,e o mais Ele fará
    terça-feira, 26 de maio de 2009 18:37
  • Para lhe ser sincero eu nunca misturei essas plataformas, porcuro colocar o PHP fora do IIS mesmo para não ter problemas.
    Espere no Senhor, confia Nele,e o mais Ele fará

    Com certeza seria a melhor coisa, mas... na prática os clientes querem rodar PHP e com isso tem que achar uma saída.

    Mais obrigado!

    Rodrigo Deguir
    terça-feira, 26 de maio de 2009 18:40
  • Rodrigo, creio que a melhor saida para você é postar no pessoal do MSDN mesmo cara, que podem lhe ajudar com melhor autoridade.
    http://social.msdn.microsoft.com/forums/pt-BR/categories/

    Abraço.
    Espere no Senhor, confia Nele,e o mais Ele fará
    • Marcado como Resposta Richard Juhasz quinta-feira, 19 de novembro de 2009 11:47
    terça-feira, 26 de maio de 2009 18:57
  • Rodrigo, creio que a melhor saida para você é postar no pessoal do MSDN mesmo cara, que podem lhe ajudar com melhor autoridade.
    http://social.msdn.microsoft.com/forums/pt-BR/categories/

    Abraço.
    Espere no Senhor, confia Nele,e o mais Ele fará

    Uau! Se eu falar em PHP no MSDN eu apanho (risos).

    Rodrigo Deguir
    terça-feira, 26 de maio de 2009 19:30
  • rsrsrsr.. É sério cara, pergunta lá, certamente eles possuem casos sobre esse assunto e podem lhe ajudar.


    Espere no Senhor, confia Nele,e o mais Ele fará
    terça-feira, 26 de maio de 2009 19:36
  • Ta certo! Mesmo assim obrigado!
    Rodrigo Deguir
    terça-feira, 26 de maio de 2009 20:35
  • Olá Rodrigo tudo bem.
    Cara não sei se você conseguiu resolver o seu problema eu utilizo php no iis7 e por enquanto tem funcionado bem, o segredo do post e as demais configurações estão no php.ini, você pode realizar alterações lá e reiniciar o IIS q vão funcionar perfeitamente, quanto a URL amigavel você deve baixar um complemento do iis que se chama "URL Rewrite" instala ele e nele você cria as regras. eu só estou tento problemas quanto aos acentos nas url's mas já estou procurando uma solução.

    Luis.
    terça-feira, 17 de novembro de 2009 13:43
  • Rodrigo

    Da uma olhada, neste site

    http://www.iis-aid.com/

    Ja usei o app deles para rodar o php no iis, e rolou sem problemas.

    Pode ser que ocorra um problema com os paths no system variables ( vai ficar faltando um ";" no final da string).

    • Marcado como Resposta Richard Juhasz quinta-feira, 19 de novembro de 2009 11:47
    terça-feira, 17 de novembro de 2009 15:50