none
erro concat_null_yields_null, ansi_warnings, ansi_padding arithabort' RRS feed

  • Pergunta

  • Em um dos meus clientes está acontecendo o seguinte erro:

    General sql error.select failed becouse the followin set option have incorrect settings: concat_null_yields_null, ansi_warnings, ansi_padding arithabort'.verify that set options are correct for use with indexed views and/or indexes on computed columns and/or query notifications and/or xml data type methods

    Tem como eu solucionar esse problema sem colocar esses parâmetros antes da criação da view? Pois essa foi a unica solução que achei até o momento e não queria alterar a view.

     

    sexta-feira, 18 de março de 2011 20:00

Respostas

  • Elisangela,

    O comentário do Fabrizzio é bastante interessante, porém não podemos esquecer que a aplicação pode sobrescrever as configurações originais do servidor, para esses casos.

    Neste site http://msdn.microsoft.com/en-us/library/ms188783.aspx (no item Required SET Options for Indexed Views) você encontrará os valores que são requeridos para o funcionamento de views indexadas e colunas calculadas. Caso o seu server esteja configurado de acordo com as especificaçãoes desta tabela, acho que você não terá outra opção a não ser forçar essas opções no momento em que sua aplicação se conectar com o banco.

    Espero que ajude!

    segunda-feira, 21 de março de 2011 01:47
  • Elisangela,

    Neste caso, você terá que analisar os impactos que esta alteração poderia chegar sobre seu ambiente.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    • Marcado como Resposta Richard Juhasz segunda-feira, 28 de março de 2011 20:03
    quarta-feira, 23 de março de 2011 19:22
    Moderador

Todas as Respostas

  • Elisansela, Voce pode definir os valors default para essas configurações, basta ir nas propiedades da instancia, porem deve-se lembrar que isso afetara tudo que roda na instancia.
    ------------------------------------------------------------- Oracle OCA11g
    sexta-feira, 18 de março de 2011 22:31
    Moderador
  • Elisangela,

    Qual seria a query que esta gerando este erro de valores nulos?

    Você poderá utilizar as diretivas:

    Set Ansi_Nulls

    Set Null_DFLT_On

    SET ANSI_WARNINGS
    SET ARITHABORT

    SET ARITHIGNORE

    Você esta realizando algum cálculo?


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    domingo, 20 de março de 2011 01:34
    Moderador
  • Os varoles são os default do sql server.

    A query que está gerando esse erro é uma view, não queria colocar esses valores nessa view, pois ela está no código do sistema e o programador tem que gerar outro executável.

    domingo, 20 de março de 2011 18:44
  • Elisangela,

    O comentário do Fabrizzio é bastante interessante, porém não podemos esquecer que a aplicação pode sobrescrever as configurações originais do servidor, para esses casos.

    Neste site http://msdn.microsoft.com/en-us/library/ms188783.aspx (no item Required SET Options for Indexed Views) você encontrará os valores que são requeridos para o funcionamento de views indexadas e colunas calculadas. Caso o seu server esteja configurado de acordo com as especificaçãoes desta tabela, acho que você não terá outra opção a não ser forçar essas opções no momento em que sua aplicação se conectar com o banco.

    Espero que ajude!

    segunda-feira, 21 de março de 2011 01:47
  • Elisangela,

    Neste caso, você terá que analisar os impactos que esta alteração poderia chegar sobre seu ambiente.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    • Marcado como Resposta Richard Juhasz segunda-feira, 28 de março de 2011 20:03
    quarta-feira, 23 de março de 2011 19:22
    Moderador