none
Lista suspensa RRS feed

  • Pergunta

  • Olá,

    eu estou preparando aqui para o meu trabalho um formulario para impressao utilizado para mensages de fax a serem enviadas. Nos temos em uma planilha uma lista com quase uma centena de commissoes escolares, com o numero de telefone e fax de cada uma. Eu preparei o formulario de forma que nós consigamos selecionar o nome da comissão escolar que queremos enviar o fax enquanto os outros campos ja estao preenchidos já que nunca se alteram. O que eu gostaria de fazer é que o campo fax se preenchesse automaticamente com o numero de fax da comissão correspondente. Como eu poderia fazer isso? Nao consegui pensar em nenhuma opção simples.

    Eu tenho um conhecimento básico de excel, portanto nao exijam muito de mim.

    Obrigado

    segunda-feira, 20 de janeiro de 2014 21:59

Todas as Respostas

  • Este formulário está no mesmo arquivo do excel que a lista de commissoes?

    Você usou qual ferramenta para criar a lista suspensa?

    Se possível poste os nomes dos arquivos excel usados, das planilhas e das colunas envolvidas, não é difícil de fazer o que você precisa, principalmente nas versões mais novas do office.

    Qual o office excel que você está usando?

    quarta-feira, 29 de janeiro de 2014 00:22
  • Caro Adriano,

    O que você deseja fazer é relativamente simples, e creio que com uma fórmula simples de PROCV você resolve seu problema.

    Faça o seguinte:

    1) Caso a planilha de comissões não esteja junto com este formulário que você criou, mova a planilha para dentro do arquivo, pois no seu caso eu não recomendo fazer vínculos com outras pastas de trabalho. Trabalhe com as informações dentro da sua planilha.

    2) A sua formula ficará mais ou menos com essa cara:

    =SEERRO(PROCV(A2;Comissões!A:ZZ;2;FALSO);"-")

    Sendo,

    A2 = A célula onde está a sua lista suspensa

    Comissões!A:ZZ = A planilha de Comissões onde será buscada a informação, sendo que o valor que consta na lista suspensa deve estar na coluna A (Se não estiver na coluna A ou você altera a fórmula para a coluna onde esteja o nome da comissão requerida, ou você ajeita a planilha de comissões para que o nome da comissão fique na coluna A)

    2 = é a coluna índice, no caso é onde está o valor da comissão. Você deve contar a partir da coluna de referencia de busca.

    Se o nome da comissão não for localizado, a célula ficará "-" (Devido a Função SEERRO)

    Tenta ai e qualquer coisa pede ajuda.

    • Sugerido como Resposta Rafael Kamimura quarta-feira, 23 de abril de 2014 19:42
    quarta-feira, 23 de abril de 2014 19:19