none
Problemas de performance Cluster Hyper-V 2012 RRS feed

  • Pergunta

  • Boa noite

    Meus amigos, estou com um problema sério de performance em meu cluster de Hyper-V 2012.

    A situação é a seguinte. Tenho uma solução Cisco UCS com 8 lâminas, conectadas via Interconnect em um storage NetApp.

    As maquinas estão instaladas com Windows server 2012, e estão em cluster. Apresentei para o cluster 4 volumes, 1 quorum e os outros CSVs. Os testes de validação forma feitos direitinho. Os nós estão com a função do Hyper-V instalada, Faiolver, MPIO, tudo igualzinho. Tenho 3 vlans, e configurei os switches virtuais perfeitamente.

    Meu problema, é que de uns 3 meses para cá, alguns nós de forma aleatoria apresentam falha de TIME OUT com meus volumes CSV. Em outros casos, acusa falha do sistema RHS.exe.

    Quando ocorre os travamentos, as VMS perdem conexão com a lun do Storage, e desligam (não todas, apenas as que se encontravam no volume). O Cluster fica com serviço inconstante, as vezes preciso desligar a força o nó travado.

    Só para completar, uma VM em específico, tem 128GB de memória e 1TB de disco (Por conta de uma aplicação QlikView) e acho que ela também esta comprometendo a performance do meu cluster. Tenho duvida na configuração de paginação inteligente. Posso apontar esta configuração para dentro do meu volume CSV no Storage?

    Amigos, qualquer ajuda é bem vinda. Estou desesperado kkk

    Melha.

    segunda-feira, 27 de outubro de 2014 23:35

Respostas

  • Fala meu amigo.

    Seguinte, pelo que você relatou, existe uma maquina virtual que esta matando a performance do seu ambiente.

    Eu passei por uma situação similar e consegui estabilizar a situação.  Fiz o seguinte. Para isolar o problema, tirei um nó do meu cluster, apresentei um volume dedicado para este nó, e movi a VM para este ambiente isolado.

    Esta ação, foi realizada numa sexta feira, e fiquei acompanhando por cerca de uma semana. O Cluster estabilizou completamente, e a VM, estando isolada e fora de um volume CSV, também não apresentou mais nenhuma falha.

    Ainda estou tratando com os especialistas QlikView, as melhores práticas para virtualização de servidores em Hyper-V, com a aplicação. O fato é que ao menos o ambiente voltou a ficar estável.

    Verifique a possibilidade de isolar esta VM. E procure os administradores da aplicação, para conseguir algum apoio para customização do ambiente.

    Se eu tiver alguma novidade por parte do QlikView, pode ficar tranquilo que postarei aqui no Forum.

    Abs

    Walter Teixeira

    • Marcado como Resposta MMelhaSP quinta-feira, 6 de novembro de 2014 03:48
    domingo, 2 de novembro de 2014 23:08

Todas as Respostas

  • A VM esta usando memoria dinamica?

    terça-feira, 28 de outubro de 2014 02:07
  • Estática.

    Nenhum MVP Hyper-V para me dar uma forcinha? rs

    Agradeço a atenção

    Melha.

    terça-feira, 28 de outubro de 2014 16:05
  • Ninguem passou por uma situação similar?

    terça-feira, 28 de outubro de 2014 20:00
  • Boa tarde Melha,

    tem como gerar um Event Viewer para nos por favor para ver os erros que esta passando ?

    Obrigado


    Matheus Leopardi Mello Canelada Campos

    Esse conteudo e fornecido sem garantias de qualquer tipo, seja expressa ou implicita.

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as respostas que resolveram o seu problema. Essa e uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais facil para os outros visitantes encontrarem a resolusao mais tarde.

    sexta-feira, 31 de outubro de 2014 15:29
  • Fala meu amigo.

    Seguinte, pelo que você relatou, existe uma maquina virtual que esta matando a performance do seu ambiente.

    Eu passei por uma situação similar e consegui estabilizar a situação.  Fiz o seguinte. Para isolar o problema, tirei um nó do meu cluster, apresentei um volume dedicado para este nó, e movi a VM para este ambiente isolado.

    Esta ação, foi realizada numa sexta feira, e fiquei acompanhando por cerca de uma semana. O Cluster estabilizou completamente, e a VM, estando isolada e fora de um volume CSV, também não apresentou mais nenhuma falha.

    Ainda estou tratando com os especialistas QlikView, as melhores práticas para virtualização de servidores em Hyper-V, com a aplicação. O fato é que ao menos o ambiente voltou a ficar estável.

    Verifique a possibilidade de isolar esta VM. E procure os administradores da aplicação, para conseguir algum apoio para customização do ambiente.

    Se eu tiver alguma novidade por parte do QlikView, pode ficar tranquilo que postarei aqui no Forum.

    Abs

    Walter Teixeira

    • Marcado como Resposta MMelhaSP quinta-feira, 6 de novembro de 2014 03:48
    domingo, 2 de novembro de 2014 23:08
  • Valeu a dica Walter.

    vou ver se é possivel fazer isso aqui.

    depois retorno.

    Melha.

    segunda-feira, 3 de novembro de 2014 01:22
  • bacana.

    Ficamos na expectativa da resposta.

    abs

    segunda-feira, 3 de novembro de 2014 12:17
  • Opa, tudo bem?

    Este tipo de comportamento com erros no RHS e perda de conectividade com a storage pode estar relacionado a filter drivers de anti-virus que não são cluster aware, e também a alta latência durante a comunicação com a storage.

    Sugiro que você execute o comando FLTMC INTANCES para identificar os filter drivers presentes no nó, e na sequência remova o respectivo anti-virus para realizar os testes.

    Sugiro também que você execute um monitoramento perfmon, adicione os contadores Physical Disk e Logical Disk\avg disc sec Write e também avg disc sec Read. Caso a latência seja maior que 0,025 isso pode indicar problemas com sua storage ou meio físico, neste caso faça uma validação com o suporte do vendor para confirmar se tudo está correto. O ideal é que a latência tanto para escrita quanto para leitura seja menor que 0,05, ou seja, 5 milissegundos.

    Espero ter ajudado! :D


    Achou útil? Classifique! Acessem nosso blog: http://www.dsindepth.com.br

    segunda-feira, 3 de novembro de 2014 12:39
  • Valeu pela ajuda Fernando. Vou checar.
    segunda-feira, 3 de novembro de 2014 13:30
  • Bacana as ideias Fernando.

    Por aqui, nosso analista de Storage fez todos os testes referentes a latência, extraiu relatórios que não indicaram nada.

    Mas acho extremamente importantes a realização deste Troubleshooting.

    abs

    segunda-feira, 3 de novembro de 2014 13:42
  • Batata Walter.

    Tirei a VM e botei noutro host, sem usar um CSV.

    Funcionou redondo.

    Agora vou ter mais tempo para analisar. Mas o ambiente normalizo.

    obrigado a todos pela atenção.

    Melha.

    quinta-feira, 6 de novembro de 2014 03:48