none
Aplicação ASP mutiplicando valor numero por 100 RRS feed

  • Pergunta

  • Olá pessoal

    Tenho uma aplicação ASP rodando no IIS6 (WinSrv2003-ENG), porém neste servidor minha aplicação funciona corretamente,.
    Mas, estamos realizando uma migração da aplicação do IIS 6.0 para o IIS 7.5(winSRv2008) e quando eu rodo a minha aplicação ASP pelo IIS 7.5, um valor de um campo que por exemplo esta defindo por 1 ele mutiplica 100 vezes e sendo assim ele grava este valor errado no meu banco SQL 2000.
    Quando eua abro aplicação no IIS 6, ele grava corretamene o valor, mas quando abro pelo IIS 7.5 ele grava mas com o valor 100 vezes mais.
    Lembrando que quando executo a aplicação pelo IIS 6 ou pelo IIS 7, uso o mesmo banco SQL 2000.

    Obrigado desde já.

    Marco Antonio Silva - MCP / MCSA Security / MCSA Messaging / Small Business Specialist
    terça-feira, 20 de outubro de 2009 19:47

Respostas

  • Pessoal,

    Incrivel que parece, resolvi este problema apenas mudando na hora da instalação do Windows SRv 2008 a opção de idioma. O Defaul é Inglês, mudei para Português e o problema foi solucionado.
    Marco Antonio Silva - MCP / MCSA Security / MCSA Messaging / MCTS
    • Marcado como Resposta pabloce sexta-feira, 8 de janeiro de 2010 18:40
    quinta-feira, 7 de janeiro de 2010 00:42

Todas as Respostas

  • Fala Marco!

    Tudo bem?

    Meu amigo, o ideal é que antes da migração fosse feito um teste de compatibilidade para detectar estes tipos de problemas, ou seja, o IIS 7.5 deveria ter sido homologado como como host para a sua aplicação antes de ter sido colocado em produção.

    Bem, sem ver, acredito que o problema esteja no desenvolvimento da aplicação e não no servidor Web. Provavelmente alguma parte do seu código busca alguma funcionalidade que só era usada em versões anteriores do IIS. Uma idéia interessante, uma vez que o servidor já foi atualizado, seria migrar a aplicação para o ASP.NET. O ASP é uma tecnologia legada e mantê-la no seu ambiente só gera custos e perda de tempo (veja pelo problema que você está enfrentando). Se esta aplicação já estivesse funcionando em ASP.NET, essa dor de cabeça da migração não teria sido sentida.

    Um abraço,

    Igor Humberto
    terça-feira, 20 de outubro de 2009 20:21
  • Olá Igor,

    Desculpe em não informar corretamente, a aplicação é asp.net.
    Assim, ainda estamos homologando, ainda não migramos por completo.
    O estranho é que quando eu uso software para efetuar o debug, ele mostra que quando eu executo aplicação pelo IIS 6 ele trás pelo formato iso8859-1 e quando executo pelo IIS 7.5 ele mostra este mesmo site porém mostra como utf-8.

    Eu até vi uma documentação que informa que o utf-8 é default no IIS 7.
    Realizei alteração no IIS no Net Globalization para trabalhar com iso8859-1 porém não teve efeito.
    Realizei também alteração no registry do WinSRv2008 (IIS7.5) para mudar o layout default (international) de ENG para PT-BR mas também não executou.


    Marco Antonio Silva - MCP / MCSA Security / MCSA Messaging / Small Business Specialist
    terça-feira, 20 de outubro de 2009 20:24
  • Marco, normalmente a migração de aplicações ASP.NET não possui traumas. Porém, não conheço uma ferramenta que faça essa migração de forma automatizada. Sendo assim, basta que você faça as mesmas configurações que foram feitas no antigo servidor no novo. Como disse, não estou vendo o seu servidor, o que dificulta o troubleshooting do problema. Quando existe reclamação neste tipo de migração, normalmente falamos mais de configurações relacionadas aos padrões de segurança do IIS 7.5, que é mais rígido que o IIS 6.

    Um abraço,

    Igor Humberto
    terça-feira, 20 de outubro de 2009 22:37
  • Pessoal,

    Incrivel que parece, resolvi este problema apenas mudando na hora da instalação do Windows SRv 2008 a opção de idioma. O Defaul é Inglês, mudei para Português e o problema foi solucionado.
    Marco Antonio Silva - MCP / MCSA Security / MCSA Messaging / MCTS
    • Marcado como Resposta pabloce sexta-feira, 8 de janeiro de 2010 18:40
    quinta-feira, 7 de janeiro de 2010 00:42