none
Script de logon x TS RRS feed

  • Pergunta

  • Pessoal,

    Tenho agora a seguinte situação:

    matriz
    rede interna: 192.168.0.X/24

    filial
    rede interna: 192.168.2.Y/24

    Em ambos os sites eu possuo um ISA em quem a conexão site to site está funcionado de forma correta. Acontece que na minha filial eu possuo uma estação de trabalha (192.168.2.15) que possui uma LX300 que está compartilhada. Essa mesma estação acessa via TS uma aplicação da matriz (por dentro da VPN) que imprime somente através da LPT1. Ou seja a estação está com ip 192.168.2.15 --> via TS w2k3 (site to site) --> acessa 192.168.0.2, no processo de logon é executado o seguinte batch:

    @echo off
    net use lpt1 /del
    net use ltpt1 \\192.168.15.2\lx300 /y

    Porém quando esse batch está sendo executado ele pede um usuário e senha, vale lembrar que na matriz tudo está dentro do dominio e na filial está tudo como grupo de trabalho (4 desktops). Na impressora dei permissão "controle total" para o grupo "todos" (a título de teste) e mesmo assim não tive êxito.

    Alguém tem alguma sugestão para resolver esse problema?

    Att,



    Denis Leal
    segunda-feira, 30 de maio de 2011 20:56

Respostas

  • Oi Denis,

    Seria algo assim:

    net use ltpt1 \\192.168.15.2\lx300 /user:192.168.15.2\usuario senha /y

    Neste caso, você pode testar com o usuário Administrador do host 192.168.15.2 e a sua respectiva senha.

    Em caso de dúvidas, digite net use /? para obter mais informações sobre o comando.

    Abs.


    Paul Haro - Microsoft Certified Professional
    quinta-feira, 2 de junho de 2011 18:03
    Moderador

Todas as Respostas

  • Denis,

    Você está logando num domínio, tentando mapear um recurso que pertence a um grupo de trabalho.

    Faça o seguinte teste:

    Incremente o comando net use, utilizando a opção /USER, no qual você deverá informar um usuário e senha existentes no desktop onde a impressora está fisicamente instalada.

    Outra opção, é adicionar o desktop citado acima no domínio ao qual o servidor TS pertence.

    Faça os testes e poste o resultado.

    Abs.


    Paul Haro - Microsoft Certified Professional
    terça-feira, 31 de maio de 2011 00:37
    Moderador
  • Paulo,

    Desculpe a demora, mas eu sou péssimo em scripts. Você pode me dar um exemplo?

    Att,


    Denis Leal
    quarta-feira, 1 de junho de 2011 13:59
  • Oi Denis,

    Seria algo assim:

    net use ltpt1 \\192.168.15.2\lx300 /user:192.168.15.2\usuario senha /y

    Neste caso, você pode testar com o usuário Administrador do host 192.168.15.2 e a sua respectiva senha.

    Em caso de dúvidas, digite net use /? para obter mais informações sobre o comando.

    Abs.


    Paul Haro - Microsoft Certified Professional
    quinta-feira, 2 de junho de 2011 18:03
    Moderador
  • Paul,

    Vou ver se consigo testar hoje a noite. Caso consiga, amanhã dou parecer aqui.

    Valeu mesmo pela força!

    Att,


    Denis Leal
    quinta-feira, 2 de junho de 2011 20:33
  • Olá Denis, Alguma novidade ? Obrigado.
    Paul Haro - Microsoft Certified Professional
    segunda-feira, 6 de junho de 2011 11:39
    Moderador
  • Senhores,

    Ao conectar via TS e marcar a opção de carregar as inpressoras a mesma não é mapeada para impressão ?

     

    segunda-feira, 6 de junho de 2011 14:29
    Moderador