none
IIS não inicia um único site. RRS feed

  • Pergunta

  • Boa Tarde Pessoal;

    Estou com um problema incomum.

    Tenho um servidor web com o IIS instalado e configurado e com varios sites criados.

    Sendo que um site especifico não funciona.

    Foi verificado o servidor. Paramos o IIS e startamos novamente. Verificamos permissão, e nada faz esse site ficar on-line.

    O mesmo presenta o erro: HTTP 500 - O navegador não pode abrir a página. 

    • Movido Felipe Feydit terça-feira, 7 de fevereiro de 2012 19:27 (De:Windows Server 2003)
    terça-feira, 7 de fevereiro de 2012 15:28

Respostas

  •  authenticationType="NOT_AVAILABLE"               activityId="{00000000-0000-0000-1A0B-0080010000E3}"
                   failureReason="STATUS_CODE"
                   statusCode="401.2"
                   triggerStatusCode="401.2"

    401.2 - Falha no logon devido à configuração do servidor.


    "Eu nunca vi nada selvagem ter pena de si mesmo, um pássaro vai cair morto de um galho, sem jamais ter sentido pena de si mesmo."

    segunda-feira, 13 de fevereiro de 2012 19:09
  • Conforme apontado pelo Felipe, verifique o Usuário que está executando o Application Pool, além das permissões NTFS da pasta que está hospedado o site.

    []s


    Erick Albuquerque | Microsoft MVP
    MVP Profile | Twitter | Linkedin | http://iisbrasil.wordpress.com

    sexta-feira, 17 de fevereiro de 2012 16:18
    Moderador

Todas as Respostas

  • Vocês precisa identificar o que esta causando a falha.

    se for ASP , pode configurar na opção ASP para mostrar o erro no browser..

    pode também habilitar o log de rastreamento de falhas e configurar para rastrear o erro 500 ou 404, no seu caso 500

    e verificar os arquivos .xml criados que vão te dizer o problema ou até mesmo analisar os eventos no windows.

    abs,


    "Eu nunca vi nada selvagem ter pena de si mesmo, um pássaro vai cair morto de um galho, sem jamais ter sentido pena de si mesmo."

    terça-feira, 7 de fevereiro de 2012 19:26
  • Robson, poderia dar mais detalhes referente ao erro 500?

    []s


    Erick Albuquerque | Microsoft MVP
    MVP Profile | Twitter | Linkedin | http://iisbrasil.wordpress.com

    sexta-feira, 10 de fevereiro de 2012 13:58
    Moderador
  • Cara o estranho é que não tem muitos detalhes.

    Ao visializar o site o mesmo apresenta:

    The website cannot display the page

    <id id="http500"> HTTP 500</id>
     

    Most likely causes:

    • The website is under maintenance.
    • The website has a programming error.

    segunda-feira, 13 de fevereiro de 2012 15:03
  • Configurei o "Request Tracing" no IIS e o mesmo gerou o seguinte log de erro em XML:

    <?xml version="1.0" encoding="UTF-8" ?>
    <?xml-stylesheet type='text/xsl' href='freb.xsl'?>
    <!-- saved from url=(0014)about:internet -->
    <failedRequest url="http://sistemaswebqa:80/"
                   siteId="1156966508"
                   appPoolId="SistemasWebQA - 80"
                   processId="4156"
                   verb="GET"
                   authenticationType="NOT_AVAILABLE"               activityId="{00000000-0000-0000-1A0B-0080010000E3}"
                   failureReason="STATUS_CODE"
                   statusCode="401.2"
                   triggerStatusCode="401.2"
                   timeTaken="16"
                   xmlns:freb="http://schemas.microsoft.com/win/2006/06/iis/freb"
                   >
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
     <System>
      <Provider Name="WWW Server" Guid="{3A2A4E84-4C21-4981-AE10-3FDA0D9B0F83}"/>
      <EventID>0</EventID>
      <Version>1</Version>
      <Level>0</Level>
      <Opcode>1</Opcode>
      <Keywords>0x0</Keywords>
      <TimeCreated SystemTime="2012-02-13T15:08:15.446Z"/>
      <Correlation ActivityID="{00000000-0000-0000-1A0B-0080010000E3}"/>
      <Execution ProcessID="4156" ThreadID="3064"/>
      <Computer>BRCORPIISQA1</Computer>
     </System>
     <EventData>
      <Data Name="ContextId">{00000000-0000-0000-1A0B-0080010000E3}</Data>
      <Data Name="SiteId">1156966508</Data>
      <Data Name="AppPoolId">SistemasWebQA - 80</Data>
      <Data Name="ConnId">1610615577</Data>
      <Data Name="RawConnId">0</Data>
      <Data Name="RequestURL">http://sistemaswebqa:80/</Data>
      <Data Name="RequestVerb">GET</Data>
     </EventData>
     <RenderingInfo Culture="en-US">
      <Opcode>GENERAL_REQUEST_START</Opcode>
     </RenderingInfo>
     <ExtendedTracingInfo xmlns="http://schemas.microsoft.com/win/2004/08/events/trace">
      <EventGuid>{D42CF7EF-DE92-473E-8B6C-621EA663113A}</EventGuid>
     </ExtendedTracingInfo>
    </Event>
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
     <System>
      <Provider Name="WWW Server" Guid="{3A2A4E84-4C21-4981-AE10-3FDA0D9B0F83}"/>
      <EventID>0</EventID>
      <Version>1</Version>
      <Level>5</Level>
      <Opcode>4</Opcode>
      <Keywords>0x100</Keywords>
      <TimeCreated SystemTime="2012-02-13T15:08:15.446Z"/>
      <Correlation ActivityID="{00000000-0000-0000-1A0B-0080010000E3}"/>
      <Execution ProcessID="4156" ThreadID="3064"/>
      <Computer>BRCORPIISQA1</Computer>
     </System>
     <EventData>
      <Data Name="ContextId">{00000000-0000-0000-1A0B-0080010000E3}</Data>
      <Data Name="ModuleName">RequestMonitorModule</Data>
     </EventData>
     <RenderingInfo Culture="en-US">
      <Opcode>PRE_BEGIN_REQUEST_START</Opcode>
      <Keywords>
       <Keyword>RequestNotifications</Keyword>
      </Keywords>
     </RenderingInfo>
     <ExtendedTracingInfo xmlns="http://schemas.microsoft.com/win/2004/08/events/trace">
      <EventGuid>{002E91E3-E7AE-44AB-8E07-99230FFA6ADE}</EventGuid>
     </ExtendedTracingInfo>
    </Event>
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
     <System>
      <Provider Name="WWW Server" Guid="{3A2A4E84-4C21-4981-AE10-3FDA0D9B0F83}"/>
      <EventID>0</EventID>
      <Version>1</Version>
      <Level>5</Level>
      <Opcode>5</Opcode>
      <Keywords>0x100</Keywords>
      <TimeCreated SystemTime="2012-02-13T15:08:15.446Z"/>
      <Correlation ActivityID="{00000000-0000-0000-1A0B-0080010000E3}"/>
      <Execution ProcessID="4156" ThreadID="3064"/>
      <Computer>BRCORPIISQA1</Computer>
     </System>
     <EventData>
      <Data Name="ContextId">{00000000-0000-0000-1A0B-0080010000E3}</Data>
      <Data Name="ModuleName">RequestMonitorModule</Data>
      <Data Name="NotificationStatus">0</Data>
     </EventData>
     <RenderingInfo Culture="en-US">
      <Opcode>PRE_BEGIN_REQUEST_END</Opcode>
      <Keywords>
       <Keyword>RequestNotifications</Keyword>
      </Keywords>
      <freb:Description Data="NotificationStatus">NOTIFICATION_CONTINUE</freb:Description>
     </RenderingInfo>
     <ExtendedTracingInfo xmlns="http://schemas.microsoft.com/win/2004/08/events/trace">
      <EventGuid>{002E91E3-E7AE-44AB-8E07-99230FFA6ADE}</EventGuid>
     </ExtendedTracingInfo>
    </Event>
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
     <System>
      <Provider Name="WWW Server" Guid="{3A2A4E84-4C21-4981-AE10-3FDA0D9B0F83}"/>
      <EventID>0</EventID>
      <Version>1</Version>
      <Level>5</Level>
      <Opcode>4</Opcode>
      <Keywords>0x100</Keywords>
      <TimeCreated SystemTime="2012-02-13T15:08:15.446Z"/>
      <Correlation ActivityID="{00000000-0000-0000-1A0B-0080010000E3}"/>
      <Execution ProcessID="4156" ThreadID="3064"/>
      <Computer>BRCORPIISQA1</Computer>
     </System>
     <EventData>
      <Data Name="ContextId">{00000000-0000-0000-1A0B-0080010000E3}</Data>
      <Data Name="ModuleName">IsapiFilterModule</Data>
     </EventData>
     <RenderingInfo Culture="en-US">
      <Opcode>PRE_BEGIN_REQUEST_START</Opcode>
      <Keywords>
       <Keyword>RequestNotifications</Keyword>
      </Keywords>
     </RenderingInfo>
     <ExtendedTracingInfo xmlns="http://schemas.microsoft.com/win/2004/08/events/trace">
      <EventGuid>{002E91E3-E7AE-44AB-8E07-99230FFA6ADE}</EventGuid>
     </ExtendedTracingInfo>
    </Event>
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
     <System>
      <Provider Name="WWW Server" Guid="{3A2A4E84-4C21-4981-AE10-3FDA0D9B0F83}"/>
      <EventID>0</EventID>
      <Version>1</Version>
      <Level>4</Level>
      <Opcode>13</Opcode>
      <Keywords>0x8</Keywords>
      <TimeCreated SystemTime="2012-02-13T15:08:15.446Z"/>
      <Correlation ActivityID="{00000000-0000-0000-1A0B-0080010000E3}"/>
      <Execution ProcessID="4156" ThreadID="3064"/>
      <Computer>BRCORPIISQA1</Computer>
     </System>
     <EventData>
      <Data Name="ContextId">{00000000-0000-0000-1A0B-0080010000E3}</Data>
     </EventData>
     <RenderingInfo Culture="en-US">
      <Opcode>FILTER_PREPROC_HEADERS_START</Opcode>
      <Keywords>
       <Keyword>Filter</Keyword>
      </Keywords>
     </RenderingInfo>
     
    segunda-feira, 13 de fevereiro de 2012 15:21
  •  authenticationType="NOT_AVAILABLE"               activityId="{00000000-0000-0000-1A0B-0080010000E3}"
                   failureReason="STATUS_CODE"
                   statusCode="401.2"
                   triggerStatusCode="401.2"

    401.2 - Falha no logon devido à configuração do servidor.


    "Eu nunca vi nada selvagem ter pena de si mesmo, um pássaro vai cair morto de um galho, sem jamais ter sentido pena de si mesmo."

    segunda-feira, 13 de fevereiro de 2012 19:09
  • Alguma novidade ?

    "Eu nunca vi nada selvagem ter pena de si mesmo, um pássaro vai cair morto de um galho, sem jamais ter sentido pena de si mesmo."

    quarta-feira, 15 de fevereiro de 2012 18:16
  • Novidades Robson ?

    "Eu nunca vi nada selvagem ter pena de si mesmo, um pássaro vai cair morto de um galho, sem jamais ter sentido pena de si mesmo."

    quinta-feira, 16 de fevereiro de 2012 19:57
  • Conforme apontado pelo Felipe, verifique o Usuário que está executando o Application Pool, além das permissões NTFS da pasta que está hospedado o site.

    []s


    Erick Albuquerque | Microsoft MVP
    MVP Profile | Twitter | Linkedin | http://iisbrasil.wordpress.com

    sexta-feira, 17 de fevereiro de 2012 16:18
    Moderador