none
Erro no Roteamento - Windows Server 2008 RRS feed

  • Pergunta

  • Olá a todos!

    Estou com um grande problema que não consigo resolver de forma alguma.

    Esta é a estrutura da minha rede... na verdade há outras filiais, mas não vem ao caso...

    Servidor PRINCIPAL - 192.168.137.10

    CISCO VPN 1 - 192.168.137.1

    INTERNET

    CISCO VPN 2 - 192.168.130.1

    SERVIDOR SECUNDARIO - 192.168.130.10 (principal),  192.168.1.121 (hospital), 10.8.0.9 (virtual)

    * O Servidor Secundário possui duas placas de rede, sendo uma ligada à rede principal (192.168.130.x) e outra ligada à rede do hospital (192.168.1.x) para utilização de um sistema...

    * O Cisco VPN 2 está com uma rota estática configurada corretamente e funcional (testei com o comando tracert). Esta rota pega a rede 192.168.1.x e joga para o gateway 192.168.130.10 (Servidor Secundário)

    * O Servidor Secundário está com o Roteamento e Acesso Remoto Configurado, mas não funciona de forma alguma!! Já desisntalei, instalei, configurei inúmeras rotas estáticas (sem necessidade) e nada de funcionar... Na dúvida, eu criei outra rede virtual (10.8.0.1) e tentei traçar as rotas mas de jeito nenhum funciona...

    Eu não sei se há alguma permissão a ser concedida pelo servidor principal ou se há necessidade de modificar o firewall, podem me ajudar??

    quarta-feira, 3 de julho de 2013 20:29

Respostas

  • Weslley, se você puder enviar uma imagem com o desenho da sua topologia facilita.

    Segue algumas perguntas:

    1. O roteador da filial não pode fazer o roteamento para a rede do hospital ao invés de incluir mais um "roteador" na rede?
    2. Você realmente precisa do servidor secundário para acesso à rede do Hospital? Através somente do VPN Cisco (que também deve ser firewall) você não tem acesso à essa rede (192.168.0.0)?
    3. Qual a finalidade do servidor, se necessário, você apenas incluindo ele na rede e com somente uma placa de rede (sem necessidade de fazer roteamento), não atenderia seu cenário?

    Att, Nino - Engº. de Projetos - http://www.TInoBar.com.br

    sexta-feira, 5 de julho de 2013 13:42

Todas as Respostas

  • Weslley, ainda não ficou muito clara sua estrutura e dúvida. Você está estabelecendo uma VPN site-to-site via Cisco VPN e ainda assim está tentando estabelecer VPN da rede primária para a do servidor secundário? Existe comunicação entre ambas as redes e trafego de ida e volta? Será interessante também rever o firewall para saber se não há nenhum bloqueio para os protocolos e redes que deseja.

    Att, Nino - Engº. de Projetos - http://www.TInoBar.com.br

    quinta-feira, 4 de julho de 2013 01:12
  • Olá Nino, obrigado pela resposta...

    Sim, há duas redes conectadas por uma VPN site-to-site via Cisco VPN. Estão funcionando perfeitamente, sem nenhum problema.

    Agora preciso conectar à rede secundária uma nova rede, que é a do hospital onde esta filial está.

    Na estrutura da filial está um servidor com duas placas de rede, sendo a principal 192.168.130.10 que está ligada à rede interna e roteador cisco e uma segunda placa de rede, conectada à rede do hospital com o ip 192.168.1.121...

    Acreditava que a simples configuração de roteamento neste servidor já resolveria a questão, mas não resolveu, este servidor não está roteando nenhuma rota...

    Para tirar qualquer dúvida, eu criei uma nova rede virtual (10.8.0.x) e tentei rotear para a rede interna desta filial (192.168.130.x), mas não deu certo, ou seja, DE FATO, o servidor secundário não está roteando...

    Eu não sei o que verificar no firewall para saber se tem algo bloqueando as rotas, tem algum artigo sobre isso?

    quinta-feira, 4 de julho de 2013 03:20
  • Weslley, aparentemente o problema está nas configurações de rede do servidor secundário. Pelo que entendi sua configuração deve ficar assim:

    - NIC Principal:

       . IP: 192.168.130.10/24

       . Gateway: 192.168.130.1 (IP do roteador da rede 192.168.130.0)

       . DNS: 192.168.130.10 (IP do servidor DNS da rede 192.168.130.0)

    - NIC Hospital:

       . IP: 192.168.1.121/24

       . Gateway: em branco

       . DNS: 192.168.1.121 (IP do servidor DNS da rede 192.168.1.0)

    - As estações da rede 192.168.1.0 (Hospital), devem ter IP dentro do range 192.168.1.1~254, Gateway 192.168.1.121 e DNS dessa rede (mesmo da NIC Hospital do servidor).


    Att, Nino - Engº. de Projetos - http://www.TInoBar.com.br


    • Editado Nino TI quinta-feira, 4 de julho de 2013 11:03 pontuação
    quinta-feira, 4 de julho de 2013 11:00
  • Olá Nino,

    Sim, aparentemente o problema está no servidor secundário, especialmente quando ao serviço de roteamento. Ou a questão é o serviço de roteamento ou alguma permissão no firewall e/ou servidor primário.

    As configurações que descreveu estão corretas, está configurada desta forma e o servidor secundário já está na rede do hospital. Eu já executei softwares no servidor acessando a rede no hospital e tudo está completamente funcional.

    O problema reside no roteamento desta rede do hospital para a rede da filial, aqui que estou travando.

    Já executei o comando tracert nos computadores da rede filial, o comando chega até o servidor secundário mas não prossegue, ou seja, algo está travando o roteamento desde servidor.

    quinta-feira, 4 de julho de 2013 13:05
  • Weslley, nas propriedades do servidor no RRAS, na aba Geral, certifique-se de que a opção Roteador esteja marcada.

    Segue alguns artigos para referência:


    Att, Nino - Engº. de Projetos - http://www.TInoBar.com.br

    quinta-feira, 4 de julho de 2013 15:02
  • Opção Roteador já estava marcada

    Vi os artigos de referencia e realizei algumas das configurações sugeridas mas nada de funcionar...

    Aliás, fiz outros teste aqui e não consegui nada de útil que possa ajudar na solução... Até desabilitei o firewall do windows para ver se ia, mas nada...

    Uma coisa é certa, cada vez tenho mais certeza que o problema está no roteamento deste servidor secundário ou alguma permissão que este servidor tem que ter no domínio... Tanto é que testei agora a pouco um roteamento de uma rede virtual no servidor principal e deu tudo certo, sem problema algum por lá...

    Vi um artigo que dizia para colocar o servidor no grupo RAS and IAS Servers, mas não resolveu o problema...

    Também fiz mudanças na rede do cliente apontando diretamente o servidor secundário como gateway e nada de resolver...

    quinta-feira, 4 de julho de 2013 16:54
  • Weslley, realmente está estranho. No prompt de comando executa o "route print" para saber se a tabela tem informações e verifica os logs de eventos para saber se tem algo que possa dar algum direcionamento.

    Att, Nino - Engº. de Projetos - http://www.TInoBar.com.br

    quinta-feira, 4 de julho de 2013 17:08

  • C:\Users\Administrador.HEMATO>route print
    ===========================================================================
    Lista de interfaces
     13 ...90 f6 52 18 5f 25 ...... Realtek PCI GBE Family Controller #2
     12 ...90 f6 52 18 3a 7d ...... Realtek PCI GBE Family Controller
      1 ........................... Software Loopback Interface 1
     17 ...02 00 54 55 4e 01 ...... Teredo Tunneling Pseudo-Interface
     18 ...00 00 00 00 00 00 00 e0  isatap.{0A865D2C-9AD2-4310-8D9D-A5FBF09DF6AC}
     26 ...00 00 00 00 00 00 00 e0  Adaptador do Microsoft ISATAP #4
    ===========================================================================

    Tabela de rotas IPv4
    ===========================================================================
    Rotas ativas:
    Endereço de rede          Máscara   Ender. gateway       Interface   Custo
              0.0.0.0          0.0.0.0    192.168.130.1   192.168.130.10    276
              0.0.0.0          0.0.0.0      192.168.0.5    192.168.1.121    276
            127.0.0.0        255.0.0.0      No vínculo         127.0.0.1    306
            127.0.0.1  255.255.255.255      No vínculo         127.0.0.1    306
      127.255.255.255  255.255.255.255      No vínculo         127.0.0.1    306
          192.168.0.0    255.255.254.0      No vínculo     192.168.1.121    276
        192.168.1.121  255.255.255.255      No vínculo     192.168.1.121    276
        192.168.1.255  255.255.255.255      No vínculo     192.168.1.121    276
        192.168.130.0    255.255.255.0      No vínculo    192.168.130.10    276
       192.168.130.10  255.255.255.255      No vínculo    192.168.130.10    276
      192.168.130.255  255.255.255.255      No vínculo    192.168.130.10    276
            224.0.0.0        240.0.0.0      No vínculo         127.0.0.1    306
            224.0.0.0        240.0.0.0      No vínculo     192.168.1.121    276
            224.0.0.0        240.0.0.0      No vínculo    192.168.130.10    276
      255.255.255.255  255.255.255.255      No vínculo         127.0.0.1    306
      255.255.255.255  255.255.255.255      No vínculo     192.168.1.121    276
      255.255.255.255  255.255.255.255      No vínculo    192.168.130.10    276
    ===========================================================================
    Rotas persistentes:
      Endereço de rede         Máscara  Ender. gateway    Custo
              0.0.0.0          0.0.0.0    192.168.130.1  Padrão
              0.0.0.0          0.0.0.0      192.168.0.5  Padrão
    ===========================================================================

    Tabela de rotas IPv6
    ===========================================================================
    Rotas ativas:
     Se destino de rede de métrica      Gateway
      1    306 ::1/128                  No vínculo
     13    276 fe80::/64                No vínculo
     12    276 fe80::/64                No vínculo
     12    276 fe80::9037:2f7c:243:3b21/128
                                        No vínculo
     13    276 fe80::d5ce:caa2:4ef6:74ff/128
                                        No vínculo
      1    306 ff00::/8                 No vínculo
     13    276 ff00::/8                 No vínculo
     12    276 ff00::/8                 No vínculo
    ===========================================================================
    Rotas persistentes:
      Nenhuma

    C:\Users\Administrador.HEMATO>
    quinta-feira, 4 de julho de 2013 17:15
  • Deixei rodando o ping em um computador e nenhum log é gerado...
    quinta-feira, 4 de julho de 2013 17:23
  • Weslley, no servidor secundário, altera a máscara de rede da NIC com IP 192.168.1.121 (Hospital) para 255.255.254.0 e tenta de uma estação dessa mesma rede (Hospital) pingar o IP 192.168.130.10.

    Talvez seja necessário reiniciar o serviço do RRAS e na estação configurar a máscara também. Somente para teste, configura IP estático em uma estação, porque se resolver o problema e estiver utilizando servidor DHCP, será necessário reconfigurar o escopo DHCP.


    Att, Nino - Engº. de Projetos - http://www.TInoBar.com.br

    quinta-feira, 4 de julho de 2013 17:46
  • Então, ai temos um problema, eu não tenho acesso às máquinas do hospital, apenas acessarei a rede deles...

    está 255.255.254.0 pois foi isso que me passaram, eis que compreende as redes 192.168.0.x e 192.168.1.x, o ip do servidor secundario esta 192.168.1.121...

    De qualquer forma, para testar, mudei para 255.255.255.0 e tentei pingar a maquina 192.168.1.100. Do Servidor secundário sem problema de acesso, da minha rede não pinga de forma alguma...

    Na máquina que tenho acesso coloquei ip fixo com o gateway apontando para meu servidor e não funcionou...

    Estou pensando em configurar uma outra máquina com windows server 2008 e colocar no lugar desta para ver se as rotas passam, mas isso dará para fazer apenas no final de semana...

    quinta-feira, 4 de julho de 2013 18:01
  • Weslley, se você puder enviar uma imagem com o desenho da sua topologia facilita.

    Segue algumas perguntas:

    1. O roteador da filial não pode fazer o roteamento para a rede do hospital ao invés de incluir mais um "roteador" na rede?
    2. Você realmente precisa do servidor secundário para acesso à rede do Hospital? Através somente do VPN Cisco (que também deve ser firewall) você não tem acesso à essa rede (192.168.0.0)?
    3. Qual a finalidade do servidor, se necessário, você apenas incluindo ele na rede e com somente uma placa de rede (sem necessidade de fazer roteamento), não atenderia seu cenário?

    Att, Nino - Engº. de Projetos - http://www.TInoBar.com.br

    sexta-feira, 5 de julho de 2013 13:42