none
Levando muito tempo para restaurar uma base de dados RRS feed

  • Pergunta

  • Boa tarde a todos,

    galera alguém sabe me informar como posso deixar meu restore mais rápido ?

    Minha configuração de rede

    placas 10 / 100 / 1000

    switch 10 / 100 / 1000

    cabos cat 6

    Discos do server (banco)

    SAS dual port 15k

    Disco do server (bkp)

    Sata 1200

    Estratégia de Backup

    1 Full no domingo 2 diferenciais por dia e backup de log

    Tamanho da base de dados junto com o arquivo de log 

    82 GB

    Tempo que esta levando para restaurar

    2h e 40min

    Obs: temos duas redes, pela qual estou efetuando o restore não roda nada durante o dia...

    quarta-feira, 1 de junho de 2011 18:31

Respostas

  • Bom dia Srs.,

    obrigado pela ajuda, cosnegui resolver o problema.

    Solução:

    Deixei ambas as placas trabalhando a 1GB Full-Duplex.

    caiu de 2h e 40min  p/ 40min

    • Marcado como Resposta Andre_Bel quinta-feira, 2 de junho de 2011 12:32
    quinta-feira, 2 de junho de 2011 12:32

Todas as Respostas

  • Andre,

    Verifique o uso da placa de rede durante o restore e veja quanto ela está usando de tráfego para garantir que ela está trabalhando na sua capacidade máxima.

    Qual o backup você está aplicando nesse tempo, o FULL ou o DIFF?

     

    Att.


    Erickson Ricci SQL Server DBA @ BB Mapfre ericksonricci.wordpress.com MCTS Database Developer 2008, Database Administrator 2008
    quarta-feira, 1 de junho de 2011 18:58
  • Andre,

     

    Utilize a opção MAXTRANSFERSIZE em seu restore, isso fara com que mais bytes sejam trafegados na rede (Claro que se a mesma aceitar e suportar) de uma só vez.

     

    Pode colocar o valor maximo em seu comando 262144 que o sql fara o melhor possivel rs...


    Oracle OCA11g, MCC 2011! Dicas e novidades: www.fabrizziocaputo.wordpress.com
    quarta-feira, 1 de junho de 2011 19:13
    Moderador
  • Andre,

     

    Dá uma olhada na fila de disco no servidor.  Uma fila muito grande (maior que 10) pode impactar diretamente neste tempo de resposta.

     

    Roberto.

    quarta-feira, 1 de junho de 2011 20:05
  • Bom dia Srs.,

    obrigado pela ajuda, cosnegui resolver o problema.

    Solução:

    Deixei ambas as placas trabalhando a 1GB Full-Duplex.

    caiu de 2h e 40min  p/ 40min

    • Marcado como Resposta Andre_Bel quinta-feira, 2 de junho de 2011 12:32
    quinta-feira, 2 de junho de 2011 12:32