locked
WSUS 2.0 Erro na Tarefa de Aprovação Automática RRS feed

  • Pergunta

  • Amigos, estou com um problema na tarefa de aprovação automática do meu WSUS 2, que roda no meu SBS 2003 R2 Premium.
    Ela reporta o erro 0x80131904 que acredito ser falta de permisão para acessar a base.
    Qual seria o procedimento correto para ajustar a segurança dessa base?
    quinta-feira, 13 de agosto de 2009 09:57

Respostas

  • Olá André,

    Veja se te ajuda: http://msmvps.com/blogs/bradley/archive/2008/07/25/how-many-of-you-have-sbs-monitoring-reports-that-as-of-lately-have-gotten-a-little-funky.aspx

    Obs. Porque não aproveita a atualiza o WSUS para 3.0 ?

    Abraço


    MVP - Daniel Santos Blog: http://engdanielc.spaces.live.com/
    quinta-feira, 13 de agosto de 2009 13:21
    Moderador
  • André,

    Vc modificou algum usuário? Se vc removeu o usuario que tinha direito na base do WSUS pode ter gerado o problema.

    Veja se a senha não foi alterada, tb vc deve procurar alguma resposta sobre permissão na base do MSDE (que deve ser a versão que vc utiliza) no forum de SQL Server.

    Grande Abraço!
    Jorge Vera - MCT/MCSA/MCITP/Small Business Specialist
    quinta-feira, 13 de agosto de 2009 21:00
    Moderador
  • André,

    Conforme você comprovou, funciona sim remover e instalar, mas lembre se você for manter o WSUS 2.0 faça backup do antigo DB.

    Se for instalar o WSUS 3.0, realize do zero mesmo, e te falo que é bem melhor.

    Veja que os pré-requisitos devem ser atendidos, um que muitas pessoas esquecem é do Microsoft Reporting Viewer (que é resposnável pelos relatórios).

    Outro pré é o .NET 2.0 (que pode ser ativado no Windows mesmo)

    Bom, espero que tudo fique bem em sua tarefa.

    Grande Abraço!
    Jorge Vera - MCT/MCSA/MCITP/Small Business Specialist
    segunda-feira, 31 de agosto de 2009 01:04
    Moderador

Todas as Respostas

  • Olá André,

    Veja se te ajuda: http://msmvps.com/blogs/bradley/archive/2008/07/25/how-many-of-you-have-sbs-monitoring-reports-that-as-of-lately-have-gotten-a-little-funky.aspx

    Obs. Porque não aproveita a atualiza o WSUS para 3.0 ?

    Abraço


    MVP - Daniel Santos Blog: http://engdanielc.spaces.live.com/
    quinta-feira, 13 de agosto de 2009 13:21
    Moderador
  • Boa tarde Daniel, eu já havia lido esse artigo. Infelizmente só existem relatos de problemas ninguém apontou um caminho.

    Quanto a passar para o 3, existe alguma vantagem prática? Eu tenho servidores com a versão 3 mas no fim fica na mesma. No SBS para manter a integração eu preciso aprovar as atualizações pelo mesmo lugar.
    quinta-feira, 13 de agosto de 2009 16:10
  • André,

    Vc modificou algum usuário? Se vc removeu o usuario que tinha direito na base do WSUS pode ter gerado o problema.

    Veja se a senha não foi alterada, tb vc deve procurar alguma resposta sobre permissão na base do MSDE (que deve ser a versão que vc utiliza) no forum de SQL Server.

    Grande Abraço!
    Jorge Vera - MCT/MCSA/MCITP/Small Business Specialist
    quinta-feira, 13 de agosto de 2009 21:00
    Moderador
  • Jorge é por esse caminho que eu vou. Eu não modifiquei nada, mas acredito que algum patch tenha alterado isso.
    Essa tarefa não tem importância já que eu aprovo todos os KBs manualmente.
    Quero resolver mais para deixar tudo 100%.
    O erro que a tarefa retorna é geralmente de permissão, pelo que me informei.
    quinta-feira, 13 de agosto de 2009 21:43
  • Vou pular direto para o WSUS 3.0 SP2. Será que ele vai conseguir migrar com esse problema na tarefa?
    Alguém já instalou o SP2 do WSUS?
    quarta-feira, 26 de agosto de 2009 21:13
  • André,

    Acredito que o problema possa persistir, pois se você hoje não consegue acesso no banco, na atualização vai acontecer o mesmo.

    Estou procurando no fórum de SQL se tem algum erro relacionado a permissão no banco e como resolver, assim que achar eu posto pra vc.

    Grande Abraço!
    Jorge Vera - MCT/MCSA/MCITP/Small Business Specialist
    sexta-feira, 28 de agosto de 2009 14:36
    Moderador
  • Só para atualizar. Volta e meia a tarefa roda normalmente 0x0.
    Os updates são baixados, a única coisa a mais é ter que aprovar manualmente.
    Caso o update do WSUS 3 SP2 não funcione, vou remover as tecnologias R2 e instalar novamente, depois rodo o WSUS 3 SP2.
    Fiz em laboratório é funcionou.
    Comecei tudo do zero, inclusive a base do WSUS.
    sábado, 29 de agosto de 2009 09:39
  • André,

    Conforme você comprovou, funciona sim remover e instalar, mas lembre se você for manter o WSUS 2.0 faça backup do antigo DB.

    Se for instalar o WSUS 3.0, realize do zero mesmo, e te falo que é bem melhor.

    Veja que os pré-requisitos devem ser atendidos, um que muitas pessoas esquecem é do Microsoft Reporting Viewer (que é resposnável pelos relatórios).

    Outro pré é o .NET 2.0 (que pode ser ativado no Windows mesmo)

    Bom, espero que tudo fique bem em sua tarefa.

    Grande Abraço!
    Jorge Vera - MCT/MCSA/MCITP/Small Business Specialist
    segunda-feira, 31 de agosto de 2009 01:04
    Moderador
  • Bom pessoal, fiz o seguinte.

    Backup da Base.
    Removi as Tecnologias R2;
    Reinstalei as Tecnologias R2;
    Fiz a primeira sincronia manual;
    Instalei o WSUS 3 SP2 Com base zero km;
    Pronto tudo ok.

    Logo que as máquinas atualizaram a GPO todas foram cadastradas automaticamente.
    sexta-feira, 4 de setembro de 2009 17:15