locked
instalar .net 4.5 windows server core RRS feed

  • Pergunta

  • pessoal, montei umas maquinas virtuais windows server, e uma delas é windows core, preciso instalar o sql server nela, e para isso, preciso instalar o .net 4.5, o problema é q o SO informa que o .net 4.5 não é suportado pelo windows core 2008, há alguma forma de contornar isso?

    segue as configurações da minha maquina :

    windows server core 8
    sp2 build 6002
    processador - amd x4 64 bits

    ambiente virtualizado no virtual box.

    Obrigado 

    terça-feira, 10 de dezembro de 2013 00:44

Respostas

  • Bom dia santosthiago, tudo certo?

    Segue a compatibilidade do .Net Framework 4.5 e 4.5.1

    4.5:

    Windows Server 2008 R2 SP1

    64-bit

    The .NET Framework is supported in the Server Core Role with SP1 or later, but isn't supported on Windows Server 2008 R2 for Itanium-Based Systems.

    http://msdn.microsoft.com/en-us/library/8z6watww(v=vs.110).aspx

    4.5.1:

    The .NET Framework 4.5.1 is supported in the Server Core role with Windows Server 2008 R2 SP1 or later.

    http://msdn.microsoft.com/en-us/library/hh925569(v=vs.110).aspxAcredito que a única forma de contornar isso neste caso seria atualizar a sua versão do 2008.


    Luiz Felipe S. T. Costa

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    TechNet Community Support

    terça-feira, 10 de dezembro de 2013 10:11
  • Opa Luiz, muito obrigado pelo auxilio, eu consegui, vi que era a minha versão do windows, era preciso o windows server core R2, depois foi preciso habilitar umas features através do comando dism.e ai eu consegui instalar .net 4.5
    sexta-feira, 13 de dezembro de 2013 01:03

Todas as Respostas

  • Bom dia santosthiago, tudo certo?

    Segue a compatibilidade do .Net Framework 4.5 e 4.5.1

    4.5:

    Windows Server 2008 R2 SP1

    64-bit

    The .NET Framework is supported in the Server Core Role with SP1 or later, but isn't supported on Windows Server 2008 R2 for Itanium-Based Systems.

    http://msdn.microsoft.com/en-us/library/8z6watww(v=vs.110).aspx

    4.5.1:

    The .NET Framework 4.5.1 is supported in the Server Core role with Windows Server 2008 R2 SP1 or later.

    http://msdn.microsoft.com/en-us/library/hh925569(v=vs.110).aspxAcredito que a única forma de contornar isso neste caso seria atualizar a sua versão do 2008.


    Luiz Felipe S. T. Costa

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    TechNet Community Support

    terça-feira, 10 de dezembro de 2013 10:11
  • Então Luiz  , td bom sim, obrigado pela ajuda, mas o server  q eu estou usando está com o sp2, tentei procurar auxilio em outros sites, e vejo muitos falando para executar o comando DISM, o problema é que este comando ambém não é reconhecido

    terça-feira, 10 de dezembro de 2013 23:25
  • A beleza, entendo, então você pode compartilhar certinho a mensagem que aparece quando você tenta instalar?

    E já aproveitando, já levou em consideração o indicado pelo link abaixo?

    http://www.technologyand.me/?p=276


    Luiz Felipe S. T. Costa

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    TechNet Community Support

    quarta-feira, 11 de dezembro de 2013 10:44
  • Opa Luiz, muito obrigado pelo auxilio, eu consegui, vi que era a minha versão do windows, era preciso o windows server core R2, depois foi preciso habilitar umas features através do comando dism.e ai eu consegui instalar .net 4.5
    sexta-feira, 13 de dezembro de 2013 01:03