none
Erro do explorer.exe, "classe não registrada" RRS feed

  • Pergunta

  • Tentei o que tenho visto até agora para resolver o meu problema, mas até agora não tive sucesso. Ontem Explorer.exe começou com a seguinte mensagem: "Classe não registrada". Eu tentei primeiro restaurar o Explorerframe.dll através Run e digitar regsvr32 ExplorerFrame.dll com a dll nova que baixei da web, que funcionou perfeitamente, mas a mensagem de erro "Classe não registrada" persiste.

    Além disso, eu tentei scannow \ sfc.exe, mas quando tento executar o cmd.exe como administrador ele fecha assim que abre assim que eu tentei pensar em Executar e digitei o comand. Cmd.exe aberto e quando eu tentei fazer a varredura ele me retornou com a seguinte mensagem "Programa muito grande para caber na memória".

    Eu também considerei a restauração do sistema, mas não havia nenhum ponto de restauração disponíveis. Quando ligar o computador tentei pressionar F8 e selecionar ", a última configuração de trabalho" ,d e qualquer forma não funcionou também.


    Felizmente
    eu encontrei uma correção da Microsoft quente (KB935855) que resolveu o problema para outras pessoas, mas quando eu tentei instalar ele retornou código de erro 0x80080005. Olhando para a frente para resolver este novo problema eu baixei um outro reparo que parece ser o mesmo com a adição de um V4 no nome, mas isso não funciona tão bem.

    Esse erro parou de todos os programas relacionados com o Windows, incluindo imagens, Internet Explorer e também drivers de áudio parou de funcionar. Pode ser um vírus, mas não é .Reinstalei o Windows recentemente, também faço uso da GDATA e spyware terminator, que não acusaram a presença de vírus ou malware.

    Um adendo, quando tento salvar um arquivo qualquer, surge essa mensagem de erro: 

    C:\Windows\System32\ntshrui.dll não foi criado para ser executado no Windows ou contém algum erro. Tente instalar o programa novamente usando a mídia de instalção original ou contate o administrador ou fornecedor do software para obter suporte

    Tentei reinstalar o ntshrui.dll via Executar mas não consegui nada, volta com o erro afirmando que o módulo foi carregado, mas o ponto de entrada DLLRegisterServer não foi localizado

    Desculpem pelo português tosco aí de cima, tinha digitado em inglês achando que não havia uma comunidade brasileira do TechNet, dai traduzi com o google tradutor quando vos achei


    Existe alguma solução para este tipo de situação?


    Carlos

    quinta-feira, 20 de janeiro de 2011 14:49

Respostas

  • Carlos, sinta-se a vontade, pois estamos aqui realmente para ajudar.

    Bom falando em tópicos de acordo com o que postou, realmente verifique a respeito do .NET e assim, o programa no qual mencionei uma vez instalado ele teria que realmente prosseguir com a instalação, ao menos que esteja algo no computador que impeça, como por exemplo esses comportamentos inesperados que está tendo com um simples comando de ipconfig.

    O link Atualizações da BIOS    http://www.aida64.com/bios-updates que você mesmo encaminhou deve constar a data da versão,e verifique se aplica realmente, o link que ensina como fazer realmente é interessante, porém o processo é simples, somente contar com a sorte de não ocorrer uma queda de energia no momento da atualização rs.

    Se irá resolver não te afirmo, mas pode ajudá-lo com outros já existentes, também gostaria de adicionar para você re-registrar todas as dlls do System32, para isso entre no prompt de comando e digite:

    for /f %s in ('dir /b *.dll') do regsvr32 /s %s

    Verifique o comportamento após este comando. E como mais afundo ainda da situação, somente como adendo, uma reparação pela mídia do SO realmente não minimiza ? Pois os testes que tentou como o SFC para verificar integridades dos arquivos de sistema e restauração porém não disponível, seria uma boa, mas a reparação pode ser que corrija outros tipos de erros mais implícitos.

    Esse comportamento ele é similar a malware no ambiente ou anti-vírus, não desconfiando do que você ja executou na busca, também para "reforçar" ainda mais, use o ComboFix, desenvolvido exclusivamente para malwares que modificam o seu sistema operacional e os erros podem variar. Link:

    http://www.baixaki.com.br/download/combofix.htm

    Abraços.


    Carlos Eduardo Gnochi de Oliveira
    • Marcado como Resposta Richard Juhasz terça-feira, 25 de janeiro de 2011 13:38
    quinta-feira, 20 de janeiro de 2011 20:22
    Moderador

Todas as Respostas

  • Olá Carlos,

    Após todos os passos que você executou e nada ainda, realmente terá que usar alguma ferramenta que faz a monitoração do processo como por exemplo o Debugging Tools:

    http://www.microsoft.com/whdc/devtools/debugging/default.mspx

    Você efetua o download para a versão correspondente a sua arquitetura no fim da página, e na próxima que abrir, no fim também terá lá a versão mais recente. Obs: Não baixe com o SDK

    * Como usar:

    http://support.microsoft.com/kb/286350/en

    - Outra coisa, você já tentou desativar o DEP? Data Execution Prevention ?

    Realmente o programa acima que citei te dará o direcionamento do que pode ter causado. Para análise desse tipo de log que será gerado, faltará symbols para abri-lo por completo, ou seja, somente desenvolvedores, mas após a coleta, poderá me enviar que eu dou uma verificada pra você. Este tipo de comportamento sempre se diz a respeito de produtos de terceiro, ou seja, tente executar o computador em Modo Clean Boot e verifique se o erro também ocorre.

    Abraços.


    Carlos Eduardo Gnochi de Oliveira
    quinta-feira, 20 de janeiro de 2011 15:20
    Moderador
  • Dois Carlos no mesmo fórum...Carlos Eduardo, Carlos Simielli, prazer.

    Baixei o Debugging Tools para 32-bit, ao tentar instalá-lo me deparo com a seguinte e grande demais para o meu gosto, mensagem de erro:

     

     

    Consulte o final desta mensagem para obter detalhes sobre como chamar a

    depuração just-in-time (JIT) em vez desta caixa de diálogo.

     

    ************** Texto de Exceção **************

    System.AccessViolationException: Tentativa de leitura ou gravação em memória protegida. Normalmente, isso é uma indicação de que outra memória está danificada.

    em System.Windows.Forms.UnsafeNativeMethods.CallWindowProc(IntPtr wndProc, IntPtr hWnd, Int32 msg, IntPtr wParam, IntPtr lParam)

    em System.Windows.Forms.NativeWindow.DefWndProc(Message& m)

    em System.Windows.Forms.Control.DefWndProc(Message& m)

    em System.Windows.Forms.Control.WndProc(Message& m)

    em System.Windows.Forms.TextBoxBase.WndProc(Message& m)

    em System.Windows.Forms.RichTextBox.WndProc(Message& m)

    em System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)

    em System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

    em System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

     

     

    ************** Conjuntos de Módulos (Assemblies) Carregados **************

    mscorlib

    Versão do Conjunto de Módulos (Assembly): 2.0.0.0

    Versão do Win32: 2.0.50727.4206 (VistaSP2GDR.050727-4200)

    Base de Código: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll

    ----------------------------------------

    SDKSetup

    Versão do Conjunto de Módulos (Assembly): 7.1.7600.30304

    Versão do Win32: 7.1.7600.30111

    Base de Código: file:///C:/7c8f2afc85c2333f85567a45c3/Setup/SDKSetup.exe

    ----------------------------------------

    System

    Versão do Conjunto de Módulos (Assembly): 2.0.0.0

    Versão do Win32: 2.0.50727.4205 (VistaSP2GDR.050727-4200)

    Base de Código: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll

    ----------------------------------------

    System.Windows.Forms

    Versão do Conjunto de Módulos (Assembly): 2.0.0.0

    Versão do Win32: 2.0.50727.4016 (NetFxQFE.050727-4000)

    Base de Código: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

    ----------------------------------------

    System.Drawing

    Versão do Conjunto de Módulos (Assembly): 2.0.0.0

    Versão do Win32: 2.0.50727.4016 (NetFxQFE.050727-4000)

    Base de Código: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

    ----------------------------------------

    System.Data

    Versão do Conjunto de Módulos (Assembly): 2.0.0.0

    Versão do Win32: 2.0.50727.4016 (NetFxQFE.050727-4000)

    Base de Código: file:///C:/Windows/assembly/GAC_32/System.Data/2.0.0.0__b77a5c561934e089/System.Data.dll

    ----------------------------------------

    System.Xml

    Versão do Conjunto de Módulos (Assembly): 2.0.0.0

    Versão do Win32: 2.0.50727.4016 (NetFxQFE.050727-4000)

    Base de Código: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll

    ----------------------------------------

    System.Configuration

    Versão do Conjunto de Módulos (Assembly): 2.0.0.0

    Versão do Win32: 2.0.50727.4016 (NetFxQFE.050727-4000)

    Base de Código: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

    ----------------------------------------

    mscorlib.resources

    Versão do Conjunto de Módulos (Assembly): 2.0.0.0

    Versão do Win32: 2.0.50727.4206 (VistaSP2GDR.050727-4200)

    Base de Código: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll

    ----------------------------------------

    System.Windows.Forms.resources

    Versão do Conjunto de Módulos (Assembly): 2.0.0.0

    Versão do Win32: 2.0.50727.4016 (NetFxQFE.050727-4000)

    Base de Código: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms.resources/2.0.0.0_pt-BR_b77a5c561934e089/System.Windows.Forms.resources.dll

    ----------------------------------------

     

    ************** Depuração JIT **************

    Para habilitar a depuração just-in-time (JIT), o arquivo .config deste

    aplicativo ou computador (machine.config) deve ter o valor

    jitDebugging definido na seção system.windows.forms.

    O aplicativo também deve ser compilado com a depuração

    habilitada.

     

    Por exemplo:

     

    <configuration>

    <system.windows.forms jitDebugging="true" />

    </configuration>

     

    Quando a depuração JIT está habilitada, qualquer exceção não tratada

    será enviada ao depurador JIT registrado no computador,

    em vez de ser tratada nesta caixa de diálogo.

     

    Pois bem, antes disso o programa pediu o NetFramework 4, baixei e não consegui instalar, de novo erro no servidor, aliás sorte minha ter o firefox, porque o ieframe.dll também apresenta falha.

     

    Quanto ao DEP, fui simplesmente checar se o DEP estava operando, sem o ExplorerFrame.dll fui em Excutar, command e digitei na linha de comando (procedimento disponível em http://support.microsoft.com/kb/912923/pt-br)

    WMIC OS obter DataExecutionPrevention_Available

    Dei enter e adivinha, "program too big to fit in memory",  não acreditei na mensagem e fui de "ip config", lá veio ela de novo, "program too big to fit in memory". Em suma, se eu "batatinha quando nasce" acho que vou receber "program too big to fit in memory", de fato essa foi a resposta...

    Vou tentar o Clean Boot, quando terminar, posto aqui.

     


    quinta-feira, 20 de janeiro de 2011 17:38
  • Opa. prazer

    Então Carlos, em relação a compatibilidade, você realmente baixou o correto certo? Acredito de que sim. Esqueci de avisá-lo sobre o pré-requisito do .Net FrameWork, na verdade tem a versão (Web Installer) de Internet.

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=9cfb2d51-5ff4-4491-b0e5-b386f32c0992&displaylang=en

    Quanto ao erros de memória que tem aparecido, você tentou apenas desativar o DEP via prompt e via Interface Gráfica?

    Meu Computador -> Propriedades -> Configurações Avançadas -> Aba Avançado -> Em Performance, clique em Configurações, vá na terceira aba Data Execution Prevention e clique na opção "Turn on DEP for essential Windows programs and services only".

    Por fim Carlos, além do Clean Boot, atualize a BIOS do seu computador, verifique o modelo da placa mãe, se quiser ajuda para pesquisar, me informe o modelo ;)

    Abraços.


    Carlos Eduardo Gnochi de Oliveira
    quinta-feira, 20 de janeiro de 2011 18:02
    Moderador
  • Acabei de sair do Clean Boot, aproveitei para testar todas as hipóteses já testadas e nada também, desculpe-me pela demora.

    A interface gráfica funciona, menu iniciar e barra de tarefas funcionam, o que é estranho já que as duas estão ligadas ao processo explorer.exe. O resto não, incluindo painel de controle e Meu Computador. Li o relatório de erro da instalação do .Net Framework, o que nos interessa está aqui

     

    [1/20/2011, 16:57:56] O Microsoft .NET Framework 4 já faz parte do sistema operacional. Não é necessário instalar o .NET Framework 4 redistribuível. Mais informações .
    [1/20/2011, 16:57:56] evaluating BlockIf:

    [1/20/2011, 16:57:56] O Microsoft .NET Framework 4 já faz parte do sistema operacional, mas está desativado no momento. Para habilitar o .NET Framework 4, use Ativar ou desativar recursos do Windows, no Painel de Controle. Mais informações .
    [1/20/2011, 16:57:56] evaluating BlockIf:

    Basta ativá-lo no Painel de controle, só que ao clicar nele, uma janela do DOS aparece e some em seguida, o painel de controle não abre nem pelo comando control.exe. Pelo que pesquisei é um problema relacionado ao banco de dados domFirebird e um arquivo dele que fica na System32, fui pelo executar, procurar e em System32 não há esse arquivo, também nunca utilizei o firebird.

    fui de atalho Windows+E, mas o erro de classe não registrada impede a operação. Se houver outro modo de abrir Meu Computador, por favor me avise.

    Quanto á placa mãe, são estes os dados

    Campo    Valor
    Propriedades da Placa Mãe   
    ID da Placa Mãe    63-0201-000010-00101111-052907-945GC$A0824000_BIOS DATE: 05/29/07 09:04:16 VER: 08.00.10
    Nome da Placa Mãe    Asus P5GC-MX/CKD/POST/SI
       
    Propriedades do Bus principal   
    Tipo de Bus    Intel AGTL+
    Largura de bus    64 bits
    Clock real    200 MHz (QDR)
    Clock efetivo    800 MHz
    Banda    6400 Mb/s
       
    Propriedades da memória do Bus   
    Tipo de Bus    DDR2 SDRAM
    Largura de bus    64 bits
    DRAM:Proporção FSB    10:6
    Clock real    333 MHz (DDR)
    Clock efetivo    667 MHz
    Banda    [ TRIAL VERSION ] Mb/s
       
    Propriedades do chipset do Bus   
    Tipo de Bus    Intel Direct Media Interface
       
    Fabricante da Placa Mãe   
    Nome da empresa    ASUSTeK Computer Inc.
    Informação sobre o produto    http://www.asus.com/ProductGroup2.aspx?PG_ID=mKyCKlQ4oSEtSu5m
    Download da BIOS    http://support.asus.com/download/download.aspx?SLanguage=en-us 
    Atualização de controlador (Driver)    http://www.aida64.com/driver-updates
    Atualizações da BIOS    http://www.aida64.com/bios-updates

    Atualizar o BIOS resolve todo o problema? Se for necessário posso seguir esse tutorial, nunca fiz esse procedimento e o texto me parece bom http://www.baixaki.com.br/tecnologia/3537-aprenda-a-atualizar-o-bios-do-computador.htm

    Essa parece ser uma opção http://vip.asus.com/forum/view.aspx?id=20070215223109668&board_id=1&model=P5B+Deluxe%2FWiFi-AP&SLanguage=en-us&page=1

    Muito obrigado até agora Carlos, tu foi o único que demonstrou conhecimento real e disposição.

    Abraços


    Carlos Simielli
    quinta-feira, 20 de janeiro de 2011 20:11
  • Carlos, sinta-se a vontade, pois estamos aqui realmente para ajudar.

    Bom falando em tópicos de acordo com o que postou, realmente verifique a respeito do .NET e assim, o programa no qual mencionei uma vez instalado ele teria que realmente prosseguir com a instalação, ao menos que esteja algo no computador que impeça, como por exemplo esses comportamentos inesperados que está tendo com um simples comando de ipconfig.

    O link Atualizações da BIOS    http://www.aida64.com/bios-updates que você mesmo encaminhou deve constar a data da versão,e verifique se aplica realmente, o link que ensina como fazer realmente é interessante, porém o processo é simples, somente contar com a sorte de não ocorrer uma queda de energia no momento da atualização rs.

    Se irá resolver não te afirmo, mas pode ajudá-lo com outros já existentes, também gostaria de adicionar para você re-registrar todas as dlls do System32, para isso entre no prompt de comando e digite:

    for /f %s in ('dir /b *.dll') do regsvr32 /s %s

    Verifique o comportamento após este comando. E como mais afundo ainda da situação, somente como adendo, uma reparação pela mídia do SO realmente não minimiza ? Pois os testes que tentou como o SFC para verificar integridades dos arquivos de sistema e restauração porém não disponível, seria uma boa, mas a reparação pode ser que corrija outros tipos de erros mais implícitos.

    Esse comportamento ele é similar a malware no ambiente ou anti-vírus, não desconfiando do que você ja executou na busca, também para "reforçar" ainda mais, use o ComboFix, desenvolvido exclusivamente para malwares que modificam o seu sistema operacional e os erros podem variar. Link:

    http://www.baixaki.com.br/download/combofix.htm

    Abraços.


    Carlos Eduardo Gnochi de Oliveira
    • Marcado como Resposta Richard Juhasz terça-feira, 25 de janeiro de 2011 13:38
    quinta-feira, 20 de janeiro de 2011 20:22
    Moderador
  • Carlos, não fuja meu caro! Estou desde ontem tentando resolver isso, amanhã tento o comando e atualizo o BIOS, antes disso lhe informo a data da versão da placa. Porque hoje eu vou jantar decentemente!

     

    Mais uma vez, muito obrigado, amanhã volto por aqui.

    Boa noite.


    Carlos Simielli
    quinta-feira, 20 de janeiro de 2011 21:12
  • Depois de muito tempo, aiás esse post já teve 202 vizualizações, construímos um guia que engloba as diversas probalidades das causas e possíveis consertos do erro "classe não registrada" do explorer.exe. Passei a semana tentanto tudo mesmo, mas até agora não atualizei o BIOS, com toda essa chuva forte, as oscilações são comuns. Eu tenho a sorte de só sentar aqui quando chove...

     

    Diante do quadro instalei o ComboFix e o MalwareBytes, novamente nada foi encontrado. Por isso coloquei o UltraExplorer para transferir meus arquivos para o notebook e restaurar tudo e claro aprendi a lição: "criarás pontos de restauração antes de cada mudança no computador, seja ela qual for"

     

    Vide log do MalwareBytes

     

    Malwarebytes' Anti-Malware 1.50.1.1100
    www.malwarebytes.org

    Versão da Base de Dados:  5623

    Windows 6.0.6002 Service Pack 2
    Internet Explorer 8.0.6001.18999

    27/01/2011 19:04:28
    mbam-log-2011-01-27 (19-04-28).txt

    Tipo de Verificação:  Verificação Rápida
    Objetos escaneados:  145775
    Tempo decorrido: 20 minuto(s), 57 segundo(s)

    Processos de Memória Infectados:  0
    Módulos de Memória Infectados:  0
    Chaves de Registro Infectadas: 0
    Valores de Registro Infectados: 0
    Itens de Dados no Registro Infectados:  0
    Pastas Infectadas:  0
    Arquivos Infectados: 0

    Processos de Memória Infectados:
    (Não foram detectados ítens maliciosos)

    Módulos de Memória Infectados:
    (Não foram detectados ítens maliciosos)

    Chaves de Registro Infectadas:
    (Não foram detectados ítens maliciosos)

    Valores de Registro Infectados:
    (Não foram detectados ítens maliciosos)

    Itens de Dados no Registro Infectados:
    (Não foram detectados ítens maliciosos)

    Pastas Infectadas:
    (Não foram detectados ítens maliciosos)

    Arquivos Infectados:
    (Não foram detectados ítens maliciosos)

     

    Ao Carlos e ao TechNet, obrigado.


    Carlos Simielli
    quinta-feira, 27 de janeiro de 2011 21:06
  • Carlos,

    Realmente seu problema não me parece simples, uma vez que todos os procedimentos efetuados não houve nenhum avanço, mas ao mesmo tempo é de se solucionar sim.

    Estava lendo novamente seu primeiro post e vi que tentou instalar um KB e que deu um código de erro, por gentileza vá até a pasta de Windows Update e cole pra mim aqui o log "windowsupdate.log" para eu verificar as informações contida nele e te passo um feedback do que possa estar ocorrendo.

    Ps: Você está com o último Service Pack ?

    Ou então coisas simples, tais como reinstalar o Client do Windows Update.

    E ainda lhe dou mais opções a fim de tentar solucionar seu problema:

    1) Registre as seguintes DLL's:


    REGSVR32 WUAPI.DLL
    REGSVR32 WUAUENG.DLL
    REGSVR32 WUAUENG1.DLL
    REGSVR32 ATL.DLL
    REGSVR32 WUCLTUI.DLL
    REGSVR32 WUPS.DLL
    REGSVR32 WUPS2.DLL
    REGSVR32 WUWEB.DLL

    - Após o registro das DLL's, abra o prompt de comando e digite:

    net stop WuAuServ

    - Renomeie a pasta C:\Windows\SoftwareDistribution para .old

    E Inicie o serviço acima:

    net start WuAuServ

    =====================================================

    Como referência technet: http://technet.microsoft.com/en-us/library/bb418925.aspx

    2) Definition update fails with error 0x80080005

    You may see a message stating that updating of definitions failed with error 0x80080005. Additionally, you may also see error code 0x8007277a in the WindowsUpdate.log file.

    Background

    This can occur if there is a problem with the Winsock installation on the client system.

    Solution

    For the steps to fix the Winsock installation, see Knowledge Base article 811259 (http://go.microsoft.com/fwlink/?LinkId=86559).

    Espero que ajude em algo.

    Abraços.


    Carlos Eduardo Gnochi de Oliveira
    sexta-feira, 28 de janeiro de 2011 01:15
    Moderador
  • Faz tempo que não respondo, mas atingi um nível que não era resoluvel, reinstalei o client do update e o erro permaneceu, tentei reinstalar as dll's, tive que baixá-las, mas eram incompatíveis, vaguei pelos sites que oferecem dll, mas não encontrei nenhuma compatível. Isso eu tentei postar aqui antes, a resposta, por mais que eu quisesse não era publicada de modo algum.

     

    Em uma das tentativas, com toda aquela chuva a força caiu bem na inicialização, na roleta dos erros aletórios, foram corrompidos os arquivos essenciais à incicialização e tive que colocar o dvd de instalação do Vista, porém a minha cópia não possue a opção de reparo, é uma das primeiras e a única opção foi reinstalar o Vista, dai, claro, tudo foi resolvido.

    No entanto localizei o agente causador de tudo isso, por mero acaso, ao reinstalar os programas aqui, o Security Essentials colocava na quarentena o setup do PrimoPDF, que funciona como uma impressora, gerando arquivos PDF. Fui descobrir o porque e achei o grande responsável por todos esses transtornos, um adware que era instalado sem autorização do usuário e que modificava alguns dll's para funcionar, enganando o sitema para facilitar a busca e envio de dados do usuário na surdina.

    Nas primeiras versões do PrimoPDF ele não existia, dai não ter tido problemas antes, mas em uma atualização recente do programa ele apareceu e causou tudo isso. Pois é, ele não era um vírus, por isso o GData não o detectou, tãopouco o Malwarebytes, o Security Essentials só fez depois de receber uma denúncia específica, provavelmente.

    Agora crio pontos de restauração antes de instalar e atualizar qualquer programa, melhor prevenir.

    Obrigado pela atenção Carlos.


    Carlos Simielli
    domingo, 20 de fevereiro de 2011 11:46