none
Duvida da Instalação RRS feed

  • Pergunta

  •  

    Fala ai ...

     

    Sou eu denovo pertubando hehee...

    Primeira duvida é... para eu ter as funções do SMS no SCCM eu preciso instalar o SMS primeiro??

     

    Eu acho que não .. mas e so para confirmar...

     

    Outra duvida é, estou rodando aquele pre-req e ele me pergunta o FQDN (de alguma maq), SDK Server e o SQL..

     

    Blz SQL... FQDN seria o servidor de DNS? e o que seria o SDK????

     

     

    Outra duvida é, irei instalar no Win2k3 sp2, eu posso instalar todos os PAPEIS (SiteServer, SMS Provider, CS, DP, FSP, MP, PXE, RP, SMP, SHV) do SCCM na mesma maquina?

     

     

    O SUP eu tenho que instalar na maq do WSUS?

     

     

    Muito obrigado!

    quarta-feira, 29 de outubro de 2008 12:56

Respostas

  • Boa tarde,

     

    eu acho que tive sorte ateh agora, eu nunca instalei em uma instancia diferente..soh a porta...

     

    1 coisa esta me intrigando e n achei isso na documentacao, se qdo vc instala em uma instancia, vc tem que trocar o MSSQLSvc ou nao, pela documentacao, a unica coisa que ele fala eh:

    ---------

    The command to register an SPN for a SQL Server named instance is the same as that used when registering an SPN for a default instance except that the port number should match the port used by the named instance.

    ---------

     

    Com base nessa informacao, eu acho que o teu spn deveria ser o padrao e trocar apenas a porta...se for assim, o teu spn deverah ser:

     

    setspn –A MSSQLSvc/serv01:1000 dominio\sqluser
    setspn –A MSSQLSvc/serv01.dominio.com.br:1000 dominio\sqluser

     

    antes de fazer isso, dele o antigo...

     

    teste e dai poste o resultado..

     

    espero ter ajudado,

     

     

     

    segunda-feira, 3 de novembro de 2008 14:45
    Moderador

Todas as Respostas

  • Boa tarde,

     

    sem problema..tendo duvida eh que se aprende...

     

    1- o SCCM eh o SMS (versao nova) com novo nome...com isso, vc n precisa ter o sms instalado...

     

    2- na hora da instalacao, vc vai indicar qual a maquina que tem o sql instalado, em qual maquina vc vai instalar o SMS Provider e qual maquina vc vai instalar o management point. o fqdn eh dessas maquinas (vc tbem pode usar o nome netbios), mas n do teu servidor dns...

    esses mesmos fqdn sao utilizados para o pre-req...

     

    3- Vc pode instalar todos os papeis no mesmo servidor sem problemas..a unica excecao eh o servidor que vai hospedar o papel de System Health Validator Point (SHVP) em uma maquina com windows 2008.

     

    em relacao ao sup, vc tem que instalar ele na maquina com o wsus instalado, pode ser tanto local como remoto, mas se for remoto vc tem que instalar o wsus console na maquina do site server...

     

    espero ter ajudado,

     

    quarta-feira, 29 de outubro de 2008 14:04
    Moderador
  • Entao o SHVP e só para 2008!!!

     

    Blzinha.. vou começar a fazer uns testes aki..

     

    Não vou fechar o post n.. pq se eu tiver algum problema na instação eu vou postar aki!

     

    abs e obrigaod

     

    quarta-feira, 29 de outubro de 2008 16:04
  • Boa noite,

     

    show de bola..como vc esta comecando..meu blog tem diversos posts que podem lhe ajudar...da 1 olhada

    blog.dotnetwork.com.br

     

    estou tbem escrevendo 1 guia sobre sccm, da 1 olhada

    www.dotnetwork.com.br/guia.asp

     

    espero ter ajudado,

    quarta-feira, 29 de outubro de 2008 19:06
    Moderador
  • Fala ai Raphael..


    Entao cara, consegui tirar todos os erros ficaram 2 errors e 1 warning...

    O warning e sobre um patch do MMC, ja instalei mas ele continua reclamndo.. que seja.. isso n impacta na instalação!

    Os outros 2 erros, 1 eu imagino que sera resolvido na instalação, pq o meu sql esta em outra maq, e o meu usuario n e SYSADM do sql, mas o usuario que eu criei para ser o serviço do SCCM é sysadmin, entao acho que este erro vai passar!

    Agora estou com o outro erro que e o SMS provider, olha o q ele fala.

    "A communication error has been detected between the SMS Provider computer and the site database computer. This error can occur when the site database server is offline or if a valid SPN has not been registered in Active Directory Domain Services for the SQL Server instance hosting the site database. Setup cannot continue."

    Achei estranho porque o SPN não é so para o SQL?

    Detalhe.. conta do serviço do sccm é sv_sccm e o sql é sv_sql

    Eu cadastrei no SPN o sv_sccm

    E no sql está configurado isso, segui ate o seu manual raphael....

    Ve ai se vc pode me ajudar!
    quinta-feira, 30 de outubro de 2008 11:48
  • Bom dia,

     

    vc configurou o spn corretamente para o sql?

    a maquina que vc esta instalando o sccm faz parte do grupo local admin do sql?

     

    http://blog.dotnetwork.com.br/?p=10

     

     

    espero ter ajudado,

    quinta-feira, 30 de outubro de 2008 11:52
    Moderador
  • Eu editei o post mas vc ja tinha postado..

    Agora fiquei em duvida, o user que tenho q cadastrar é o user do SCCM ou do SQL?
    quinta-feira, 30 de outubro de 2008 12:09
  • Boa tarde,

     

    o spn vc tem que colocar o user do sql...

     

    espero ter ajudado,

     

    quinta-feira, 30 de outubro de 2008 12:28
    Moderador
  • agora vem outra duvida,

    eu tenho outros sqls que usam esta conta... sera que n vai dar problema n?

    abs
    quinta-feira, 30 de outubro de 2008 12:39
  • Bom dia,

     

    que eu saiba nao...

     

    espero ter ajudado,

    quinta-feira, 30 de outubro de 2008 12:49
    Moderador
  • Perguntei para o meu DBA aqui e ele disse tb nao, entao fiz o procedimento...

    Cara continua dando erro...!! ]=

    Algo mais tem q fazer?

    Fiz aquele check .. apareceu certinho as 2 entradas do SPN!
    quinta-feira, 30 de outubro de 2008 13:04
  • Raphel..

    Não da para escolher qual é o serviço que o SCCM vai instalar????

    Mesmo dando este erro no Pre-req.. eu começei a instalação, porem estou parado na hora que configura o SQL server.. porque meu usuario não tem acesso ao sql, so o usuario que eu criei para o servico do SCCM...

    Tem como fazer isso?

    abs
    quinta-feira, 30 de outubro de 2008 13:15
  • Bom dia,

     

    o que vc quer dizer com os servicos do sccm??

     

    por padrao, o sccm eh instalado com o minimo possivel, depois que vc instala ele que vc vai instalar o Fallback status point, server locator point, software update point, etc..etc..

     

    na instalacao, ele soh instala o distribution point e o management point (caso vc queira, vc tem a opcao de n instalar)

     

    em relacao ao sql segue a copia do help

    ------------------------

    SQL Server)

    Failure

    Verifies that the logged on user and site server computer account possess administrative rights to the SQL Server computer.

    --------------------------

     

    infelizmente, a conta que esta sendo utilizada para instalar e a conta de maquina DEVEM ser ADMINISTRADORES no sql server...

     

    agora, o q vc tem que fazer eh desinstalar o sccm, dar os devidos direitos (se precisar reiniciar o sccm faca isso) e entao inicie a instalacao novamente.

     

    como vc tem 1 usuario que tem esses poderes, instale o sccm com ele, o q vc vai ter que fazer eh colocar ele no grupo local admin da maquina sccm... o problema disso eh que o usuario que instala o sccm possui todos os direitos no sccm

     

    espero ter ajudado,

    quinta-feira, 30 de outubro de 2008 13:58
    Moderador
  • Meio ruim isso ne cara.. vc n pode setar a conta que vai rodar o serviço do SCCM...


    Tipo estava verificando os logs... olha só
    ConfigMgrSetup.log
    <10-30-2008 15:02:08> Starting evaluation process.
    <10-30-2008 15:02:08> Enough free disk space.
    <10-30-2008 15:02:09> Checking domain for advanced security, PDC for domain TESTE is \\SERV0
    <10-30-2008 15:02:51> No server type detected from registry
    <10-30-2008 15:03:33> Sql version is 9.0, 9.00.3260.00.
    <10-30-2008 15:04:01> Verified machine account by installing service SMS_ACCOUNT_TEST_SERVICE
    <10-30-2008 15:04:01> This is not cluster SQL.
    <10-30-2008 15:04:01> The prereq rules for primary site fresh installation are being run.
    <10-30-2008 15:04:01> Verifying SMS Active Directory Schema Extensions.
    <10-30-2008 15:04:01> DS Root:CN=Schema,CN=Configuration,DC=teste,DC=com,DC=br
    <10-30-2008 15:04:01> NtfsDisable8dot3NameCreation is set to 0.
    <10-30-2008 15:04:01> Success in GetMMCVersion. Version is 3.0.
    <10-30-2008 15:04:01> .NET Framework Version: 50727
    <10-30-2008 15:04:52> Could not get value for NtfsDisable8dot3NameCreation.
    <10-30-2008 15:04:52> Sql version is 9.0, 9.00.3260.00.
    <10-30-2008 15:05:00> NtfsDisable8dot3NameCreation is set to 0.
    <10-30-2008 15:05:00> This is a local site system. It does not check Admin$.
    <10-30-2008 15:05:00> NtfsDisable8dot3NameCreation is set to 0.
    ________________________________________________________________________
    ConfigMgrPrereq.log
    <10-30-2008 15:04:10> <<<RuleCategory: System Requirements>>>
    <10-30-2008 15:04:10> <<<CategoryDesc: Checking system requirements for ConfigMgr...>>>
    <10-30-2008 15:04:31> Failed to get domain membership informaiton for machine SERV01 with 0.
    <10-30-2008 15:04:31> SERV01;    Domain membership;    Error;    Configuration Manager site server components can only be installed on computers that are members of a Windows domain.
    <10-30-2008 15:04:52> SERV01;    Short File Name (8.3) Support (Site system);    Error;    Setup either could not verify that short file name (8.3) support is enabled on the computer specified for site system installation or the server could not be contacted to determine short file name support information. No further prerequisite checking rules can be evaluated on the specified system. Setup cannot continue.
    <10-30-2008 15:04:01> Failed to connect to registry for KB940848 with 203.
    <10-30-2008 15:04:01> SERVRJ02;    MMC updates for Configuration Manager (Software Updates);    Warning;    This software update addresses several MMC errors that may occur when running the Configuration Manager console. This update should be applied if any of the following occur: Configuration Manager console stops responding when the host computer is low on available memory, context menu errors on console home pages, or inconsistent display after drag-and-drop operations do not succeed. More information about this update is available at: http://go.microsoft.com/fwlink/?LinkId=98349.

    Serv0 = DC
    serv01= SQL
    serv02=SCCM

    Todo o resto dos check passaram... Vc ja pegou este problema?
    quinta-feira, 30 de outubro de 2008 14:01
  • Boa noite,

     

    isso eh problema com os pre-requisitos, abaixo vai o link dos pre-requisitos

    http://technet.microsoft.com/en-us/library/bb680951.aspx

     

    em relacao ao 8.3, vc tem que habilitar

    Short file name (8.3) support

    (Site system)

    Failure

    Verifies that short file name support (8.3) is enabled on the site system computer.

    Configuration Manager Setup requires that short file name (8.3) support is enabled on site system computers.

    More information about enabling short file name (8.3) support is available at http://go.microsoft.com/fwlink/?LinkId=106183.

     

    em relacao ao domain membership, vc soh pode instalar o sccm em uma maquina que pertence ao dominio, n pode ser workgroup, os clientes podem, mas o servidor nao

    Domain membership

    Failure

    Verifies that the computer specified for installation is a member of a Windows domain.

    Configuration Manager site server components can only be installed on computers that are members of a Windows domain.

     

    se a maquina jah esta no dominio, verifique se esta funcionando 100%, veja no event viewer, e se for o caso, retire e ponha novamente

     

    numa olhada por cima foi isso que eu pude perceber

     

    espero ter ajudado,

    quinta-feira, 30 de outubro de 2008 17:59
    Moderador
  • Fala ai raphael..

    Cara primeiramente obrigadao ai pela ajuda!!!!

    Consegui passar desta fase.... olha q loucura.. para aprendizado!!

    Como eu uso o sql em um porta diferente do padrao.. eu precisei instalar o client do sql para ele reconhecer.. porem eu no alias no client eu não pus o nome da maquina.. eu criei realmente um alias.. e ai por algum motivo o SCCM não consegui checar a maquina verdadeira..... ai eu pus no alias extamente o nome/instance.. pronto funcionou... agora estou tendo outro problema.. vou ver se eu resolvo se n conseguir eu falo ctg!

    abs e obrigado
    quinta-feira, 30 de outubro de 2008 18:30
  • Essa instalalção aqui n qr sair...

    Demorei um pouco para postar pq estava lendo uns carinhas falando sobre este meu problema..

    ja tentei varias maneiras e nada disso funcionar... dizem q esta ligado ao SPN este erro.. vejam se vcs podem me ajudar

    <10-31-2008 09:42:19> pSetupInf->SDKServer = SERVRJ01
    <10-31-2008 09:42:22> Successfully created local user group SMS Admins on the local machine with BANCOBRASCAN\gandradeabc as the member.
    <10-31-2008 09:42:22> nlsdl.dll already exists.
    <10-31-2008 09:42:23> Created the provider registry settings.
    <10-31-2008 09:42:24> Registered OCX E:\Program Files\Microsoft Configuration Manager\bin\i386\smsprov.dll
    <10-31-2008 09:42:25> Registered OCX E:\Program Files\Microsoft Configuration Manager\bin\i386\extnprov.dll
    <10-31-2008 09:42:25> Registered OCX E:\Program Files\Microsoft Configuration Manager\bin\i386\TaskSequenceProvider.dll
    <10-31-2008 09:42:25> CompileMOFFile: Starting to compile MOF E:\Program Files\Microsoft Configuration Manager\bin\i386\sms_schm.mof
    <10-31-2008 09:42:28> CompileMOFFile: Compiled MOF E:\Program Files\Microsoft Configuration Manager\bin\i386\sms_schm.mof
    <10-31-2008 09:42:28> CompileMOFFile: Starting to compile MOF E:\Program Files\Microsoft Configuration Manager\bin\i386\TaskSequenceProvider.mof
    <10-31-2008 09:42:29> CompileMOFFile: Compiled MOF E:\Program Files\Microsoft Configuration Manager\bin\i386\TaskSequenceProvider.mof
    <10-31-2008 09:42:29> CompileMOFFile: Starting to compile MOF E:\Program Files\Microsoft Configuration Manager\bin\i386\smsprov.mof
    <10-31-2008 09:42:31> CompileMOFFile: Compiled MOF E:\Program Files\Microsoft Configuration Manager\bin\i386\smsprov.mof
    <10-31-2008 09:42:31> CompileMOFFile: Starting to compile MOF E:\Program Files\Microsoft Configuration Manager\bin\i386\smsRprt.mof
    <10-31-2008 09:43:13> CompileMOFFile: Failed to compile MOF E:\Program Files\Microsoft Configuration Manager\bin\i386\smsRprt.mof, error -2147217407
    <10-31-2008 09:43:13> Setup cannot compile MOF file E:\Program Files\Microsoft Configuration Manager\bin\i386\smsRprt.mof.  Do you want to continue?
    <10-31-2008 09:43:13> Setup failed to install SMS Provider.  For more information about this error, see Microsoft Knowledge Base at http://microsoft.com or contact Microsoft Technical Support for further assistance.
    sexta-feira, 31 de outubro de 2008 12:46
  • Bom dia pessoal..

    Entao esta minha isntalação n qr sair de jeito nenhum.. agora dps de varios testes.. lendo varios posts de pessoas que ja tiveram este problema.. eu ja estou caso desistindo hehehe.. nada funciona!!!

    Vejam se vcs podem me ajudar, este erro esta acontecendo na hora do SMS Provider...

    <10-31-2008 09:42:19> pSetupInf->SDKServer = SERVRJ48
    <10-31-2008 09:42:22> Successfully created local user group SMS Admins on the local machine with BANCOBRASCAN\gandradeabc as the member.
    <10-31-2008 09:42:22> nlsdl.dll already exists.
    <10-31-2008 09:42:23> Created the provider registry settings.
    <10-31-2008 09:42:24> Registered OCX E:\Program Files\Microsoft Configuration Manager\bin\i386\smsprov.dll
    <10-31-2008 09:42:25> Registered OCX E:\Program Files\Microsoft Configuration Manager\bin\i386\extnprov.dll
    <10-31-2008 09:42:25> Registered OCX E:\Program Files\Microsoft Configuration Manager\bin\i386\TaskSequenceProvider.dll
    <10-31-2008 09:42:25> CompileMOFFile: Starting to compile MOF E:\Program Files\Microsoft Configuration Manager\bin\i386\sms_schm.mof
    <10-31-2008 09:42:28> CompileMOFFile: Compiled MOF E:\Program Files\Microsoft Configuration Manager\bin\i386\sms_schm.mof
    <10-31-2008 09:42:28> CompileMOFFile: Starting to compile MOF E:\Program Files\Microsoft Configuration Manager\bin\i386\TaskSequenceProvider.mof
    <10-31-2008 09:42:29> CompileMOFFile: Compiled MOF E:\Program Files\Microsoft Configuration Manager\bin\i386\TaskSequenceProvider.mof
    <10-31-2008 09:42:29> CompileMOFFile: Starting to compile MOF E:\Program Files\Microsoft Configuration Manager\bin\i386\smsprov.mof
    <10-31-2008 09:42:31> CompileMOFFile: Compiled MOF E:\Program Files\Microsoft Configuration Manager\bin\i386\smsprov.mof
    <10-31-2008 09:42:31> CompileMOFFile: Starting to compile MOF E:\Program Files\Microsoft Configuration Manager\bin\i386\smsRprt.mof
    <10-31-2008 09:43:13> CompileMOFFile: Failed to compile MOF E:\Program Files\Microsoft Configuration Manager\bin\i386\smsRprt.mof, error -2147217407
    <10-31-2008 09:43:13> Setup cannot compile MOF file E:\Program Files\Microsoft Configuration Manager\bin\i386\smsRprt.mof.  Do you want to continue?
    <10-31-2008 09:43:13> Setup failed to install SMS Provider.  For more information about this error, see Microsoft Knowledge Base at http://microsoft.com or contact Microsoft Technical Support for further assistance.

    Muito posts que li, dizem que esta ligado diretamente com o SPN.....

    Mas ja tentei mill formas e nada!

    Abs,
    sexta-feira, 31 de outubro de 2008 12:49
  • Bom dia,

     

    como o teu ambiente n eh o padrao, o spn deve representar o teu sql...

     

    vc vai usar setspn.exe –a MSSQLSvc/<SQL Server FQDN>:1433 <Domain\Account> e setspn.exe –a MSSQLSvc/<SQL Server Netbios Name>:1433 <Domain\Account> qdo eh o padrao, se vc n tiver o padrao, por exemplo, mudou a porta, vc vai precisar mudar a porta tbem, em vez de colocar 1433 colocar a porta.

     

    espero ter ajudado,

    sábado, 1 de novembro de 2008 11:54
    Moderador
  • Boa noite Pessoal,

     

    Como estamos aqui de solução? Se puder classifiquem o post, por favor.

     

    Abração,

     

    Cleber Marques
    Projeto MOF Brasil: Simplificando o Gerenciamento de Serviços de TI
    www.mof.com.br | www.clebermarques.com | www.clebermarques.com.br

    domingo, 2 de novembro de 2008 00:55
    Moderador
  • Entao cleber a solução esta braba!!!

     

    Porque fazer isso que o nosso amigo fez.. eu ja mudei.. na verdade minha instancia e minha porta n e padrao... porem já esta configurado como os docs mandam....

     

    Sendo que sempre fico preso nisso.. um gringo disse sobre o WMI, porem n entendo praticamente nada!!

     

    vou fazer alguns testes e dps posto aqui, qm tiver alguma ideia plz!

     

    segunda-feira, 3 de novembro de 2008 12:10
  • Bom dia,

     

    veja se o SPN esta registrado corretamente

     

    1- Abra o adsiedit.msc

    2- vai ateh o usuario que esta sendo utilizado para subir o sql

    3- entre nas propriedades dele e procure por servicePrincipalName..veja se esta criada e com o valor correto

     

    espero ter ajudado,

    segunda-feira, 3 de novembro de 2008 12:17
    Moderador
  • Isso que estou cabreiro.. ta tudo "certinho"

     

    minha instancia aqui é SQL01

    Porta do sql 10000

    Usuario que roda o serviço do sql server: sqluser

    Meu servidor é serv01.dominio.com.br

     

    Logo o registro que fiz foi

     

    SQL01/serv01.dominio.com.br:10000 dominio\sqluser

    SQL01/serv01:10000 dominio\sqluser

     

     

    Quando eu verifico no adsiedit esta tudo certo..

    quando rodo o setspn -l dominio\sqluser apareçe tudo ok...!!

     

    Cara n sei o q fazer!!!

     

    segunda-feira, 3 de novembro de 2008 12:24
  • Rafael, li alguns post e falavam que poderia ser problema no WMI.

     

    Da uma olhada e ve se vc ja pegou este problema...

     

    Este erro ocorreu bem na hora de instalar o SMS provider.

     

    A provider, ExtnProv, has been registered in the WMI namespace, root\SMS\site_SMS, to use the LocalSystem account.  This account is privileged and the provider may cause a security violation if it does not correctly impersonate user requests.

     

    A provider, TaskSequenceProvider, has been registered in the WMI namespace, root\SMS\site_SMS, to use the LocalSystem account.  This account is privileged and the provider may cause a security violation if it does not correctly impersonate user requests.

     

    Abs e obrigado

     

    segunda-feira, 3 de novembro de 2008 12:50
  • Boa tarde,

     

    eu acho que tive sorte ateh agora, eu nunca instalei em uma instancia diferente..soh a porta...

     

    1 coisa esta me intrigando e n achei isso na documentacao, se qdo vc instala em uma instancia, vc tem que trocar o MSSQLSvc ou nao, pela documentacao, a unica coisa que ele fala eh:

    ---------

    The command to register an SPN for a SQL Server named instance is the same as that used when registering an SPN for a default instance except that the port number should match the port used by the named instance.

    ---------

     

    Com base nessa informacao, eu acho que o teu spn deveria ser o padrao e trocar apenas a porta...se for assim, o teu spn deverah ser:

     

    setspn –A MSSQLSvc/serv01:1000 dominio\sqluser
    setspn –A MSSQLSvc/serv01.dominio.com.br:1000 dominio\sqluser

     

    antes de fazer isso, dele o antigo...

     

    teste e dai poste o resultado..

     

    espero ter ajudado,

     

     

     

    segunda-feira, 3 de novembro de 2008 14:45
    Moderador
  • Cara primeiramente...

     

    I love u to much!!! heheheheheh

     

    brincadeira muito obrigado.. passou!! !hehehe que coisa louca ne?!

    Agora vou seguir seu manual e vou ver no q da!!

     

    abs

    segunda-feira, 3 de novembro de 2008 17:23
  • Boa noite,

     

    show de bola que funcionou...agora eh "partir pro abraco"..

     

    qquer coisa que precisar estamos ai

     

    espero ter ajudado,

     

    segunda-feira, 3 de novembro de 2008 17:47
    Moderador