none
Gerenciador de Servidores - Hyper-V Server 2008 R2 RRS feed

  • Pergunta

  • Pessoal boa tarde!

    Tenho o Hyper-V Server 2008 R2 instalado no Servidor e estou gerenciando via RSAT Windows 7 ENT.

    Quando abro a ferramenta Gerenciador de Servidores > Computador Remoto. Aparece desabilitado para conectar.

    No cliente já habilitei o WinRM e no Servidor até desabilitei o Firewall (para não bloquear nada) e mesmo assim não funcionou o Gerenciador, continua desabilitado.

    Será que esqueci de configurar algo no Cliente ou no Servidor?

    Grato
    Rafael

    terça-feira, 2 de abril de 2013 18:27

Todas as Respostas

  • Rafael, boa tarde! No AD existe um grupo built-in chamado Hyper-v Administrator. Pode ser algo de permissão.

    Tente dar essa permissão ao usuário, caso não funcione ou o usuário seja admin responda novamente. Vamos tentar algo juntos.


    Ajudou a resolver? Marque como útil!

    terça-feira, 2 de abril de 2013 19:36
  • Daniel,

    Obrigado pelor retorno,.

    O Servidor está como Workgroup. Não faz parte do domínio.

    Grato
    Rafael

    terça-feira, 2 de abril de 2013 19:39
  • Rafael, provavelmente seu problema é permissão para visualizar os recursos então.

    Tente executar a console de gerenciamento utilizando

    botão direito + shift > Executar como usuário diferente> NomeDaMaquina\Adm_local e sua senha

    Verifique se acessa


    Ajudou a resolver? Marque como útil!

    terça-feira, 2 de abril de 2013 19:44
  • Daniel, testei esta alternativa e não deu certo.
    Quando eu tento com o usuário Administrator, aparece falha de autenticação. Quando eu tento com um usuário que criei no Servidor ele abre o Gerenciador, porém desabilitado.
    • Editado Rafael Luz terça-feira, 2 de abril de 2013 20:00
    terça-feira, 2 de abril de 2013 19:57
  • Esse usuário está no grupo de ADM local Rafael?

    Pela console de gerenciamento de Hyper-v, não pelo RSAT, você consegue visualizar as máquinas?

    Para checar, Iniciar > Executar >appwiz.cpl >Ativar ou desativar recursos do windows> Ferramenta de Administração de Funções > Ferramentas do Hyper-V

    Verifique isso no seu client W7 e coloque aqui para nós!


    Ajudou a resolver? Marque como útil!

    terça-feira, 2 de abril de 2013 20:31
  • Bom Dia Daniel,

    Vamos lá...
    Sim o usuário que criei é o mesmo do cliente e servidor, com a mesma senha em ambos.
    Eu já tenho instalado o RSAT e tenho acesso total ao servidor, menos pelo Gerenciamento de Servidores que é extremamente importante.
    Sinceramente não acho que o problema esteja no Servidor e sim no cliente. O que você acha?

    Vlw
    Rafael


    • Editado Rafael Luz quarta-feira, 3 de abril de 2013 11:21
    quarta-feira, 3 de abril de 2013 11:19
  • Rafael, seu Windows é Enterprise Certo? Pelas documentações da MS, o Enterprise tem essa funcionalidade habilitada.

    Vou te passar algumas comandos, execute eles, reinicie sua estação Win 7 e faça um teste, por favor.

    Abra o CMD, com privilégios elevados e digite: 

    • winrm set winrm/config/client @{TrustedHosts="RemoteComputerName"} - Substitua "RemoteComputerName" pelo nome do server que você quer conectar.

    Depois, insira essa chave de registro, pelo mesmo CMD com privilégios ADM: 

    • reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v LocalAccountTokenFilterPolicy /t REG_DWORD /d 1 /f

    Fico no aguardo!


    Ajudou a resolver? Marque como útil!

    quarta-feira, 3 de abril de 2013 12:35
  • Daniel,

    Eu tentei anteriormente executar este comando, mas retorna o seguinte erro abaixo.

    C:\>winrm set winrm/config/client @{TrustedHosts="WIN-SERVER"}
    WSManFault
        Message = O cliente não conseguiu se conectar ao destino especificado na solicitação. Verifique se o serviço está em execução no destino e se está aceitando solicitações. Consulte os registros e a documentação do serviço WS-Management em execução no destino, comumente IIS ou WinRM. Se o destino estiver no serviço WinRM, execute o seguinte comando no destino para analisar e configurar o serviço WinRM: "winrm quickconfig".

    Número do erro:  -2144108526 0x80338012
    O cliente não conseguiu se conectar ao destino especificado na solicitação. Verifique se o serviço está em execução no destino e se está aceitando solicitações.
     Consulte os registros e a documentação do serviço WS-Management em execução no destino, comumente IIS ou WinRM. Se o destino estiver no serviço WinRM, execute
    o seguinte comando no destino para analisar e configurar o serviço WinRM: "winrm quickconfig".

    O Serviço WinRM está em execução no Servidor, já verifiquei também.
    Complicado hein! :)

    quarta-feira, 3 de abril de 2013 13:12
  • Rafael, estamos progredindo... siga por favor os passos desse link:

    http://support.microsoft.com/kb/2269634/en-us

    Vou subir uma VM com o 7 Ent para poder ver aqui também, minha máquina é Win7 Prof.


    Ajudou a resolver? Marque como útil!

    quarta-feira, 3 de abril de 2013 13:51
  • quarta-feira, 3 de abril de 2013 14:23
  • Daniel,

    Ao executar o comando gera o mesmo erro. Executei em dois clientes Win7 e em ambos a mesma coisa.

    -winrm invoke Restore winrm/Config.

    Vou tentar reinstalar o pacote.

    Abs.


    • Editado Rafael Luz quarta-feira, 3 de abril de 2013 14:33
    quarta-feira, 3 de abril de 2013 14:30
  • Daniel,

    Ao executar o comando gera o mesmo erro. Executei em dois clientes Win7 e em ambos a mesma coisa.

    -winrm invoke Restore winrm/Config.

    Vou tentar reinstalar o pacote.

    Abs.


    Olha Rafael, já fiz por aqui, contudo sem resultado.... Estou pesquisando ainda, já te retorno com algo!

    Ajudou a resolver? Marque como útil!

    quarta-feira, 3 de abril de 2013 15:03
  • Daniel,

    Não entendi. Você teve o mesmo problema no seu ambiente de teste?

    quarta-feira, 3 de abril de 2013 15:09
  • Exatamente Rafael... Estou recorrendo há alguns colegas agora, mas estamos enfrentando todos o mesmo problema!


    Ajudou a resolver? Marque como útil!

    quarta-feira, 3 de abril de 2013 15:54
  • http://www.cooperati.com.br/wordpress/2013/02/19/gerenciando-vms-no-hyper-v-server-2012-com-windows-7/

    Aqui tem um vídeo sobre este assunto, já tentou?


    Boa Sorte! Jorge Borges.

    quarta-feira, 3 de abril de 2013 16:37
  • Daniel,

    Blza... fico no aguardo, enquanto isso procuro algo também.
    Segue meu MSN - rafael_mluz@hotmail.com.

    quarta-feira, 3 de abril de 2013 16:40
  • Jorge, já tentamos sim, mas também não resolveu.

    Ajudou a resolver? Marque como útil!

    quarta-feira, 3 de abril de 2013 16:41
  • cmdkey /add:hyper-v_server /user:usuario /pass:senha

    Já tentou?


    Boa Sorte! Jorge Borges.

    quarta-feira, 3 de abril de 2013 16:49
  • cmdkey /add:hyper-v_server /user:usuario /pass:senha

    Já tentou?


    Boa Sorte! Jorge Borges.

    Não funcionou também.

    Ajudou a resolver? Marque como útil!

    quarta-feira, 3 de abril de 2013 16:51
  • Jorge, também não funcionou. O problema que tenho todos acessos ao Servidor menos pelo Gerenciador de Servidores. Estou utilizando o Win7 Ultimate com SP1.

    Daniel, quando você executa o comando (winrm invoke Restore winrm/Config.) gera aquele erro?

    Abraço.

    quarta-feira, 3 de abril de 2013 16:54
  • Aqui não tenho problemas Rafael... Mas mesmo assim não resolve o fato de estar desabilitado.

    Ajudou a resolver? Marque como útil!

    quarta-feira, 3 de abril de 2013 16:56
  • Daniel, bom dia!

    Será que hoje a gente consegue matar este problema? :)

    Abraço

    quinta-feira, 4 de abril de 2013 11:10
  • Pessoal,

    Fiz um novo teste, porém agora utilizando o Windows Server 2008 R2 para conectar remotamente no Hyper-V Server.
    Realizei diversos comandos e o erro persiste.

    sexta-feira, 5 de abril de 2013 15:58
  • Rafael, boa tarde!

    Existe algum motivo para esse host hyper-v não estar no Domínio?


    Ajudou a resolver? Marque como útil!

    sexta-feira, 5 de abril de 2013 16:19
  • Bom dia,

    Rafael tentou utilizar o utilitario AZMAN para conceder permissões ao Hyper-V.

    De uma olhada nesse artigo: http://www.linhadecodigo.com.br/artigo/2953/delegando-o-controle-e-o-gerenciamento-de-acesso-no-hyper-v.aspx

    Att,

    segunda-feira, 8 de abril de 2013 13:48
  • Rafael, boa tarde!

    Existe algum motivo para esse host hyper-v não estar no Domínio?


    Ajudou a resolver? Marque como útil!

    Daniel, eu também estou achando que não estou conseguindo pelo fato do Servidor não estar no domínio.
    O servidor Hyper-V irá ficar standalone e as VMs no domínio.

    Abs.

    segunda-feira, 8 de abril de 2013 16:26
  • Bom dia,

    Rafael tentou utilizar o utilitario AZMAN para conceder permissões ao Hyper-V.

    De uma olhada nesse artigo: http://www.linhadecodigo.com.br/artigo/2953/delegando-o-controle-e-o-gerenciamento-de-acesso-no-hyper-v.aspx

    Att,

    Marcos, boa tarde!

    Interesssante este link, entretanto o Servidor é Hyper-V Server e não se aplica a este link. De qualquer forma gravei para consultas futuras.
    Será que não estou conseguindo pq o Servidor não está no domínio?

    segunda-feira, 8 de abril de 2013 16:27