none
Permissão adm para aplicativo com usuário padrão RRS feed

  • Pergunta

  • Preciso fazer com meus usuários do domínio acessem um software que roda em mysql, com privilégios de adm, sem ser um usuário adm. Esse software está em uma pasta na unidade C de um segundo servidor que faz parte do domínio. Essa pasta está compartilhada com os usuários do domínio. 

    Em cada usuário padrão eu crio um atalho desse exe na área de trabalho dele, e quando vou acessar ele pede a senha de ADM.

    Já tentei utilizar o comando runas savecred, mas não funciona pra mim pois, ao utilizar esse meu software com o comando runas, quando eu gero um arquivo nesse programa para salvar na área de trabalho do usuário local, ele sempre salva na pasta do usuário Administrador.

    Como faço para dar permissão de ADM para meus usuários padrão, somente a esse programa?


    terça-feira, 21 de junho de 2016 21:05

Respostas

  • Je,

    Já tentou ir na pasta onde está o programa e dar permissões(controle total, etc) ao grupo usuários do domínio? Neste caso, ele teria permissões mais elevadas na pasta.

    O ruim do comando RUNAS é isso aí(de cada usuário que logar ele pedi a senha para executar). Tava criando um script em uma época desligar as estações de um laboratório, porém, toda pessoa que logava pedia a senha do administrador local(já que ele precisa salvar a primeira vez a cada usuário). Aí coloquei a cabeça para pensar e criei um usuário de administrador local, dei o comando RUNAS executando por esse usuário e no atalho, coloquei para toda vida que for executar, aparece a mensagem: "Digite a senha:12346578 para desligar as estações". Isso para cada usuário e não ter que ir até o local e ter que fica salvando a senha... rs

    Voltado ao assunto, tenta dar permissões ao grupo e ver o que dar.

    Observação: Caso essa resposta seja útil, clique em propor como resposta.
    Blog Pessoal: https://diegogouveiace.wordpress.com


    • Marcado como Resposta jefbly quarta-feira, 22 de junho de 2016 11:41
    quarta-feira, 22 de junho de 2016 00:10
  • Bom Dia,

    Com o UAC desabilitado ele apresenta algum erro?

    Ja tive problemas com aplicações e não queria liberar o acesso de administrador.

    O que fiz foi desabilitar o UAC, rodar o Procmon e verificar em qual chave de registro a aplicação solicitava acesso, após isso, dei a permissao na chave de registro e não tive mais problemas.

    • Marcado como Resposta jefbly quinta-feira, 23 de junho de 2016 12:09
    quarta-feira, 22 de junho de 2016 12:00

Todas as Respostas

  • Je,

    Já tentou ir na pasta onde está o programa e dar permissões(controle total, etc) ao grupo usuários do domínio? Neste caso, ele teria permissões mais elevadas na pasta.

    O ruim do comando RUNAS é isso aí(de cada usuário que logar ele pedi a senha para executar). Tava criando um script em uma época desligar as estações de um laboratório, porém, toda pessoa que logava pedia a senha do administrador local(já que ele precisa salvar a primeira vez a cada usuário). Aí coloquei a cabeça para pensar e criei um usuário de administrador local, dei o comando RUNAS executando por esse usuário e no atalho, coloquei para toda vida que for executar, aparece a mensagem: "Digite a senha:12346578 para desligar as estações". Isso para cada usuário e não ter que ir até o local e ter que fica salvando a senha... rs

    Voltado ao assunto, tenta dar permissões ao grupo e ver o que dar.

    Observação: Caso essa resposta seja útil, clique em propor como resposta.
    Blog Pessoal: https://diegogouveiace.wordpress.com


    • Marcado como Resposta jefbly quarta-feira, 22 de junho de 2016 11:41
    quarta-feira, 22 de junho de 2016 00:10
  • Bom dia Diego, então eu fiz isso, Controle total tanto em opções de permissão como na aba segurança, dei controle total pra esse usuário, mas, o ícone do exe, sempre fica com logo de um escudo, exigindo a senha do Administrador.

    Como resolvo esse problema.


    • Editado jefbly quarta-feira, 22 de junho de 2016 11:45
    quarta-feira, 22 de junho de 2016 11:44
  • Bom Dia,

    Com o UAC desabilitado ele apresenta algum erro?

    Ja tive problemas com aplicações e não queria liberar o acesso de administrador.

    O que fiz foi desabilitar o UAC, rodar o Procmon e verificar em qual chave de registro a aplicação solicitava acesso, após isso, dei a permissao na chave de registro e não tive mais problemas.

    • Marcado como Resposta jefbly quinta-feira, 23 de junho de 2016 12:09
    quarta-feira, 22 de junho de 2016 12:00
  • Bom dia Daniel, eu faço esse procedimento no computador do onde o usuário está logado, ou no servidor onde está o software?
    • Editado jefbly quarta-feira, 22 de junho de 2016 12:36
    quarta-feira, 22 de junho de 2016 12:36
  • Já desativei o UAC da máquina local, do servidor e não deu certo. Já fiz um procedimento para desabilitar um programa específico do UAC e tanto do servidor como na máquina local e também não deu certo.

    Só dá certo se eu colocar o usuário como membro do grupo "Administradores do Domínio", se eu colocar somente como membro do grupo "Administradores" não dá certo.

    Alguém mais pode me ajudar?



    • Editado jefbly quinta-feira, 23 de junho de 2016 12:19
    quinta-feira, 23 de junho de 2016 12:09
  • Olá, Socorro, ajuda por favor!!!
    quinta-feira, 23 de junho de 2016 17:18
  • Olá Diogo, deu certo consegui utilizando o programa Application Compatibility Toolkit.

    Obrigado a todos pela ajuda!!!

    quarta-feira, 13 de julho de 2016 14:24