none
SCSM - Lentidão RRS feed

  • Pergunta

  • Srs., Boa tarde!

    Estou com um problema de lentidão muito grande na console do SCSM, quando mando visualizar todos os chamados passa quase 4 minutos para mostar na exibição.

    Tenho 2 servidores virtuais

    MS - 16GB de Ram e Disco de 200GB

    DW - 8GB de RAM e Disco de 400GB

    Abaixo segue tela.

     


    MCP - Windows Server 2003
    quarta-feira, 11 de janeiro de 2012 18:11

Respostas

  • Ola Paulo, O Erro que falou foi por causa no Management Pack selecione, deixe o MP padrão que funciona. As vezes se vc cria um novo para utilizar ele da aquele erro. Sobre a lentidão, se vc utilizar a opção avança e tiver mais que 15 min, ele demora mto.., isso ocorre pois aumenta um a quantidade de opção que precisa trazer. Recomendo utilzar sempre Tipico ou POrtal., pq avança demora mto mais... Poderia marcar como respondido?
    || Aurélio Alves || - http://aurelioalves.wordpress.com
    quarta-feira, 18 de janeiro de 2012 16:17

Todas as Respostas

  • Ola Henrique tudo bem?

    Você realizou a instalação do Service Manager com o SP1?

    Caso sim você realizou a instalação dos Cumulative Updates 3?

    Caso não tenha aplicado segue o link com os binários, não se esqueça de instalar a atualização nas maquinas que possuam a console.

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=28159

    Você realizou a instalação da Base e do Management Server no mesmo servidor? Valide se os recursos de hardware disponibilizados para a máquina estão atendendo.

    Abraços


    Emerson Gomes - http://itchannelbr.wordpress.com/
    quarta-feira, 11 de janeiro de 2012 18:24
    Moderador
  • Bom dia,

            Amigo realizei a instalação do SCSM com o SP1, e fiz o CU3, o management Server se encontra no mesmo servidor da base, com o hardware abaixo.

    Management Server:

    4 processadores

    16gb de memoria

    150GB de Disco

    Obs.: Acho que se trata de alguma customização no sql server, pois só fica lento nas exibições que tem muitos registros.

    Mais alguma ideia ?

    Att.

     


    MCP - Windows Server 2003
    quarta-feira, 11 de janeiro de 2012 19:28
  • Ola Henrique., tudo bem??

     

    Voce fez alguma customização nessa visualização?

    Poderia acessar as propriedades dessas visualização e coloa um print do final de Exibir (As opções com |>)?

    Como esta o desemplenho do SCSM em questão de memoria e processador?

    []'s

     

     

     

     

     

     


    || Aurélio Alves || - http://aurelioalves.wordpress.com
    quarta-feira, 11 de janeiro de 2012 23:35
  • Aurélio,

    O caso é bem estranho; fizemos vários testes através de diferentes console e conseguimos diagnosticar o seguinte:

    1. Todas as exibições de Itens de Configuração (tais como computadores) e Atividades estão funcionando normalmente, mesmo quando tem de exibirem vários resultados (mais de 600!). Ou seja, a causa não é a quantidade de itens que a exibição precisa buscar e retornar;

    2. O problema só está acontecendo quando falamos de incidentes, mas não em todas as exibições de incidentes;

    3. As exibições de incidentes nos quais este erro está ocorrendo: algumas são nativas do proprio sistema (como "Todos os incidentes")  e algumas foram criadas por nós, enquanto o restante funciona normalmente;

    Chegamos a criar uma nova exibição idêntica a "Todos os incidentes" com outro nome e em miléssimos ela exibiu mesmo todos os incidentes, enquanto a outra continuava parada. Esta nova exibição foi armazenada em um management pack criado por nós; deletamos esta exibição e desta vez foi armazenada no MP default do sistema, e também funcionou. Ou seja, a causa não parece ser o MP onde a exibição foi armazenada.

    Fizemos outro teste pegando uma exibição de incidente que havíamos criado e modificamos o critério para exibir algo que outra exibição não estava conseguindo; o resultado é que esta exibição que foi modificada não funciona mais.

    Em suma: não sabemos exatamente o que está acontecendo; só conseguimos chegar até aí, no momento.

    Segue abaixo o print do servidor; já observamos também o SQL durante os testes, e ele está rodando perfeitamente, com muita folga, sem alertas.

    Alguma idéia?

     

     


    MCP - Windows Server 2003
    quinta-feira, 12 de janeiro de 2012 13:49
  • Ola Henrique..

     

    Poderia acessar a exibição e me enviar um print da opção Exibir?

     

    Essa lentidão pode ser a classe escolhida do Incidente. Ao tenta criar uma exbição vc tem a opção de selecionar as classes de Incidente, Incidente (Portal) e Incidente (avança), a lentidão da busca depente da opção que voce escolheu.

     

    []'s


    || Aurélio Alves || - http://aurelioalves.wordpress.com
    • Sugerido como Resposta Aurélio Alves quarta-feira, 18 de janeiro de 2012 16:17
    quinta-feira, 12 de janeiro de 2012 13:56
  • Olá Aurélio,

    Estou atuando neste problema junto com o Henrique Alves :-)

    Li sua resposta e fiz uma revisão geral: todas as exibições que nós criamos para incidentes utilizamos a classe "Incidente (Avançado)".Porém, como Henrique respondeu antes, somente algumas exibições default e algumas que criamos é que estão apresentando esse problema de lentidão :-(

    Mas resolvi seguir sua linha de raciocínio e fiz novos testes: quando usei a classe "Incidente (Típico)" não tivemos problemas e a nova exibição funcionou, mas quando mudei para "Incidente (Avançado)" foi exibida a mensagem abaixo:

    "Data: 12/01/2012 11:15:50
    Aplicativo: Editar 1o Nível - Central de Serviços
    Versão do Aplicativo: 7.0.6555.128
    Severidade: Erro
    Mensagem: Falha na consulta ao adaptador 'dataportal:ManagementPackViewWriteAdapter'.

    Microsoft.EnterpriseManagement.UI.DataModel.QueryFailedException: Falha na consulta ao adaptador 'dataportal:ManagementPackViewWriteAdapter'. ---> : A verificação falhou com 1 erros:
    -------------------------------------------------------
    Erro 1:
    : Failed to verify View: View.af2490ddf1154321ba7f66c8f012e7a5
    Failed to verify reference to ViewType: GridViewTypeCannot resolve identifier CoreIncident!System.WorkItem.Incident in the context of management pack MP_PSUAPE_01. Unknown alias: CoreIncident
    -------------------------------------------------------

    Failed to verify View: View.af2490ddf1154321ba7f66c8f012e7a5Failed to verify reference to ViewType: GridViewTypeCannot resolve identifier CoreIncident!System.WorkItem.Incident in the context of management pack MP_PSUAPE_01. Unknown alias: CoreIncident
       --- Fim do rastreamento de pilha de exceções internas ---
       em Microsoft.EnterpriseManagement.UI.DataModel.DataPortalService.EndQuery(IAsyncResult result)
       em Microsoft.EnterpriseManagement.UI.SdkDataAccess.Common.DataAccessQuery.QueryAdapter(Uri adapterUri, Uri dataSourceUri, IList`1 inputs, Dictionary`2 parameterList, DataQueryBase query)
       em Microsoft.EnterpriseManagement.UI.SdkDataAccess.Common.DataAccessQuery.QueryAdapter(Dictionary`2 parameterList, IList`1 inputs, Type adapterType, Uri adapterUri)
       em Microsoft.EnterpriseManagement.ServiceManager.UI.Administration.View.ViewHelper.CreateUpdateView()
       em Microsoft.EnterpriseManagement.ServiceManager.UI.Administration.View.ViewHelper.AcceptChanges(WizardMode wizardMode)
       em Microsoft.EnterpriseManagement.UI.WpfWizardFramework.PropertySheetDialogBase.bgw_DoAcceptWork(Object sender, DoWorkEventArgs e)
       em System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
       em System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
    : A verificação falhou com 1 erros:
    -------------------------------------------------------
    Erro 1:
    : Failed to verify View: View.af2490ddf1154321ba7f66c8f012e7a5
    Failed to verify reference to ViewType: GridViewTypeCannot resolve identifier CoreIncident!System.WorkItem.Incident in the context of management pack MP_PSUAPE_01. Unknown alias: CoreIncident
    -------------------------------------------------------

    Failed to verify View: View.af2490ddf1154321ba7f66c8f012e7a5Failed to verify reference to ViewType: GridViewTypeCannot resolve identifier CoreIncident!System.WorkItem.Incident in the context of management pack MP_PSUAPE_01. Unknown alias: CoreIncident
    : Failed to verify View: View.af2490ddf1154321ba7f66c8f012e7a5
    Failed to verify reference to ViewType: GridViewTypeCannot resolve identifier CoreIncident!System.WorkItem.Incident in the context of management pack MP_PSUAPE_01. Unknown alias: CoreIncident
    : Failed to verify reference to ViewType: GridViewType
    Cannot resolve identifier CoreIncident!System.WorkItem.Incident in the context of management pack MP_PSUAPE_01. Unknown alias: CoreIncident
    : Cannot resolve identifier CoreIncident!System.WorkItem.Incident in the context of management pack MP_PSUAPE_01. Unknown alias: CoreIncident"

    MP_PSUAPE_01 é um pacote de gerenciamento não lacrado que criamos para armazenar o conteúdo de listas, filas, e exibições de incidentes, atividaes, computadores e serviços corporativos que nós mesmos criamos. É utilizado sem problemas a bastante tempo.

    O que será que está havendo? E por que até 3a-feira pela manhã estava tudo bem e depois começou isso, senão modificamos nada no ambiente, e desde o começo tanto o servidor quanto as consoles estão atualizadas até o CU3?

    Paulo Xaxá

     

     

     

     

    quinta-feira, 12 de janeiro de 2012 14:32
  • Aurélio,

    Seguindo sua dica, alteramos a classe da exibição de "Incidente (Avançado)" para "Incidente (Típico)", e estão todas funcionando perfeitamente.

    Só para fechar, criamos 2 novas exibiçoões usando a classe "Incidente (Avançado)": o resultado demora para aparecer, mas é exibido.

    Paulo Xaxá

    sexta-feira, 13 de janeiro de 2012 11:58
  • Ola Paulo, O Erro que falou foi por causa no Management Pack selecione, deixe o MP padrão que funciona. As vezes se vc cria um novo para utilizar ele da aquele erro. Sobre a lentidão, se vc utilizar a opção avança e tiver mais que 15 min, ele demora mto.., isso ocorre pois aumenta um a quantidade de opção que precisa trazer. Recomendo utilzar sempre Tipico ou POrtal., pq avança demora mto mais... Poderia marcar como respondido?
    || Aurélio Alves || - http://aurelioalves.wordpress.com
    quarta-feira, 18 de janeiro de 2012 16:17
  • Boa tarde, Aurélio!

    Tudo bem?

    Sou novo no forum e estou com esse mesmo problema de lentidão.

    Irei fazer esses teste, mas gostaria de saber como faço para trocar do modo Incidente (Avançado) para o modo Inicidente (Típico).

    Pois procurei na console e não consegui ver esse tipo de configuração. Pode ser no Autoring tools, que eu modifico essa configuração?

    Edson Carlos

    terça-feira, 17 de abril de 2012 17:23
  • 
    

    Sim.

    Clique com o botão direito na exibição e clique em editar exibição. Na opção criteria, clique em procurar. Voce pode selecionar a opção incidente ou modifiar  classe para ver todas as opções como incidente (Avançado).

    []'s

    Aurélio Alves


    || Aurélio Alves || - http://aurelioalves.wordpress.com

    quarta-feira, 18 de abril de 2012 17:37
  • Bom dia, Aurélio!

    Irei fazer os teste para ver se continua a lentidão.

    Obrigado pelas informações, pois me ajudou bastante.

    Edson Carlos


    Edson Carlos

    sexta-feira, 20 de abril de 2012 12:58
  • Bom dia!<o:p></o:p>

    Aurélio
    tentei fazer conforme a sua orientação a mudança do incidente Avançado para o Típico, mas não consegui achar na console do Autoring Tools esse tipo de informação. Estou fazendo várias mudanças de melhorias no ambiente e acaba a informação passando despercebida. Você tem algum tutorial explicando melhor como faz para mudar essa configuração no Autoring Tools o Incidente do modo avançado para o modo Típico. Desculpe se estou sendo chato, mas para mim as informações são todas novas e estou aprendendo a utilizar o sistema.

    Desde já lhe agradeço!<o:p></o:p>

    Edson<o:p></o:p>



    Edson Carlos

    quinta-feira, 10 de maio de 2012 14:42
  • Edson, bom dia.

    Não é no Authoring Tools, e sim na própria console do Service Manager:

    1. No Gerenciamento de Incidentes, clique na opção "Criar Exibição" (se for uma exibição já existente, clique nela com o botão direito do mouse e depois em "Propriedades");
    2. Na tela de edição da exibição, acesse a área "Critérios". Em "Procurar objetos de uma classe específica", clique no botão "Procurar";
    3. Na tela "Selecionar uma classe", mude a listagem "Exibir" para "Classes de combinação";
    4. Na mesma tela, no campo "Filtrar por nome", pesquise a classe desejada (neste caso, "Incidentes");
    5. Na área abaixo serão exibidas as classes localizadas; é só selecionar agora a classe "Incidente (avançado) e clicar em "Ok". O restante é criar/modificar a exibição de acordo com os critérios que você precisar.

    • Sugerido como Resposta edsoncarlo terça-feira, 15 de maio de 2012 14:21
    quinta-feira, 10 de maio de 2012 15:15
  • Bom dia, Aurélio!

    Obrigado pelo tutorial, pois ajudou muito.

    O item funcionou perfietamente quando troco o tipo de incidente para o tipíco. Quando volto com o avançado a lentião volta.

    Obrigado pela ajuda!

    Edson


    Edson Carlos

    terça-feira, 15 de maio de 2012 14:23
  • Bom dia, Paulo!

    Obrigado pelo tutorial, pois ajudou muito.

    O item funcionou perfietamente quando troco o tipo de incidente para o tipíco. Quando volto com o avançado a lentião volta.

    Obrigado pela ajuda!

    Edson


    Edson Carlos


    Edson Carlos

    quinta-feira, 17 de maio de 2012 12:47