locked
Cópia de e-mail interno para um e-mail externo RRS feed

  • Pergunta

  • Mestre,

     

    Um usuário aqui na empresa comprou um iPhone e me pediu para sincronizar com o Exchange. Após vários testes só consegui fazer a sincronização com o Exchange quando o iPhone está na rede interna. Quando tenta pela internet dá erro.

     

    Para que o usuário recebesse uma cópia dos e-mails de sua caixa postal do Exchange em seu iPhone, configurei no webmail para que enviasse uma cópia de todas suas mensagens para um e-mail dele no Gmail. Até aqui funcionou perfeitamente. O problema é que como os e-mails enviados internamente não são enviados para o webmail, consequentemente não é enviada uma cópia para o Gmail e o usuário não os recebe em seu iPhone.

     

    Existe alguma configuração no Exchange para que enviasse uma cópia dos e-mails que o usuário recebe internamente para seu e-mail do Gmail?

     

    Obrigado.

    quinta-feira, 11 de dezembro de 2008 15:17

Respostas

Todas as Respostas

  • Ola Wander,

    Antes de mais nada, dê uma pesquisada aqui no fórum pois outros usuários já abriram posts falando do Iphone.
    O Iphone não usa activesync como o windows mobile, então o que tu tem que fazer é configurar o mesmo com o endereço externo do teu exchange e verificar o certificado.

    O lance do Gmail não considero a melhor opção, mas tu pode fazer redirect para que todas as mensagens saiam para o gmail.

    Abs.
    quinta-feira, 11 de dezembro de 2008 15:30
  • Olá Rodrigo,

     

    Eu configurei o iPhone com o endereço externo, mas dá erro no certificado. O que tenho que fazer para o iPhone aceitar o certificado?

     

    Vcx tem algum tutorial para fazer esse redirect, pq não achei.

     

    Obrigado

    quinta-feira, 11 de dezembro de 2008 16:42
  • Ola Wander,

    Aí está o seu problema. Veja esse artigo para lhe ajudar no processo:
    http://windowsitpro.com/article/articleid/96730/getting-your-iphone-to-sync-with-exchange-2003.html

    Abs.
    quinta-feira, 11 de dezembro de 2008 16:51
  • Rodrigo,

     Obrigado pela dica, mas eu não entendo muito de certificado. Existe algum tutorial que explique melhor como criar um certificado que funcione com o OWA e iPhone?

    quinta-feira, 11 de dezembro de 2008 17:01
  • Ola Wander,

    Procura lá no site do anderson por certificado e SAN, ele vai te ajudar no seu problema.
    Temos vários posts aqui também no fórum falando disso, de uma pesquisada.

    Abs.

    Se útil classifique!
    quinta-feira, 11 de dezembro de 2008 17:04
  • Rodrigo,

     

    O erro que aparce no iPhone é que o certificado não pôde ser verificado. Mesmo clicando em aceitar, ele não conecta.

     

    Eu dei uma lida nos tutoriais sobre certificado e SAN que vc me passou. Eu preciso instalar o OCS 2007 para criar um certificado? Esqueci de menciuonar que aqui eu uso o Small Business Server 2003. Isso muda alguma coisa? No Wizard de configuração de Internet, ele cria um certificado. Esse certificado não pode ser usado?

    quinta-feira, 11 de dezembro de 2008 17:41
  • Ola Wander,

    O OCS é um outro produto, que não tem nada a ver com certificado, na verdade ele faz uso de certificados.
    O que você precisa é do Certificate Services do Windows Server, só isso. No caso do iphone é estranho, mas o procedimento é aquele mesmo que tá no tutorial acima.

    Abs.
    quinta-feira, 11 de dezembro de 2008 18:22
  • Ola Wander,

     

    Junto com a dica do Rodrigo, o IPhone da apple na nova versão dele é licensiado para o Activesync, teu problema provavelmente está no certificado, tu usa o ISA? Tu fez a instalacao de certificado e configurou AutoDiscover e URLs para acesso externo? Fora isso, usa o http://www.msexchange.org/articles_tutorials/exchange-server-2007/tools/exchange-server-remote-connectivity-analyzer-tool-part1.html e testa o acesso de fora se funcionar com este cara funciona com o Iphone.

     

    quinta-feira, 11 de dezembro de 2008 18:28
  • Rodrigo,

     

    No servidor eu tenho a Autoridade de Certificação instalada. Na parte de certificados emitidos, tem 9 certificados lá, no qual 6 estão expirados.

     

    Usamos aqui o OWA. Toda a vez que entramos no OWA, vem uma tela que há um problema no certificado de segurança do site. Escolhemos para entrar mesmo assim e funciona normal. Não sempre tem problema de certificado aqui. Gostaria de resolver isso.

     

    O que poderia ser?

     

    Rodrigo,

    Tentei acessar agora o OWA e não consegui. Aparece um erro de que não encontrou a página.

    Entrei na configuração do IIS/sites padrão/diretório virtual do Exchange e fui em propriedades. Na aba Diretório Virtual o caminho que está lá é: \\.\BackOfficeStorage\anastassiadis.com.br\MBX. Acredito que esse caminho deva estar errado.

     

    O caminho correto seria este: C:\Arquivos de programas\Exchsrv\webdata? Eu fui tentar mudar para esse caminho mas não achei o diretório webdata.

     

    Alguma dica do que eu possa fazer para deixar o OWA funcionando?

     

    Obrigado

     

    quinta-feira, 11 de dezembro de 2008 18:32