none
Scripts Vista RRS feed

  • Pergunta

  • Srs.

    Em um ambiente onde o DC é W2K3, as estações são Vista e todos os usuários são administradores locais de suas máquinas.

    Todos os scripts que coloco para executar no logon via GPO não funcionam, sejam scripts de mapeamento de pasta, impressoras ou avisos.

    Como faço para fazer esses scripts funcionarem?

    Obrigado.

     

     

     

    terça-feira, 23 de março de 2010 20:34

Respostas

  • Olá Cláudio,

    O problema continua sim. Mas já descobri o porque, o Vista não executa scripts de logon via GPO, quando o usuário em questão é administrador local da máquina.

    Para conhecimento, re-posto o link:

    http://technet.microsoft.com/pt-br/library/cc766208(WS.10).aspx

    No tópico "Os scripts da Diretiva de Grupo podem falhar devido ao Controle de Conta de Usuário" explica a falha.

    Obrigado pela atenção.

     

     

     

    • Sugerido como Resposta tiagosoares terça-feira, 13 de abril de 2010 20:33
    • Marcado como Resposta Fábio JrModerator sexta-feira, 13 de janeiro de 2012 15:24
    terça-feira, 13 de abril de 2010 17:29

Todas as Respostas

  • Olá CH_TN,

                  Eu precisaria de algumas informações a mais para poder ajudar. Você pode postar aqui o seu script? É registrado algum evento informando erro de processamento de GPO? Você pode no VISTA executar um GPRESULT e postar o resultado aqui?

    Aguardo notícias...

    terça-feira, 23 de março de 2010 23:32
  • Tenho certeza que o problema é no Vista, pois os pc`s com xp executam tudo perfeitamente.

    Segue, script simples para mapeamento de impressora:

    Set objNetwork = WScript.CreateObject("WScript.Network")

    objNetwork.AddWindowsPrinterConnection "\\servidor\impressora"


    Resultado do comando gpresult:

    RSOP data for DOMINIO\usuario on COMPUTADOR : Logging Mode           
    ----------------------------------------------------------

    OS Configuration:            Member Workstation
    OS Version:                  6.0.6002
    Site Name:                   Primeiro-site-padrao
    Roaming Profile:             N/A
    Local Profile:               C:\Users\usuario
    Connected over a slow link?: No


    COMPUTER SETTINGS
    ------------------
        CN=COMPUTADOR,OU=Computers,OU=MyBusiness,DC=dominio,DC=local
        Last time Group Policy was applied: 25/03/2010 at 16:16:09
        Group Policy was applied from:      servidor.dominio.local
        Group Policy slow link threshold:   500 kbps
        Domain Name:                        DOMINIO
        Domain Type:                        Windows 2000

        Applied Group Policy Objects
        -----------------------------
            Small Business Server - Diretiva do Windows Vista
            Computador Cliente do Small Business Server
            Diretiva de Assistência Remota do Small Business Server
            Default Domain Policy
            Mapeamento Impressora
            Diretiva de Auditoria Clientes
            WSUS-SERVIDOR01
            Local Group Policy

        The following GPOs were not applied because they were filtered out
        -------------------------------------------------------------------
            Diretiva de Senha de Domínio do Small Business Server
                Filtering:  Disabled (GPO)

            Firewall do Windows - Small Business Server
                Filtering:  Denied (WMI Filter)
                WMI Filter: PostSP2

            Firewall de Conexão com a Internet - Small Business Server
                Filtering:  Denied (WMI Filter)
                WMI Filter: PreSP2

            Diretiva de Bloqueio do Small Business Server
                Filtering:  Disabled (GPO)

            Diretiva de Configurações Comuns do Small Business Server Update Services
                Filtering:  Disabled (GPO)

            Diretiva de Computadores Cliente do Small Business Server Update Services
                Filtering:  Disabled (GPO)

        The computer is a part of the following security groups
        -------------------------------------------------------
            BUILTIN\Administrators
            Everyone
            BUILTIN\Users
            NT AUTHORITY\NETWORK
            NT AUTHORITY\Authenticated Users
            This Organization
            COMPUTADOR$
            Computadores do domínio
            CERTSVC_DCOM_ACCESS
            System Mandatory Level


    USER SETTINGS
    --------------
        CN=USUARIO,OU=Users,OU=MyBusiness,DC=dominio,DC=local
        Last time Group Policy was applied: 25/03/2010 at 16:16:09
        Group Policy was applied from:      servidor.dominio.local
        Group Policy slow link threshold:   500 kbps
        Domain Name:                        DOMINIO
        Domain Type:                        Windows 2000

        Applied Group Policy Objects
        -----------------------------
            Default Domain Policy
            Mapeamento Impressora

        The following GPOs were not applied because they were filtered out
        -------------------------------------------------------------------
            Diretiva de Senha de Domínio do Small Business Server
                Filtering:  Disabled (GPO)

            Firewall do Windows - Small Business Server
                Filtering:  Denied (WMI Filter)
                WMI Filter: PostSP2

            WSUS-SERVIDOR01
                Filtering:  Disabled (GPO)

            Firewall de Conexão com a Internet - Small Business Server
                Filtering:  Denied (WMI Filter)
                WMI Filter: PreSP2

            Diretiva de Servidores do Small Business Server Update Services
                Filtering:  Disabled (GPO)

            Computador Cliente do Small Business Server
                Filtering:  Not Applied (Empty)

            Diretiva de Auditoria Clientes
                Filtering:  Not Applied (Empty)

            Diretiva de Bloqueio do Small Business Server
                Filtering:  Disabled (GPO)

            Diretiva de Assistência Remota do Small Business Server
                Filtering:  Disabled (GPO)

            Local Group Policy
                Filtering:  Not Applied (Empty)

            Diretiva de Configurações Comuns do Small Business Server Update Services
                Filtering:  Disabled (GPO)

            Diretiva de Computadores Cliente do Small Business Server Update Services
                Filtering:  Disabled (GPO)

            Small Business Server - Diretiva do Windows Vista
                Filtering:  Not Applied (Empty)

        The user is a part of the following security groups
        ---------------------------------------------------
            Usuários do domínio
            Everyone
            Offer Remote Assistance Helpers
            BUILTIN\Administrators
            BUILTIN\Users
            NT AUTHORITY\INTERACTIVE
            NT AUTHORITY\Authenticated Users
            This Organization
            LOCAL
            Admins. do domínio
            Mobile Users
            Internet Users
            Suporte
            Report Users
            Web Workplace Users
            CERTSVC_DCOM_ACCESS
            Oferecer Auxiliares para Assistência Remota
            High Mandatory Level
    _____________________________________________________________________________________________

    quinta-feira, 25 de março de 2010 19:26
  • CH_TN,

    Neste caso o problema deve ser no vista mesmo. O Vista já tem o driver da impressora? Se você fizer este procedimento na manualmente, logado no VISTA, digitar \\servidor e mandar conectar na impressora, funciona ou dá algum erro de driver?

    quinta-feira, 25 de março de 2010 22:26
  • Sim esse procedimento funciona normalmente, a conexão manual da impressora. Lembre-se que não é somente o mapeamento de impressoras que não roda, mas são todos os scripts de login.

    http://technet.microsoft.com/pt-br/library/cc766208(WS.10).aspx

    Nesse link, existe um tópico chamando: "Os scripts da Diretiva de Grupo podem falhar devido ao Controle de Conta de Usuário." E até existe uma solução, fazer o agendamento da execução do script via agendador de tarefas.

    Mas acho estranho pois o UAC das máquinas vista está desativado. E como tenho um ambiente misto, não dá pra adotar essa solução.


     

     

     

    sexta-feira, 26 de março de 2010 00:19
  • Desculpa a demora pra responder, precisei me ausentar durante um tempo. Você continua com problema? Tem chance do seu vista estar negando a execução de arquivos vbs, seja pelo antivírus ou qualquer outra política?
    terça-feira, 13 de abril de 2010 10:19
  • Olá Cláudio,

    O problema continua sim. Mas já descobri o porque, o Vista não executa scripts de logon via GPO, quando o usuário em questão é administrador local da máquina.

    Para conhecimento, re-posto o link:

    http://technet.microsoft.com/pt-br/library/cc766208(WS.10).aspx

    No tópico "Os scripts da Diretiva de Grupo podem falhar devido ao Controle de Conta de Usuário" explica a falha.

    Obrigado pela atenção.

     

     

     

    • Sugerido como Resposta tiagosoares terça-feira, 13 de abril de 2010 20:33
    • Marcado como Resposta Fábio JrModerator sexta-feira, 13 de janeiro de 2012 15:24
    terça-feira, 13 de abril de 2010 17:29
  • Entendi então o que tá acontecendo. Quando eu faço os meus mapeamentos aqui para os usuários, eu não uso script, eu uso Group Policies Preferences, que funcionou muito bem, mesmo no VISTA ou Windows 7. Você já tentou executar o script usando o launchapp.wsf, conforme ele fala no tópico abaixo?

    quarta-feira, 14 de abril de 2010 15:27
  • Entendi então o que tá acontecendo. Quando eu faço os meus mapeamentos aqui para os usuários, eu não uso script, eu uso Group Policies Preferences, que funcionou muito bem, mesmo no VISTA ou Windows 7. Você já tentou executar o script usando o launchapp.wsf, conforme ele fala no tópico abaixo?

    quarta-feira, 14 de abril de 2010 15:27