none
calcular media desprezando valores repetidos RRS feed

  • Pergunta

  • Boa tarde,

    Tenho uma planilha que preciso calcular a média de uma linha, mas preciso desprezar o zero e também quero que ele não calcule eventuais valores repetidos.

    Ex:

    11,58 12,13 9,50 0 9,72 11,70 11,70

    para desprezar o zero eu utilizei a seguinte fórmula

    =MÉDIA(SE(H5:M5>0;H5:M5))

    agora o que eu preciso é desprezar o valor repetido fazendo com que ele seja calculado uma única vez, pois a questão é que quando ele soma todos os valores e divide pela quantidade de células que são 7 o resultado é 9,47 agora se ele calcular todos desprezando a repetição o valor será de 7,80 que seria o correto no meu caso.

    quarta-feira, 23 de julho de 2014 16:06

Todas as Respostas

  • Olá Xará!

    Considerando os valores no intervalo descrito, tente as fórmulas conforme imagem:

    As fórmulas são matriciais, portanto você deve digitar CTRL+SHIFT+ENTER ao invés de ENTER. E a fórmula funciona com os valores nesse intervalo especifico, caso o intervalo mude, tem que rever o fator "+64" da fórmula para que a fórmula CARACT traga o valor correspondente da letra da coluna onde está o primeiro valor.

    Observação, os valores de médias que você descreveu na pergunta não batem com os cálculos feitos com o número que você deu de exemplos.

    É possível fazer isso de forma mais simples se você colocar uma linha de apoio que conte quantas vezes o valor já se repetiu até a coluna equivalente. Tendo essa coluna, basta usar a função MÉDIASES com os critérios ajustados para a necessidade.

    Para entender melhor, vou disponibilizar este modelo para baixar com as duas formas de realizar este cálculo:

    https://dl.dropboxusercontent.com/u/80811028/C%C3%A1lculos%20de%20m%C3%A9dias%20diversas.xlsx


    Rafael Kamimura




    quarta-feira, 23 de julho de 2014 17:42