none
NLB não funciona conforme esperado. RRS feed

  • Pergunta

  • Pessoal, boa noite.


    Temos 2 ISAs instalados, CSS em réplica. As 2 máquinas fazem a comunicação intra-array através de rede privativa (heartbeat).

    Habilitamos o NLB na interface interna, porém o mesmo não está funcionando.

    Na verdade, o array está se comportando como se um dos nós fosse master, respondendo com o IP virtual. Se eu rebooto este server com uma janela de ping para o ip virtual aberta, eu perco pacotes até que o servidor volte ao ar. Neste momento, caso eu tente acessar a internet com o proxy configurado com o ip virtual, não é possível, pois o browser não encontra o servidor.

    Caso o boot seja no outro nó, o ip virtual continua respondendo.

    Alguma dica?


    Agradeço antecipadamente.


    Abraços,


    Álvaro

    sexta-feira, 15 de janeiro de 2010 01:34

Respostas

  • Um clear arp no switch resolveu a pendenga!

    Agora ficou um dúvida na minha cabeça: O NLB não cria um MAC virtual não? Como é que os switches enxergam o VIP?

    Abraço,

    AL

    • Marcado como Resposta AlvaroMotta quinta-feira, 18 de março de 2010 13:05
    sexta-feira, 15 de janeiro de 2010 19:50

Todas as Respostas

  • Ele regsitra algum tipo de erro no event vieweR?

    Luiz Fernando Dias - MVP .::http://lfdias.mvpbrasil.com.br::.::http://lfdias.mvpbrasil.com.br/blog::.
    sexta-feira, 15 de janeiro de 2010 12:21
    Moderador
  • Oi Luiz, bom dia.

    Lá vem voce me salvando novamente .... :o))) Obrigado.

    Meu amigo, no eventvwr não tem nenhuma msg significativa. Aqui onde me encontro, o sp3 do 2k3 não é homologado. Voce saberia me dizer se tem alguma coisa a ver?

    Mais uma vez, obrigado.

    Abraço,

    AL

    sexta-feira, 15 de janeiro de 2010 12:35
  • SP3, do 2003?
    Luiz Fernando Dias - MVP .::http://lfdias.mvpbrasil.com.br::.::http://lfdias.mvpbrasil.com.br/blog::.
    sexta-feira, 15 de janeiro de 2010 13:55
    Moderador
  • Sim, o 2003 está com sp2.  Não deve ser esse o problema, visto que o cliente tem outro array em isa 2006, 2k3 com sp2 e o nlb está funcionando.

    O ISA 2006 está com o sp1 instalado e com o kb971143.

    De acordo com o eventvwr, o wlbs está funcionando de forma correta.

    AL
    sexta-feira, 15 de janeiro de 2010 14:45
  • Não existe SP3 do 2003...só SP2 mesmo.

    Estranho.

    Como estão as configurações das placas de rede tanto internas quanto externas dos ISAs?
    Luiz Fernando Dias - MVP .::http://lfdias.mvpbrasil.com.br::.::http://lfdias.mvpbrasil.com.br/blog::.
    sexta-feira, 15 de janeiro de 2010 14:49
    Moderador
  • Nó 1:

    10.32.1.13/24

    Nó 2:
    10.32.1.100/24

    VIP: 10.32.1.200

    O DG está virado para a DMZ e tem uma rota estática para a rede 10.

    De acordo com o eventvwr, o processo está certíssimo .....

    Estamos desconfiando de entrada na tabela arp do switch, mas temos que esperar pelos responsáveis pelos switches chegarem para dar uma olhada.

    sexta-feira, 15 de janeiro de 2010 15:07
  • Pode ser o switch sim...

    E as placas externas?
    Luiz Fernando Dias - MVP .::http://lfdias.mvpbrasil.com.br::.::http://lfdias.mvpbrasil.com.br/blog::.
    sexta-feira, 15 de janeiro de 2010 17:42
    Moderador
  • Um clear arp no switch resolveu a pendenga!

    Agora ficou um dúvida na minha cabeça: O NLB não cria um MAC virtual não? Como é que os switches enxergam o VIP?

    Abraço,

    AL

    • Marcado como Resposta AlvaroMotta quinta-feira, 18 de março de 2010 13:05
    sexta-feira, 15 de janeiro de 2010 19:50