none
Erro ao tentar uma conexão remota via powershell RRS feed

  • Pergunta

  • Boa noite, estou tentando fazer uma conexão remota com o exchange via powershell utilizando o comando

    New-PSSession -ConfigurationName Microsoft.Exchange - ComputerName exch02 -Credential meudominio\conta.teste


    Quando dou um enter me abre a tela de autenticação solicitando a senha da conta, eu digito e mesma, logo em seguida vem o erro.

    [exch02] Falha ao conectar ao servidor remoto com a seguinte mensagem de erro: The WS-Management service cannot process the request. The resource URI (http://schemas.microsoft.com/powershell/Microsoft.Exchange) was not found in the WS-Management catalog. The catalog contains the metadata that describes resources, or logical endpoints.

    Quando eu executo o comando no servidor que eu preciso acessar

    Get-PSSessionConfigurarion

    Me retorna:

    microsoft.powershell

    microsoft.PowerShell32

    microsoft.ServerManager

    Não tem o Microsoft.Exchange

    Alguém ai sabe como adicionar o recurso Microsoft.Exchange?

    A versão do Exchange é 2010 com SP2.


    Bruno.



    sexta-feira, 6 de setembro de 2013 21:44

Respostas

  • Fala Bruno, beleza?

    Dá uma olhada se o procedimento citado neste KB resolve seu problema:

    support.microsoft.com/kb/976839/pt-br

    Espero ter ajudado!

    Abraço


    Fernando Henrique da Silva – Microsoft Contingent Staff

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    TechNet Community Support

    Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quarta-feira, 11 de setembro de 2013 18:43

Todas as Respostas

  • Bom dia, alguém tem alguma luz ai para dar uma força?

    Obrigado.


    Bruno.

    segunda-feira, 9 de setembro de 2013 12:59
  • Fala Bruno, beleza?

    Dá uma olhada se o procedimento citado neste KB resolve seu problema:

    support.microsoft.com/kb/976839/pt-br

    Espero ter ajudado!

    Abraço


    Fernando Henrique da Silva – Microsoft Contingent Staff

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    TechNet Community Support

    Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quarta-feira, 11 de setembro de 2013 18:43
  • Fala Fernando,

    Esse procedimento eu já executei no meu ambiente de teste, usei o comando agora

    New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri http://exchange/PowerShell/ -Authentication Kerberos -Credential (Get-credential)
    Acho que irá funcionar, acusou erro do meu certificado que está vencido, estou renovando ele para testar, assim que finalizar os testes eu posto o resultado aqui.

    Bruno.

    • Sugerido como Resposta fernando silva 1 sexta-feira, 13 de setembro de 2013 13:27
    quinta-feira, 12 de setembro de 2013 18:49
  • Algum retorno Bruno?

    Fernando Henrique da Silva – Microsoft Contingent Staff

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    TechNet Community Support

    Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 16 de setembro de 2013 18:02
  • Funcionou, depois de renovar os certificados no meu ambiente de homologação deu certo, obrigado pelo apoio Fernando.

    Bruno.

    segunda-feira, 23 de setembro de 2013 20:01