none
PROCV ou VBA RRS feed

  • Pergunta

  • Ola! preciso de uma ajuda da seguinte maneira:

    Em Plan2 eu tenho um banco de dados - Cod. Nome-Cnpj-valor- datavenc. -valorpagto- data pagto

    Em plan1 eu montei um formulario na propria planilha mesmo e gostaria de chamar pelo cod. do cliente ou CNPJ que seria melhor ainda, todos os lançamentos efetuados daquele cliente.

    Seria possivel vcs me ajudarem neste problema.

    Grato!

     

    terça-feira, 26 de outubro de 2010 01:06

Respostas

  • Pelo PROCV é possível, considerando que sua lista de códigos está em ordem crescente, por exemplo. Ficaria na célula de Plan1 onde deve aparecer o nome do cliente (supondo que o código digitado no seu formulário em Plan1 seja na célula A2):

    =PROCV(A2;Plan2!A:G;2)

    Para buscar o CNPJ lá em Plan2, seria:

    =PROCV(A2;Plan2!A:G;3)

    E assim sucessivamente. O primeiro argumento (no exemplo A2) é onde está a informação chave que deverá ser pesquisada, no caso o código do cliente. No argumento Plan2!A:G estou informando que a matriz de dados está em Plan2 (o sinal de exclamação indica que é uma planilha de valores) nas colunas A até G. E o terceiro argumento é qual coluna da matriz de dados que deve ser mostrado quando encontrar a ocorrência, no caso do nome é a 2ª coluna, para o CNPJ é a terceira coluna, para o valor é a 4ª coluna, etc.

    Detalhe: se não encontrar o código, o resultado que é mostrado será o último valor da matriz de dados, o último código pesquisado na matriz de dados.


    Fernando Nishimura de Aragão
    Se a resposta foi útil, clique no ícone ao lado para avaliar positivamente o participante. Obrigado.
    terça-feira, 26 de outubro de 2010 16:33
  • Olá Fernando! o problema é que o PROCV eu sei fazer, mas o que eu quero é: suponha que o cliente de cod. 005 tenha 10 linhas de lançamentos, lá na plan1 qdo eu digitar o cod. ou o CNPJ eu quero que me apareça os 10 lançamentos deste cliente. Acho que desta forma com o PROCV não tem como fazer ou tem?
    quarta-feira, 27 de outubro de 2010 00:46
  • Amigos,

    acredito que somente com o Access.


    Gilberto Soares Lopes
    quarta-feira, 3 de novembro de 2010 14:26
    Moderador

Todas as Respostas

  • Pelo PROCV é possível, considerando que sua lista de códigos está em ordem crescente, por exemplo. Ficaria na célula de Plan1 onde deve aparecer o nome do cliente (supondo que o código digitado no seu formulário em Plan1 seja na célula A2):

    =PROCV(A2;Plan2!A:G;2)

    Para buscar o CNPJ lá em Plan2, seria:

    =PROCV(A2;Plan2!A:G;3)

    E assim sucessivamente. O primeiro argumento (no exemplo A2) é onde está a informação chave que deverá ser pesquisada, no caso o código do cliente. No argumento Plan2!A:G estou informando que a matriz de dados está em Plan2 (o sinal de exclamação indica que é uma planilha de valores) nas colunas A até G. E o terceiro argumento é qual coluna da matriz de dados que deve ser mostrado quando encontrar a ocorrência, no caso do nome é a 2ª coluna, para o CNPJ é a terceira coluna, para o valor é a 4ª coluna, etc.

    Detalhe: se não encontrar o código, o resultado que é mostrado será o último valor da matriz de dados, o último código pesquisado na matriz de dados.


    Fernando Nishimura de Aragão
    Se a resposta foi útil, clique no ícone ao lado para avaliar positivamente o participante. Obrigado.
    terça-feira, 26 de outubro de 2010 16:33
  • Olá Fernando! o problema é que o PROCV eu sei fazer, mas o que eu quero é: suponha que o cliente de cod. 005 tenha 10 linhas de lançamentos, lá na plan1 qdo eu digitar o cod. ou o CNPJ eu quero que me apareça os 10 lançamentos deste cliente. Acho que desta forma com o PROCV não tem como fazer ou tem?
    quarta-feira, 27 de outubro de 2010 00:46
  • Amigos,

    acredito que somente com o Access.


    Gilberto Soares Lopes
    quarta-feira, 3 de novembro de 2010 14:26
    Moderador