none
SP_CONFIGURE retorna somente um número limitado de registros RRS feed

  • Pergunta

  • Prezados, bom dia!

    Ontem me deparei com um problema de lentidão no SQL Server 2005.
    Durante a procura por uma solução, ao executar a sp_configure para saber se os parâmetros de memória mínima e máxima, notei que a mesma retorna apenas 14 registros, não contemplando parâmetros como "max server memory (MB)" e "min server memory (MB)", dentre outros.
    O S.O. do servidor é W2k3 Std SP1 e o SLQ é Std (9.00.1406.00 (Intel X86)   Mar  3 2007).
    Desde já, agradeço pela ajuda.


    Att,
    Joaquim Filho

    • Movido Gustavo Maia Aguiar quarta-feira, 26 de agosto de 2009 13:24 (De:SQL Server - Desenvolvimento Geral)
    quarta-feira, 26 de agosto de 2009 11:51

Respostas

  • Fausto,

    vc esqueceu o reconfigure..

    sp_configure 'show advanced options',1
    reconfigure with override
    go
    sp_configure


    Att.
    Marcelo Fernandes
    MCP, MCDBA, MCSA, MCTS. Se útil, classifique!!!
    • Marcado como Resposta Joaquim Filho quarta-feira, 26 de agosto de 2009 13:07
    quarta-feira, 26 de agosto de 2009 11:57
    Moderador

Todas as Respostas

  • Você precisa "configurar" ele para mostrar as outras opções:

    EXEC sp_configure 'show advanced option', '1';
    GO
    EXEC sp_configure

     



    Tks. Fausto Fiorese Branco DBA - SQL Server 2k5 São Paulo - Brasil * http://dba-sqlserver.blogspot.com/
    quarta-feira, 26 de agosto de 2009 11:54
  • Fausto,

    vc esqueceu o reconfigure..

    sp_configure 'show advanced options',1
    reconfigure with override
    go
    sp_configure


    Att.
    Marcelo Fernandes
    MCP, MCDBA, MCSA, MCTS. Se útil, classifique!!!
    • Marcado como Resposta Joaquim Filho quarta-feira, 26 de agosto de 2009 13:07
    quarta-feira, 26 de agosto de 2009 11:57
    Moderador
  • Verdade..... vlw.


    Tks. Fausto Fiorese Branco DBA - SQL Server 2k5 São Paulo - Brasil * http://dba-sqlserver.blogspot.com/
    quarta-feira, 26 de agosto de 2009 11:59
  • Caros,

    Muitíssimo obrigado pelo auxílio.
    Funcionou fantásticamente.


    Att,
    Joaquim Filho
    quarta-feira, 26 de agosto de 2009 12:48