locked
ISSO É IMPOSSÍVEL MESMO? RRS feed

  • Pergunta

  • Romário RPS Medalhas de usuárioMedalhas de usuárioMedalhas de usuárioMedalhas de usuárioMedalhas de usuário

     
    Você não pode votar na sua própria postagem
    0

    Prezados Amigos,

    Estou em um dilema, já faz uma semana. Pois bem Vamos Lá.

    Copie e cole  no excel o exemplo abaixo, exclua a coluna onde tem os números e a linha que tem as letras.... apenas quis desenhar a planilha de excel para vocês terem ideia de como monstar na planilha.

     

                   A

               B

                  C

    1

     

     

     

    2

    Abril

    Carol

    Função PROCV

    3

    Abril

    Ana

    Função PROCV

    4

    Abril

    Flavia

    Função PROCV

    5

    Maio

    Gustavo

    Função PROCV

    6

    Maio

    André

    Função PROCV

    8

    Maio

    Maicon

    Função PROCV

    9

    Junho

    Deise

    Função PROCV

    10

    junho

    michell

    Função PROCV



    Criei a Função procv da seguinte forma, na linha 2, coluna C : =PROCV($C$1;$A$2:$B$9;2;0) e arrastei até até a linha 10.

    Quando digito a palavra Abril  na linha 1, coluna C, a função procv me trás a palavra Carol, isso se repete em todas as outras linhas que possui a função.

    Como, qual, o se é possível fazer alguma coisa para que o nome não se repita e me traga o próximo registro (Ana)????

    Já tentei não fixar a tabela matriz, mas quando digito a palavra Maio na linha 1, coluna C, repeti a primeira informação (Gustato).

    Será que existe a possibilidade de não repeti a informação da coluna C nas demais linhas??? nem juntando duas funções???

    Tentei fazer por tabela dinâmica, até consegui fazer, porém possuo um arquivo com 2 mil linhas e 30 colunas e o arquivo ficou muito pesado para o tipo de atividade que irei desenvolver.

    Meu e-mail é romario.rps@hotmail.com

     

    Se alguém consegui dá um toque... ou respondo esse post mesmo.


    sexta-feira, 7 de agosto de 2009 16:57

Todas as Respostas

  • Boa noite.

    Segue "Gambi" pois não me preocupei com tratamento de erros, a solução é bem simples, coloque na linha 2, coluna C: =SE(PROCV($C$1;$A2:$B$9;2;0)=B2;B2) e pode arrastar.

    Att,

    Jonathan
    sábado, 8 de agosto de 2009 04:48
  • Sempre vai estar ordenado por mes?? VOCE NAO PODE JOGAR DIRETAMENTE O NOME DA CLUNA C1:=B1 ....Cn:=Bn

    Passe um pouco do uso,

    []'s
    Thiago Cardoso Luiz - MCP W2k3 MCTS http://t-cardoso.blogspot.com/ Caso seja util VOTE e COLOQUE COMO RESPOSTA
    sábado, 8 de agosto de 2009 12:56