none
Problema na replicação entre sites diferentes RRS feed

  • Pergunta

  • Boa tarde a todos,

    Estou com um problema de replicação entre dois sites, estive verificando e constatei que o AD da filial não esta sincronizando.

    Um detalhe que me chamou a atenção foi que ao engressar um usuário no domínio da filial, o servidor AD da matrix recebeu a modificação. Com esta constatação, vejo que o problema esta aqui na minha Matrix, já que quando crio um usuário ou ingresso um equipamento ao domínio ele não sincroniza com a filial.

    Alguem poderia me ajudar a solucionar este problema.

    segunda-feira, 3 de maio de 2010 18:39

Respostas

  • Kadu, bom dia.

     

    Você chegou a verificar o firewall?

    Tem uma grnde possibilidade dele estar bloqueando alguma coisa!

    Monitore os logs e poste aqui se achar algo suspeito.

    • Marcado como Resposta Kadu Leal quinta-feira, 18 de novembro de 2010 11:40
    terça-feira, 4 de maio de 2010 11:22
  • Fabio boa tarde,

    Realmente, por algum motivo meu dns da filial não esta sincronizando.

    Fiz alguns testes com o DNSLint e meu dns da filial não esta autorizado a realizar qualquer consulta no principal.

    Estou realizando alguns testes para ver se soluciono este problema.

     

    abraço.

     

     

    • Marcado como Resposta Richard Juhasz sexta-feira, 14 de maio de 2010 15:14
    quarta-feira, 5 de maio de 2010 20:02

Todas as Respostas

  • Boa tarde.

    Você pode tentar replicar todas as conexões la no "Serviços e sites do Active Directory" manualmente.

    Clique no nome do site, expanda "Servers" depois expanda o nome dos servidores, abra "NTDS Settings", clique com o botão direito no nome das conexões existentes e clique em "Duplicar agora".

    Faça isso em todas as conexões de todos os servidores e veja qual (ou quais) está dando erro e poste aqui.

    Até mais!

    segunda-feira, 3 de maio de 2010 18:48
  • Fabio boa tarde,

     

    Já realizei este procedimento, aqui na matrix ele executa a replicação ao servidor da Filial. Quando executo da filial ele não responde ao servidor da matrix, ele da messangem dizendo que ele não pode responder a chamada.

     

    segunda-feira, 3 de maio de 2010 19:15
  • Fabio,

    Entra no eventviewer nas logs do Directory Service e nos passa os erros que estao sendo apresentados.


    André Fagundes - MCP - MCSA - MCSA + S - MCSE - MCSE + S
    segunda-feira, 3 de maio de 2010 19:24
  • Kadu,

    digite o comando "gpupdate /force" no executar e verifique se no log de eventos de aplicativo deu um dos erros "1030" ou "1058". Se não deu esses erros ele deve apresentar um log com id "1704". faça o teste tanto na matriz quanto na filial.

    Dê uma olhada também nos logs do "serviço de duplicação de arquivos".

    No aguardo!

    segunda-feira, 3 de maio de 2010 19:36
  • Abaixo os erros que estão sendo apresentados:

    Event Id:1311

    Não existem informações suficientes sobre conectividade de site nos Serviços e Sites do Active Directory para que o KCC crie uma topologia de replicação de estrutura estendida. Ou, um ou mais controladores de domínio com essa partição de diretório não podem duplicar as informações sobre partição de diretório. Esse problema está provavelmente relacionado a controladores de domínio inacessíveis.
     
    Ação do Usuário
    Utilize os Serviços e Sites do Active Directory para executar uma das ações a seguir:
    - Publique informações suficientes sobre conectividade de site para que o KCC possa determinar uma rota pela qual essa partição de diretório possa alcançar esse site. Essa é a opção preferencial.
    - Adicione um objeto de Conexão a um controlador de domínio que contenha a partição de diretório nesse site a partir de um controlador de domínio que contenha a mesma partição de diretório em outro site.
     
    Se nenhuma das tarefas dos Serviços e Sites do Active Directory corrigir essa condição, consulte eventos anteriores registrados pelo KCC que identifiquem os controladores de domínio inacessíveis.

    Event Id:1566

    Nenhum dos controladores de domínio no site a seguir que podem duplicar a partição de diretório por este transporte está disponível no momento.
     
    Site:
    CN=BH,CN=Sites,CN=Configuration,DC=documentar,DC=local
    Partição de diretório:
    CN=Configuration,DC=documentar,DC=local
    Transporte:
    CN=IP,CN=Inter-Site Transports,CN=Sites,CN=Configuration,DC=documentar,DC=local

    O verificador de consistência de conhecimento (KCC) detectou problemas com a seguinte partição de diretório.
     
    Partição de diretório:
    CN=Configuration,DC=documentar,DC=local 
     
    Event Id: 1865

    O KCC (Knowledge Consistency Checker) não pôde formar uma topologia de rede de árvore de abrangência completa . Como resultado, a lista de sites a seguir não pode ser acessada do site local.
     
    Sites:
    CN=BH,CN=Sites,CN=Configuration,DC=documentar,DC=local
     

     

    São estes os logs que estão sendo apresentados.

    segunda-feira, 3 de maio de 2010 19:40
  • Fabio,

    Desculpe intrometer-me, mas pelo que percebo este problema esta relacionado a replicação entre os controladores de dominio e não a aplicacao de GPO.

    Continuamos aguardando pelas logs do Directory Services.


    André Fagundes - MCP - MCSA - MCSA + S - MCSE - MCSE + S
    segunda-feira, 3 de maio de 2010 19:40
  • Kadu,

    Recomendo que a partir do controlador de dominio do site BH entre no Active Directory Sites and Services > Site BH > Servers > <Nome do Servidor> > Botao direito em NTDS Settings > All tasks > Check Replication Topology.

    Com este procedimento verifique se sera modificada suas conexoes que estao listadas a direita.

    Abraços,


    André Fagundes - MCP - MCSA - MCSA + S - MCSE - MCSE + S
    segunda-feira, 3 de maio de 2010 19:51
  • Fabio,

     

    Estes logs foram retirados do directory services.

    O problema que estou relatando é replicação entre controladores de domíno, conforme relatado na primeira menssagem.

    Estou a disposição.

     

    segunda-feira, 3 de maio de 2010 19:53
  • André, sem problemas.

     

    Eu só perguntei pra verificar se poderia estar ocorrendo algum outro tipo de problema de replicação. Apenas para ajudar no diagnóstico.

    segunda-feira, 3 de maio de 2010 19:54
  • Kadu, conforme respondi pro André, só queria saber sobre as GPOs pra ver se nao tinha mais algum tipo de problema relacionado a replicação.

    Verifique se a dica do André funciona e poste o resultado.!

     

    Até mais!

    segunda-feira, 3 de maio de 2010 19:59
  • André.

     

    Realizei o procedimento e não notei nenhuma modificação.

    O que pode estar acontecendo, este problema iniciou a alguns dias.

    Havia levantado a ipotese de ser firewall mas após vários testes não constatei problema algum.

    desde já grato.

    segunda-feira, 3 de maio de 2010 20:15
  • Fabio e Andre,

    O que tenho notado é que sempre que realizo alguma mudança em BH o controlador de domínio do RJ não recebe esta modificação.

    Já quando há alguma modificação realizada no RJ é replicada ao servidor de BH.

     

    Atenciosamente.

     

    segunda-feira, 3 de maio de 2010 20:23
  • Kadu,

    Eu tive problemas semelhantes e em alguns casos era realmente o firewall.

    Em um caso exclusivo, alguém atrasou a data de um dos servidores (1 ano atrasado) e quando voltei para a data correta ele parou de replicar alegando que havia passado do tempo limite para replicação ( que é de 180 dias ).

    Eu só consegui fazer a replicação após modificar o registro para que o Windows permitisse a replicação ignorando erros.

    A alteração deve ser feita em todos os DCs que são replicados entre si.

    Se o seu servidor não está sem replicar há muito tempo, você pode fazer a mudança e testar, depois, funcionando ou não, você volta pras configurações padrões.

     

    segue a alteração:

     

    Replicação ignorando erros:

     

    1. Abra o editor de registro (regedit.exe).

    2. Vá para: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters.

    3. Se a entrada "Allow Replication With Divergent and Corrupt Partner" existir, modifique seu valor para "1". Se ela não existir crie-a, ela é um valor "REG_DWORD".

    4. Nome: "Allow Replication With Divergent and Corrupt Partner" .

    5. Valor: "1".

    6. Feche o editor de registro. Não é necessário reiniciar.

     

    Nota: Faça em todos os servidores que replicam entre si.

     

    Teste e veja se a replicação ocorre normalmente.

    Em caso positivo ou negativo, delete a entrada do registro ou modifique o seu valor para "0".

     

    No Aguardo...

    Até mais!

    segunda-feira, 3 de maio de 2010 20:34
  • Fabio,

     

    Mais uma vez o servidor não replicou os objetos.

    e também continua retornando erro no evento.

     

    Atenciosamente.

    segunda-feira, 3 de maio de 2010 21:03
  • Kadu, bom dia.

     

    Você chegou a verificar o firewall?

    Tem uma grnde possibilidade dele estar bloqueando alguma coisa!

    Monitore os logs e poste aqui se achar algo suspeito.

    • Marcado como Resposta Kadu Leal quinta-feira, 18 de novembro de 2010 11:40
    terça-feira, 4 de maio de 2010 11:22
  • Fabio boa noite.

     

    Hoje não consegui verificar, mas acontece que  o servidor da filial não esta conseguindo acessar nenhum compartilhamento na matrix.

    Verifiquei que da matrix estou conseguindo acessar os compartilhamento, acessando as pastas! já da filial não tenho o mesmo sucesso!

    Mas o mais engraçado é que do servidor da Matrix, ao realizar alguma ação ele não replica para a filial, exemplo: criei um usuário e ele não sincronizou o objeto.

    já se realizo a operação inversa, consigo verificar o usuário, se configuro usuário da filial para matrix é aplicado ao AD.

    Tem alguma ideia do que pode estar ocorrendo?

     

    Abraço;

     

    quarta-feira, 5 de maio de 2010 02:27
  • Bom dia amigo,

    já tive esse problema, e no meu caso, a falha era na resolução de nomes na árvore DNS do domínio.

    Ambos os controladores de domínio compartilham a mesma base DNS? As entradas e ponteiros (SRV e demais) indicando a topologia dos controladores de domínio estão criados corretamente no DNS Server? Dá uma confirmada nisso.

    Att,


    Fabiano Barreira

    MCP + MCDST + MCSA on Windows Server 2003 + MCTS + MCITP
    quarta-feira, 5 de maio de 2010 10:26
  • Fabio boa tarde,

    Realmente, por algum motivo meu dns da filial não esta sincronizando.

    Fiz alguns testes com o DNSLint e meu dns da filial não esta autorizado a realizar qualquer consulta no principal.

    Estou realizando alguns testes para ver se soluciono este problema.

     

    abraço.

     

     

    • Marcado como Resposta Richard Juhasz sexta-feira, 14 de maio de 2010 15:14
    quarta-feira, 5 de maio de 2010 20:02
  • Olá kadu.

    Você tem alguma novidade sobre o problema?

     

    Abraço.

     


    Richard Juhasz
    terça-feira, 11 de maio de 2010 16:01
  • Pessoal, 

     

    Após vários teste, detectei o erro!

     

    O firewall estava barrando a comunicação entre sites.

     

    Obrigado pelo retorno! 

     

    Se puder ajudar em alguma coisa, estarei a disposição!

    Kadu Leal

    MCP - Itil Foundation

    quinta-feira, 18 de novembro de 2010 11:39