locked
Analysis Server RRS feed

  • Pergunta

  • Tenho uma aplicação asp.net e estou conectando ao  Analysis Server 2000 , no momento em que vou criar um cubo através da instrução SQL, ocorre um erro dizendo que o meu banco de dados não existe. Na verdade o problema esta no fato que eu só consigo me conectar ao Analysis server com o usuário (nome_comp)\ASPNET e para minha aplicação deveria ser conectado pelo usuário que esta logado na máquina, sendo que já estou utilizando o windows authentication e

    <identity impersonate="true" />

    ...

    Alguem tem alguma idéia de como contornar essa situação ??

    sexta-feira, 22 de junho de 2007 12:47

Todas as Respostas

  •  

     

     crie um grupo no seu ad coloque os usuarios que precisam acessar neste grupo e de direitos a este grupo dento do AS

     

    Abs;

    sexta-feira, 22 de junho de 2007 17:23
  • Thiago,

     

    Estes usuários estão fazem parte de um domínio?

    sexta-feira, 22 de junho de 2007 18:02
    Moderador
  • Então Marcelo,

     

    no AS já estou dando permissão ao usuário q estava logado na máquina, porém não consegue se conectar ao AS. Porém quando coloco no AS o usuário ASPNET, ai consigo me conectar..Penso que talvez seja incompatibilidade entre o AS2000  e o IIS5.1 ....

    segunda-feira, 25 de junho de 2007 11:58
  • Olá Junior,

     

    os usuários fazem parte do domínio da empresa, sendo que é administrador da máquina....

    segunda-feira, 25 de junho de 2007 12:01
  • Thiago,

     

    Se você utiliza o IIS 5 ele tem uma conta local do servidor com o nome de ASPNET, onde ele utiliza esta para executar o processo aspnet_wp.exe que é onde fica a execução de todos os códigos .net no servidor web.

     

    Tente alterar o site/diretório virtual pra utilizar Windows Authentication;

    Coloque na conexão com o AS a opção de Impersonate.

     

    Vou procurar mais informações e ver como você pode alterar isso e te informo assim que tiver alguma dica.

     

    Espero ter ajudado.

     

    Abraços,

    quarta-feira, 27 de junho de 2007 20:08
  •  Rodrigo Fernandes wrote:

    Thiago,

     

    Se você utiliza o IIS 5 ele tem uma conta local do servidor com o nome de ASPNET, onde ele utiliza esta para executar o processo aspnet_wp.exe que é onde fica a execução de todos os códigos .net no servidor web.

     

    Tente alterar o site/diretório virtual pra utilizar Windows Authentication;

    Coloque na conexão com o AS a opção de Impersonate.

     

    Vou procurar mais informações e ver como você pode alterar isso e te informo assim que tiver alguma dica.

     

    Espero ter ajudado.

     

    Abraços,

     

    Thiago, verifique também se existe alguma opção no machine.config do .Net, porém cuidado pois qualquer alteração afeta todo o seu ambiente.

    quarta-feira, 27 de junho de 2007 20:29