none
Problema com Relay do Exchange 2007 RRS feed

  • Discussão Geral

  • Prezados bom dia,

    Estou com um segunte problema no Exchange 07, tenho uma página da Web desenvolvida de Asp no qual tem um formulário de cadastro.

    Portanto adicionamos endereçamento do servidor e um usuário para autenticação ele não funciona..
    Abraços
    Everton


    Microsoft Certified Systems Engineer Security
    quinta-feira, 24 de setembro de 2009 12:19

Todas as Respostas

  • Veja o link abaixo, deve ajudar:

    http://www.andersonpatricio.org/Tutoriais/Tutoriais.asp?tut=884



    Abraço!

    Diego Wachholz - MCSA/MCTS - Microsoft Exchange Server 2007
    quinta-feira, 24 de setembro de 2009 12:30
  • Diego bom dia,

    Neste caso para uma página de web externo ? este relay é para aplicações internas ou não ?



    Portanto eu tenho esta seguinte linha de programação do meu site..... existe algo no Exchange para q quando eu faço um cadastro de formulário eu consiga receber os mesmos ?

    Set objConfig = Server.CreateObject("CDO.Configuration")

        Set Fields = objConfig.Fields

     

        With Fields

          .Item("http://schemas.microsoft.com/cdo/configuration/sendusing") = 2

          .Item("http://schemas.microsoft.com/cdo/configuration/smtpserver") = "IP do Servidor "

     

          .Item("http://schemas.microsoft.com/cdo/configuration/smtpauthenticate") = 1  

          .Item("http://schemas.microsoft.com/cdo/configuration/sendusername") = "usuário"

          .Item("http://schemas.microsoft.com/cdo/configuration/sendpassword") = "senha"

     

          .Update

        End With

     

        Set objMailer = Server.CreateObject("CDO.Message")

        Set objMailer.Configuration = objConfig

     

        objMailer.To = "grupo de distribuição"

        objMailer.Bcc = "grupo de distribuição"

        objMailer.From = "grupo de distribuição"

        objMailer.Subject = "Cadastro Microsoft"

        objMailer.HTMLBody = conteudo

        objMailer.Send

     

        Set objMailer = Nothing




    abs
    Everton
    Microsoft Certified Systems Engineer Security
    quinta-feira, 24 de setembro de 2009 12:38
  • Ola Everton,

    FAca um teste com o cliente, se funcionar logo o problema/configuracao a ser mudada é o código. Te aconselho a postar no forum de MSDN sobre isso.
    Grande abraço,
    Anderson Patricio

    Exchange and OCS resource site:http://www.andersonpatricio.org
    Blog (BR): http://blog.andersonpatricio.org
    MSExchange Blog: http://blogs.msexchange.org/patricio
    Blog (EN): http://msmvps.org/blogs/andersonpatricio
    Twitter: http://twitter.com/apatricio

    Quer aprender sobre Exchange Server 2007? Em breve treinamento online com os MVP´s... Detalhes aqui: http://www.andersonpatricio.org/training - Aguarde!

    quinta-feira, 24 de setembro de 2009 13:45
  • Anderson bom dia,

    Eu fiz um teste com o mesmo script criado em outro webserver, no qual ele apresenta um erro de permissão.... tu tens noção de qual permissão preciso colocar para q o Script funcione ?


    Att,
    Everton
    Microsoft Certified Systems Engineer Security
    terça-feira, 29 de setembro de 2009 14:25
  • No link que o Diego te mandou tem o processo.
    Grande abraço,
    Anderson Patricio

    Exchange and OCS resource site:http://www.andersonpatricio.org
    Blog (BR): http://blog.andersonpatricio.org
    MSExchange Blog: http://blogs.msexchange.org/patricio
    Blog (EN): http://msmvps.org/blogs/andersonpatricio
    Twitter: http://twitter.com/apatricio

    Quer aprender sobre Exchange Server 2007? Em breve treinamento online com os MVP´s... Detalhes aqui: http://www.andersonpatricio.org/training - Aguarde!

    terça-feira, 29 de setembro de 2009 14:42