none
Problema em plano de manutençao do SQL Server RRS feed

  • Pergunta

  • Bom dia pessoal,

    Estou com um problema no meu SQL Server 2008 R2 em um servidor,

    eu criei um plano de manutenção para fazer a limpeza de backups antigos, mas a execução dá como finalizado com sucesso mas não exclui nem arquivo.

    Se eu faço esse mesmo plano de manutenção em outro SQL Server no outro servidor, funciona normalmente.

    Mas esse problema ocorreu depois que ao instalar uma nova base de dados, o script de instalação desativou a autenticação do windows. Reativamos a autenticação do windows, mas começou a acontecer problemas como esse.

    Alguém sabe como resolver?

    Desde já agradeço.

    quarta-feira, 22 de outubro de 2014 13:41

Respostas

  • Danilo,

    Eu já tive problemas como este nos pacotes SSIS do SQL Server 2008 e em alguns Planos de Manutenção.

    Isto acontece muito quando um Plano de Manutenção é copiado para outra instância SQL ou quando à mudanças nas configurações de conexões (usuário, senha, ...). 

    Comigo, em alguns casos bastou excluir o objeto de conexão com a instância/banco de dados e criar novamente (refazendo o "bind" para cada Task com nova conexão).

    Se ajudou na sua solução, não esqueça de marcar como resposta !

    Abraços,

    Durval Ramos
    Microsoft Partner | MTA | MCSA - SQL Server 2012 | MCSE - Data Platform
    ----------------------------------
    Se foi resolvido clique "Marcar como resposta" e se foi útil "Votar como Útil"

    • Marcado como Resposta danilo_gouveia quinta-feira, 23 de outubro de 2014 11:41
    quarta-feira, 22 de outubro de 2014 18:06

Todas as Respostas

  • Dê uma olhada nestas opções:

    http://www.bradleyschacht.com/sql-maintenance-plan-doesnt-delete-backups/

    http://stackoverflow.com/questions/5327282/sql-maintenance-cleanup-task-working-but-not-deleting

    Marque como resposta se foi útil!

    • Sugerido como Resposta Deric Ferreira quarta-feira, 22 de outubro de 2014 13:43
    quarta-feira, 22 de outubro de 2014 13:43
  • Bom dia Danilo,

    Já passei por esse problema, verifique no Maintenance Cleanup Task se o 'File Extension' está como 'bak' e não como '.bak'.

    O plano de execução no outro servidor está idêntico?


    Att, Bruno Silva.

    quarta-feira, 22 de outubro de 2014 15:32
  • Deric já tinha tentado o 1 passo, e também pelo script não funciona.
    quarta-feira, 22 de outubro de 2014 16:15
  • Danilo,

    Eu já tive problemas como este nos pacotes SSIS do SQL Server 2008 e em alguns Planos de Manutenção.

    Isto acontece muito quando um Plano de Manutenção é copiado para outra instância SQL ou quando à mudanças nas configurações de conexões (usuário, senha, ...). 

    Comigo, em alguns casos bastou excluir o objeto de conexão com a instância/banco de dados e criar novamente (refazendo o "bind" para cada Task com nova conexão).

    Se ajudou na sua solução, não esqueça de marcar como resposta !

    Abraços,

    Durval Ramos
    Microsoft Partner | MTA | MCSA - SQL Server 2012 | MCSE - Data Platform
    ----------------------------------
    Se foi resolvido clique "Marcar como resposta" e se foi útil "Votar como Útil"

    • Marcado como Resposta danilo_gouveia quinta-feira, 23 de outubro de 2014 11:41
    quarta-feira, 22 de outubro de 2014 18:06
  • Boa tarde Bruno,

    eu fiz esse teste também mas não funcionou.

    quarta-feira, 22 de outubro de 2014 20:05
  • Valeu Durval,

    funcionou aqui.

    quinta-feira, 23 de outubro de 2014 11:42