none
Problemas com o horário de verão RRS feed

  • Pergunta

  • Pessoal,

    Estou com o seguinte problema:

    As estações estão com o Windows XP SP3 e com o update KB2570791 referente ao horário de verão 2011-2012. Inicialmente os usuários não possuíam a permissão de alterar o horário das estações, somente os Administradores do domínio. Verifiquei que as estações não alteraram o horário de verão devido a opção ajustar automaticamente o relógio para horário de verão estar desmarcada. Criei uma GPO que cria a chave do registro DisableAutoDaylightTimeSet=0 que habilita esta opção e executei um Gpupdate, no entanto mesmo com esta opção habilitada as estações permaceram com o mesmo horário. Fiz testes executando os comandos de net time /domain, w32tm, etc, mas não resolveu, verifiquei que o horário somente é alterado quando eu entro nas configurações de horário, verifico que a opção ajustar automaticamente o relógio para horário de verão está marcada e seleciono OK, aí sim a estação assume o novo horário. Fiz testes com a conta de administração do domínio e habilitei para que os usuários possam alterar o horário, mas o problema permanece.

    Grato

    terça-feira, 18 de outubro de 2011 11:56

Todas as Respostas

  • Luiz,

    A Microsoft já disponibilizou alguns procedimentos para o ajuste correto dos horários em computadores domésticos e corporativos, descritos no seguinte site:

    http://windows.microsoft.com/pt-BR/windows/help/horariodeverao



    Leonardo Côco .:. MCP / MCDST / MCTS / MCSA / ITILF .:. Se a resposta foi útil classifique-a.
    terça-feira, 18 de outubro de 2011 14:05
  • Leonardo,

    Em relação aos procedimentos, sem problemas, o fato é que as estações não estavam com a opção de ajustar automaticamente o relógio para horário de verão habilitado, eu habilitei por GPO, mas vamos dizer assim, a opção é habilitada, mas não é ativada, somente quando eu entro nas configurações de hora e verifico que está marcada e pressiono OK é que o Windows corrige o horário.

    Att, 

     

    terça-feira, 18 de outubro de 2011 15:53
  • Oi Luis,

    Estou exatamente com o mesmo problema. Fiz os testes, o checkbox fica marcado mas a opção não é ativada. Se tiver sucessu nessa tarefa por favor poste aqui no Forum.

    Muito Obrigado,


    Luiz Arthur Chagas
    quarta-feira, 19 de outubro de 2011 14:11
  • Boa tarde

    Primeiro ajuste a hora do seu servidor: Desmarque a opção : Ajustar automaticamente para o horário de verão

    Agora, Faça uma GPO com 2 scripts

     

    O primeiro em .bat

    net time \\nome_do_seu_servidor /set /yes

    No segundo, faça um script de registro que desabilite a opção : Ajustar automaticamente para o horário de verão

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
    "Bias"=dword:000000b4
    "StandardName"="Hora oficial do Brasil"
    "StandardBias"=dword:00000000
    "StandardStart"=hex:00,00,02,00,02,00,02,00,00,00,00,00,00,00,00,00
    "DaylightName"="Hora oficial do Brasil"
    "DaylightBias"=dword:00000000
    "DaylightStart"=hex:00,00,02,00,02,00,02,00,00,00,00,00,00,00,00,00
    "ActiveTimeBias"=dword:000000b4
    "DisableAutoDaylightTimeSet"=dword:00000001

     

    A ultima linha diz se a opção é pra estar marcada ou não.

     

    Espero ter ajudado. Se util classifique

     

    Att

    Willian Knippelberg

    quinta-feira, 20 de outubro de 2011 17:23
  • Detalhe que o segundo Script é .VBS
    quinta-feira, 20 de outubro de 2011 17:24
  • Olá ,

    alguma novidade?

    Abraços,

     


    Flavio Honda - http://flaviohonda.wordpress.com
    segunda-feira, 24 de outubro de 2011 12:32
    Moderador
  • Bom dia,

    Amigo, entendi sua ideia... porém essescript não está funcionando...

    Poderia me ajudar detalhando melhor ?

     

    Continuo com o problema... :(

     

    Obrigado

    terça-feira, 25 de outubro de 2011 12:35