none
MIM 2016 issue

    Pergunta

  • Hello,

    I´ve got solution deployed at customer, where HR (SQL 2008 R2 database) manage accounts in AD. Sync flow is HR (SQL) -> MIM -> AD. MIM 2016 version: 4.4.1237.0. Only MIM synchronization service is used with custom VB code for customized provisioning. MIM anchor: attribute called EmployeeID.

    Two MA -one for HR (SQL), second one AD obviously for AD. Order & run of MA:

    HR MA Full Import
    HR MA Full Synchronization
    AD MA Export
    AD MA Full Import
    AD MA Full Synchronization
    HR MA Export

    Some updates in the SQL structure have been done time ago. I run Schema Update on HR MA to get latest columns/data from SQL database.

    I´m getting error message on HR MA Full Import:
    Status: failed-connection
    Error: column-list-reordering
    Error code: 0x80004005

    Eventlog error IDs: 6401 & 6005

    Also notified that many objects are disconnected and could not find the match in Metaverse. In the metaverse 90% of objects have got only AD MA Connetor visible, that means the connection between Metaverse and AD is established, but not with SQL database!

    Question 1: How to get it back (link on the EmployeeID in between SQL and AD in Metaverse)?

    Question 2: Is the issue connected to the changed structure of SQL database or is it a MIM bug? -> Update to the lastest version will fix it? Can the issue be caused by the invalid or updated data type in SQL?

    Thanks in advance.


    Petr Weiner









    • Editado Petr Weiner terça-feira, 15 de maio de 2018 09:35
    terça-feira, 15 de maio de 2018 09:02

Todas as Respostas


  • I did update of .NET and Metaverse looked good for few syncs. Same problem again now. In the App.log getting:

    ID 6401 

    The management agent controller encountered an unexpected error.

     "ERR_: MMS(1256): ..\libutils.cpp(10186): Failed to start run because of undiagnosed MA error
    Forefront Identity Manager 4.4.1237.0"

    ID 6005:

    The management agent "HR MA" failed on run profile "HR MA Full Import (Stage only)" because of an unspecified management agent error.
     Additional Information
     
     %3

    I did uninstall of latest Win.updates and starts working or 6 automatic schedules and then it revert back in to the hell... 

    Petr Weiner







    • Editado Petr Weiner terça-feira, 15 de maio de 2018 13:49
    terça-feira, 15 de maio de 2018 10:17
  • Hi Petr,

    Question 1: How to get it back (link on the EmployeeID in between SQL and AD in Metaverse)?

    - Do you see these objects in Connector Space (right click on MA, Search CS)?

    Question 2: Is the issue connected to the changed structure of SQL database or is it a MIM bug? -> Update to the lastest version will fix it? Can the issue be caused by the invalid or updated data type in SQL?

    - Looks like SQL DB problem.


    Emil Valiev


    • Editado Emil Valiev terça-feira, 15 de maio de 2018 13:06
    terça-feira, 15 de maio de 2018 13:06
  • Hello Emil thanks for your reply.

    Add 1/ Yes I doo see about 419 users there now (should be about 7500). It changes each time. At some point I get all records in metaverse. 

    Add 2/ SQL server backend where databases are store is running SQL 2008 R2 version 10.50.6542.0
    MIM is using SQL Native clients 2008R2 (updated from 10.50.1600.1 to 10.51.2500.0) and 2012 on version 11.3.6518.0

    Issue still persist. I got a tip to check if the anchor´s data type in SQL did not changed, but it is still same data type (varchar50).

    Last attempt will be to upgrade to the lastest MIM version tomorrow. I will investigate more on this topic.

    Thank you.


    Petr Weiner

    quarta-feira, 16 de maio de 2018 09:35
  • I tried to reconfigure  SQL MA on Configure Externsions to "Run this rules extension in a separate process", but does not work either.

    Petr Weiner

    quinta-feira, 17 de maio de 2018 09:33
  • Probably you can resolve the issue with the next method. Attention! These actions may corrupt your MA.

    1. Save MA - right-click, Export Management Agent.

    2. Open saved xml file. Look for 

    <schema>some text here</schema>

    Check this block and modify if needed.

    3. Delete old MA.

    4. Create new MA - Import Management Agent, select saved file.


    Emil Valiev

    quinta-feira, 17 de maio de 2018 09:47
  • It does not look it needs some modification...

    Petr Weiner

    sexta-feira, 18 de maio de 2018 08:52
  • I have not worked with SQL MA but I guess you should re-create SQL MA.

    Emil Valiev

    quinta-feira, 31 de maio de 2018 13:02
  • I will try to backup & load the SQL agent again next week and let you know.

    Thank you


    Petr Weiner


    • Editado Petr Weiner quinta-feira, 31 de maio de 2018 13:04
    quinta-feira, 31 de maio de 2018 13:04
  • I would like to recreate SQL management agent, which option to use?

    Delete connetor space only

    OR

    Delete managmeent agent and connector space

    I have got available also exported configuration (File - Export Server Configuration), would be enough to load that configuration only? It does rewrite the configuration, does it make sense to do it this way? It means no impact for the Connector Space.


    Petr Weiner

    quinta-feira, 21 de junho de 2018 10:40
  • I did delete & create SQL MA, did not resolve my issue. Note I tried to load MA and as this did not help, tried also to create MA manually according the documentation. Even that, still issue. Pointing me to the fact it might be SQL related.

    https://social.technet.microsoft.com/wiki/contents/articles/4191.fim-2010-how-to-delete-management-agent-and-connector-space.aspx

    Thinking about updating MIM to the latest version.


    Petr Weiner


    • Editado Petr Weiner sábado, 1 de setembro de 2018 10:48
    sábado, 1 de setembro de 2018 07:41
  • I did a backup of SQL DB and restore it on another SQL (2008 R2) and it works well. No issue with SQL Management Agent.

    Looks it´s related to the version of SQL server or the database itself (that is my quess). I will monitor next days to confirm the premise.


    Petr Weiner


    • Editado Petr Weiner terça-feira, 11 de setembro de 2018 14:17
    sábado, 1 de setembro de 2018 14:08