none
Exportar e Importar com o LDIFDE RRS feed

  • Pergunta

  • Estou com uma demanda de ajustar alguns campos de meus users no AD [Windows 2003], criei uma OU de teste e criei um user lá, estou utilizando o LDIFDE para exportar, alterar os campos e importar.

    Seguem os comandos export:
    ldifde -f users.csv -d "OU=TESTE,OU=dominio user,DC=dominio,DC=com,DC=br"

    Estou abrindo o arquivo no EXCEL, o estranho que ele não abre de forma organizada por mais que eu tabule, ele fica tudo em uma coluna, bem fiz a alteração e ao importar;

    Comando de importação:

    LDIFDE -i -f users.csv

    Apresenta o erro

    Connecting to "server.vonpar.com.br"

    Logging in as current user using SSPI

    Importing directory from file "users.csv"

    Loading entries.

    Add error on line 1: Invalid Syntax

    The server side error is "The parameter is incorrect."

    There is a syntax error in the input file

    Failed on line 36.  The last token starts with 'S'.

    0 entries modified successfully.

    An error has occurred in the program

    No log files were written.  In order to generate a log file, please

    specify the log file path via the -j option.

    Alguém pode me ajudar ??

     

    Abraço

     

    quarta-feira, 29 de junho de 2011 18:10

Respostas

  • Boa tarde.

    Tente o seguinte comando:

    ldifde -f users.csv -d "cn=TESTE,cn=dominio user,DC=dominio,DC=com,DC=br"

    Abraço.


    Se útil, classifique.
    Matheus M. Bertuco
    MCT, MCSA, MCTS, MCP.
    http://matheusbertuco.wordpress.com/

    quarta-feira, 29 de junho de 2011 19:13
    Moderador
  • Cassio,

    o arquivo input.csv está dentro de c:\ ?

     

    Se caso não tiver vai dar erro mesmo, pois vc está executando o LDIFDE dentro do c:\... o que voce pode fazer é colocar o path inteiro do arquivo .csv

     

    Conheça mais sobre o LDIFDE: http://support.microsoft.com/kb/237677/pt-br

     

    []s


    Erick Albuquerque | Moderador Fórum Technet
    Blog: http://erickalbuquerque.com.br |
    Artigos IIS: http://iisbrasil.wordpress.com
    Twitter: @_ealbuquerque
    Linkedin: http://br.linkedin.com/in/easantos
    segunda-feira, 4 de julho de 2011 16:22
    Moderador

Todas as Respostas

  • Boa tarde.

    Tente o seguinte comando:

    ldifde -f users.csv -d "cn=TESTE,cn=dominio user,DC=dominio,DC=com,DC=br"

    Abraço.


    Se útil, classifique.
    Matheus M. Bertuco
    MCT, MCSA, MCTS, MCP.
    http://matheusbertuco.wordpress.com/

    quarta-feira, 29 de junho de 2011 19:13
    Moderador
  • Alterei para exportar somente o user, mas na hora de importar apresenta o erro:

     

    C:\>LDIFDE -i -f input.csv

    Connecting to "server.vonpar.com.br"

    Logging in as current user using SSPI

    Importing directory from file "input.csv"

    Loading entries.

    Add error on line 1: Invalid DN Syntax

    The server side error is "The parameter is incorrect."

    0 entries modified successfully.

    An error has occurred in the program

    No log files were written.  In order to generate a log file, please

    specify the log file path via the -j option.

    Na primeira linha esta assim:
    dn: CN = teste.gpo, OU = TESTE, OU = Vonpar Users, DC = vonpar, DC = com, DC = br

     

     


    quarta-feira, 29 de junho de 2011 21:04
  • Cassio,

    o arquivo input.csv está dentro de c:\ ?

     

    Se caso não tiver vai dar erro mesmo, pois vc está executando o LDIFDE dentro do c:\... o que voce pode fazer é colocar o path inteiro do arquivo .csv

     

    Conheça mais sobre o LDIFDE: http://support.microsoft.com/kb/237677/pt-br

     

    []s


    Erick Albuquerque | Moderador Fórum Technet
    Blog: http://erickalbuquerque.com.br |
    Artigos IIS: http://iisbrasil.wordpress.com
    Twitter: @_ealbuquerque
    Linkedin: http://br.linkedin.com/in/easantos
    segunda-feira, 4 de julho de 2011 16:22
    Moderador
  • Olá Cassio.

    Alguma novidade sobre o problema?

     

    Abraço.

     


    Richard Juhasz - Microsoft LATAM Forum Support Engineer
    http://www.forumguys.com.br
    quarta-feira, 6 de julho de 2011 17:29
  • Hoje vou testar, estou de mudança de CPD e esta fod....

     

    Abraço

    sexta-feira, 8 de julho de 2011 12:21