none
MSDE em rede Mista... RRS feed

  • Pergunta

  • olá pessoa...

    tenhu um sistema que roda em rede...

    porém instalo tanto Sistema/Msde localmente e só aponto pro banco de dados no servidor...

    fiz varios testes aki na empresa.. desde win 98 até o 2003.. e nada deu errado...

    claro que qndo chego no cliente .. não funcionou...

     

    bem.. ele tinha lá uma rede com autenticação Novell.. mas tinha rede windows tbem...

    instalei tudo normal.. e localmente funcionou.. mas qndo fui rodar da maquinas "clientes" não rodou...

    dava o erro: " Sql Server não existe ou o acesso foi negado"

    ai tenteni puxar um atalho do sistema para os clientes e deu o mesmo erro...

    como eu faço pra configurar a rede nesse caso...

     

    desde já agradeço..

    quinta-feira, 8 de fevereiro de 2007 12:24

Respostas

Todas as Respostas

  • no client utilities vc. deve habilitar o multprotocol, como vc. esta usando o msde vc. vai ter que fazer isso via codigo. outro ponto e que se vc. instalou o msde no windows 2003 pode ser que somente esteja faltando o service pack ( para usar o sql no windows 2003 vc. precisa pelo menos o service pack 3 ). veja ai primeiro o tema do sql no windows se nao for o caso retorne.

     

    Abs;

    quinta-feira, 8 de fevereiro de 2007 12:34
  • Olá Marcelo...

     

    entaum.. eu testei com o windows 2003.. mas funcionou normal..

    como no cliente é tudo Xp.. tô usando o Msde com sp4...

    entuam.. eu creio que o problema não é windows...

    e sim a configuração de rede...

    como eu faço pra poder habilitar esse multiprotocol..(tanto via código, qnto pelo Enterprise(se é que dá pra fazer por ele..rs)) se vc puder ajudar..

     

    agradeço...

    Abraços

    quinta-feira, 8 de fevereiro de 2007 12:47
  • se vc. tem as ferramentas melhor  vc. pode usar o server network utility e o client network utility para isso.

     

    Abs;

    quinta-feira, 8 de fevereiro de 2007 13:10
  • via ferramenta é só adicionar o Multiprotocol?

    colocando ele em enabled protocols....

     

    mas como faço issu via código..??????

    pq no cliente .. não tem como eu usar a ferramenta..

    se puder me passar fico grato....

    abraços

    quinta-feira, 8 de fevereiro de 2007 13:27
  • quinta-feira, 8 de fevereiro de 2007 16:26
  • TBueno,

    Esta sua rede Novell foi removida?

    Nas máquinas clientes também foi removido os protocolo IPX/SPX que eram utilizados pela Novell?

     

    sexta-feira, 9 de fevereiro de 2007 09:58
    Moderador
  • Olá Junior...

     

    Entaum.. não foi removido não...

    na realidade ele usa até hj a rede Novell..

     

    hum.. eu creio que não.. eu creio que esse protocolo esteje sendo utilizado até.. hj...

     

    issu pode interferir em algo?

     

    grato

    sexta-feira, 9 de fevereiro de 2007 11:21
  • TBueno,

    Com certeza, além de gerar lentidão, pode fazer com que o seu client SQL Server pare de trabalhar.

    sexta-feira, 9 de fevereiro de 2007 12:02
    Moderador
  • olá...

    e tem como por exemplo.. eu tentar burlar issu...

    já que eles tem uma rede Windows rodando por tras?

     

    grato...

    sexta-feira, 9 de fevereiro de 2007 12:18
  • TBueno,

    O que você pode fazer é nas estações configurar o protocolo TCP/IP como padrão das conexões.

    sexta-feira, 9 de fevereiro de 2007 12:36
    Moderador
  • mas issu só do Sql.. né?

    não vai interferir no desempenho da rede do cara.. né?

    eu tentei acessar o Sql de uma maquina para outra via Ip... e não deu certo....

     

    como eu posso fazer essa configuração pra dexar o Protocolo TCP/IP como padrão?

     

    abraços.

    Grato

     

    sexta-feira, 9 de fevereiro de 2007 12:59
  •  

     nao nao vai interferir na rede dele nao, sao configuracoes de rede do sql server.

     

    Abs/;

    terça-feira, 13 de fevereiro de 2007 09:25
  • Olá pessoal,eu estava na net pesquisando como já iniciar o windows com o MSDE apontando para o banco principal quando vi a dúvida de vcs aqui.
    Faça o seguinte : Compreendi que vc está sendo negado no acesso ao banco principal quando aponta na estação.Então a solução é vc anular a senha do banco local da estação,ai vc loga e depois aponta para o banco principal,tive um problema bem parecido.Vou lhe dar um exemplo.

    Abra o promt de comando :

    osql -S -U sa
    TESTE
    1>sp_password null,null,'sa'
    2>go


    sa é o login do seu banco
    TESTE é o usuário do seu software
    1> Vc estará anulando a senha
    2> Estará finalizando a operação.


    OBS : Esse login e usuário,vai ter que entrar em contato com o suporte do software que está trabalhando para conseguir fazer essa operação,só dei um exemplo acima.


    Abraço,qualquer coisa entrem em contato.
    quarta-feira, 18 de julho de 2007 13:43
  • Conectei o Sistema diretamente e funcionou.


    Valeu Galera,
    Thiago Bueno
    Thiago Bueno
    terça-feira, 16 de junho de 2009 14:56